Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Disable Anonymous LDAP Browse

  1. #11
    Himanshu is offline Advanced Member
    Join Date
    Jan 2008
    Posts
    223
    Rep Power
    7

    Default

    How does one make zimbra ldap to return authenticated search.. What username , password & syntax should be used
    in context to outlook 2007..? As I have a new install of current versio which does not return any results & old install which was upgraded to current version returns results as anonymous query is allowed.

  2. #12
    ewilen's Avatar
    ewilen is offline Moderator
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    Disable Anonymous LDAP Browse tells how you can modify your new install to allow anonymous queries.

    I assume username and password for authentication are <email address> and <email password> respectively. You'll want to use secure LDAP to prevent those credentials from being sniffed.

    Outlook-specific information: http://office.microsoft.com/en-us/ou...101611033.aspx

    I haven't tested these instructions but I hope they help.

  3. #13
    ewilen's Avatar
    ewilen is offline Moderator
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    Now I'm trying to set this up myself using Mac Address Book as an LDAP client.

    It's always been fine using anonymous LDAP but now that we're on GnR I'd like to use secure authenticated LDAP and open up the firewall.

    But do I have to turn off anonymous LDAP in order to allow clients to authenticate?

    It seems if I turn off anonymous LDAP, port 389 stays open on zimbra and port 636 stays closed. (Based on nmap.) I'm guessing that TLS is available, but I'm not sure that's compatible with Address Book even if I turn on SSL and then manually change the port from 636 to 389.

    The best I seem to be able to do is leave SSL turned off and enter my username@domain, password credentials in Address Book preferences. The lookups don't work but at least the error I get in the Mac console is

    3/25/10 5:41:36 PM Address Book[3426] [zimbra] Could not bind to server: Invalid DN syntax (ID 34)

    instead of a password error or

    3/25/10 6:04:27 PM Address Book[3426] [zimbra] Could not bind to server: Can't contact LDAP server (ID -1).

    Anyone else had any success in this area? I guess I'll try Apache Directory Studio tomorrow.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. upgrading from 5.0.4 to 5.0.5 opensource
    By smoke in forum Installation
    Replies: 4
    Last Post: 10-19-2008, 10:38 AM
  2. Replies: 8
    Last Post: 08-07-2008, 05:18 AM
  3. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  4. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  5. disable anonymous LDAP access
    By sasha in forum Administrators
    Replies: 10
    Last Post: 02-19-2007, 04:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •