Results 1 to 3 of 3

Thread: alias an entire domain to one user

  1. #1
    sgcowgill is offline Intermediate Member
    Join Date
    Dec 2005
    Posts
    17
    Rep Power
    9

    Default alias an entire domain to one user

    Ok...I have strange setup I am attempting to migrate over and I wondered if I am missing an easy solution.

    Old server setup (at least for this one domain)

    Fedora running Sendmail. Using the virtusertable any mail addressed to a particular domain is redirected to a single shell account. The remote client at the other end uses fetchmail to pull the mail down and then he distributes it to individual users at his end.

    So in the virtusertable I have the following:

    @sampledomain.com sampleuser

    So mail sent to joe@sampledomain.com or pete@sampledomain.com or kevin@sampledomain.com all gets routed to the one mailbox. Then once he fetches it he redistributes it at the other end by the real e-mail address. The clients want to keep this setup.

    The only way I can see to do this is to create a single user, sampleuser@sampledomain.com, with a bunch of aliases. So joe@sampledomain.com and pete@sampledomain.com would be aliases for the sampleuser@sampledomain.com. I can see no way to do the equivalent of a virtusertable and effectively alias an entire domain to one user. Am I just missing something or is this in fact not doable.

    Not a huge deal, just creates a tiny bit more administrative overhead to create the aliases whenever user is added or deleted.

    Thanks

    Steve

  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Catchall is what your looking for:

    Installation error
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    sgcowgill is offline Intermediate Member
    Join Date
    Dec 2005
    Posts
    17
    Rep Power
    9

    Default

    Kevin,

    Thanks much as always for the help. That was exactly what I needed. I just did not know the right name so my searches kept coming up empty.

    You guys are the best.

    Steve

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  3. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 10:34 PM
  4. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 09:19 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •