Results 1 to 4 of 4

Thread: RFC: Zimbra generates In-Reply-To incorrectly?

  1. #1
    Baylink is offline Elite Member
    Join Date
    Aug 2008
    Location
    St Pete FL USA
    Posts
    392
    Rep Power
    7

    Exclamation RFC: Zimbra generates In-Reply-To incorrectly?

    I've just gotten my installation running finally (in my Copious Free Time) and hit my first *major* snag:

    It appears that Z (or the webclient, whichever is pertinent) generates improper In-Reply-To headers. I will deal with the fact that it doesn't thread *inbound* mail on them later, that only affects me... but rewriting them breaks the RFC -- and threading for everyone else -- and has to be dealt with first.

    I replied to a message from a Yahoogroups (irony is great, isn't it? :-) mailing list with this Message-ID:

    <9423743.1221407307773.JavaMail.root@elwamui-milano.atl.sa.earthlink.net>

    And the copy of my message which the mailing list sent me back had an In-Reply-To header of this:

    In-Reply-To: <31469464.491221407842912.JavaMail.root@benjamin.v icimarketing.com>

    Any ideas, folks? Could this be caused by a misconfiguration, or should I open a ticket on it?
    Jay R. Ashworth - ZCS 6.0.9CE/CentOS5 - St Pete FL US - Music - Blog - Photography - IANAL - IAAMA
    Try to Ask Questions The Smart Way -- you'll get better answers.

    Put your product and version in your profile/signature - All opinions strictly my own, even though I have an employer these days.
    If you [SOLVE] something, please tell everyone how for the archives
    And, please... read what people write, and answer the questions they asked, not the ones they didn't.

  2. #2
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default

    Never seen this before and can't repro. My first guess is that your mailing list provider may be incorrectly rewriting the In-Reply-To header. Look at mail sent to the list by another user around the same time and see if there's similar rewriting going on.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Baylink is offline Elite Member
    Join Date
    Aug 2008
    Location
    St Pete FL USA
    Posts
    392
    Rep Power
    7

    Default

    This list has been well-behaved in the past.

    I will attempt to reproduce with several of my lists, and see, but as I noted, the provider is *yahoogroups*. Not Fat Jack's Cancer Clinic and Mailing Lists. :-)
    Jay R. Ashworth - ZCS 6.0.9CE/CentOS5 - St Pete FL US - Music - Blog - Photography - IANAL - IAAMA
    Try to Ask Questions The Smart Way -- you'll get better answers.

    Put your product and version in your profile/signature - All opinions strictly my own, even though I have an employer these days.
    If you [SOLVE] something, please tell everyone how for the archives
    And, please... read what people write, and answer the questions they asked, not the ones they didn't.

  4. #4
    Baylink is offline Elite Member
    Join Date
    Aug 2008
    Location
    St Pete FL USA
    Posts
    392
    Rep Power
    7

    Default

    There's a possibility this happened because I was in Conversation mode at the time; I've turned it off for now, because I don't like the way it displays in addition to not liking the way it threads, and this test came out ok.

    I'll try a reply to a list again tonight with Conversation mode back on and see what happens.
    Jay R. Ashworth - ZCS 6.0.9CE/CentOS5 - St Pete FL US - Music - Blog - Photography - IANAL - IAAMA
    Try to Ask Questions The Smart Way -- you'll get better answers.

    Put your product and version in your profile/signature - All opinions strictly my own, even though I have an employer these days.
    If you [SOLVE] something, please tell everyone how for the archives
    And, please... read what people write, and answer the questions they asked, not the ones they didn't.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. slapd message error
    By smoke in forum Administrators
    Replies: 7
    Last Post: 04-27-2008, 03:23 PM
  2. Replies: 12
    Last Post: 02-25-2008, 07:28 PM
  3. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM
  4. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  5. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 06:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •