Results 1 to 5 of 5

Thread: antispam not starting up

  1. #1
    ScottChapman is offline Special Member
    Join Date
    May 2008
    Posts
    118
    Rep Power
    7

    Default antispam not starting up

    So, I am using 5.0.9, and I have a backup script. Pretty simple, does a zmcontrol stop and then backs up the files, and then does a zmcontrol start to get things running again.

    The problem is that recently the antispam service has failed to start.

    I can get it going by manually doing a zmcontrol stop followed by a zmontrol start.

    How can I diagnose this problem?

  2. #2
    ScottChapman is offline Special Member
    Join Date
    May 2008
    Posts
    118
    Rep Power
    7

    Default

    From what I can tell a couple of things are happening. I am getting told that ClamAV is out of date, but it tries to update files anyway. Here is the output of my script:
    Host zimbra.woofplanet.com
    Stopping stats...Done
    Stopping mta...Done
    Stopping spell...Done
    Stopping snmp...Done
    Stopping archiving...Done
    Stopping antivirus...Done
    Stopping antispam...Done
    Stopping imapproxy...Done
    Stopping mailbox...Done
    Stopping logger...Done
    Stopping ldap...Done
    Host zimbra.woofplanet.com
    Starting ldap...Done.
    Starting logger...Done.
    Starting mailbox...Done.
    Starting antispam...Done.
    Starting antivirus...FAILED
    amavisd already running: pid 21222
    ClamAV update process started at Tue Sep 9 02:41:01 2008
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Local version: 0.93.3 Recommended version: 0.94
    DON'T PANIC! Read Clam AntiVirus
    main.cld updated (version: 48, sigs: 399264, f-level: 35, builder: sven)
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Current functionality level = 33, recommended = 35
    DON'T PANIC! Read Clam AntiVirus
    WARNING: getfile: daily-7652.cdiff not found on remote server (IP: 65.120.238.2)
    WARNING: getpatch: Can't download daily-7652.cdiff from db.us.clamav.net
    WARNING: getfile: daily-7652.cdiff not found on remote server (IP: 209.8.40.140)
    WARNING: getpatch: Can't download daily-7652.cdiff from db.us.clamav.net
    WARNING: getfile: daily-7652.cdiff not found on remote server (IP: 208.67.80.27)
    WARNING: getpatch: Can't download daily-7652.cdiff from db.us.clamav.net
    WARNING: Incremental update failed, trying to download daily.cvd
    daily.cvd updated (version: 8196, sigs: 17356, f-level: 35, builder: guitar)
    WARNING: Your ClamAV installation is OUTDATED!
    WARNING: Current functionality level = 33, recommended = 35
    DON'T PANIC! Read Clam AntiVirus
    Database updated (416620 signatures) from db.us.clamav.net (IP: 194.47.250.218)
    WARNING: Clamd was NOT notified: Can't connect to clamd on 127.0.0.1:3310
    connect(): Connection refused
    clamd failed to start


    Starting snmp...Done.
    Starting spell...Done.
    Starting mta...Done.
    Starting stats...Done.
    Date: 09-09-2008, Tuesday, 02:20 Hours

  3. #3
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    That's not one of the typical errors I remember (as it says it updates then can't connect) but give this a shot: ClamAV - Reset Defs DB - Zimbra :: Wiki

  4. #4
    ScottChapman is offline Special Member
    Join Date
    May 2008
    Posts
    118
    Rep Power
    7

    Default

    I did this, it worked for one day, and now it is failing again.

    It does look like it runs, but then it (at some point) stops running. I can alway start it manually and it runs just fine.

    Anyother ideas?

  5. #5
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Scott,

    Anything in /opt/zimbra/log/clamd.log to indicate why the daemon is dying ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. upgrading from 5.0.4 to 5.0.5 opensource
    By smoke in forum Installation
    Replies: 4
    Last Post: 10-19-2008, 10:38 AM
  2. zmmailboxdctl not starting after reboot, in RC2 also..
    By tamilnandhu in forum Installation
    Replies: 3
    Last Post: 11-26-2007, 02:25 AM
  3. postfix stopped
    By riegersteve in forum Administrators
    Replies: 1
    Last Post: 05-15-2007, 03:25 PM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  5. Zimbra on Debian?
    By omry_y in forum Installation
    Replies: 25
    Last Post: 11-04-2005, 11:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •