Results 1 to 8 of 8

Thread: [SOLVED] ***unchecked***

  1. #1
    Nox
    Nox is offline Active Member
    Join Date
    Jul 2008
    Location
    Michigan, USA
    Posts
    42
    Rep Power
    7

    Default [SOLVED] ***unchecked***

    On our server, I have turned the option to block encrypted archives. Now when users send or receive password protected zip files, the word ***UNCHECKED*** appears just like that in the subject line of the message.

    Is there any way to disable this from appending to the subject of an email?

  2. #2
    Nox
    Nox is offline Active Member
    Join Date
    Jul 2008
    Location
    Michigan, USA
    Posts
    42
    Rep Power
    7

    Default

    Anyone? Is this feature not available? Is this a feature of SpamAssasin that needs to be taken up with them?

  3. #3
    bonoboslr's Avatar
    bonoboslr is offline Special Member
    Join Date
    Jan 2008
    Location
    Pretoria
    Posts
    133
    Rep Power
    7

    Default

    Try changing the following using zmprov:

    $ zmprov gacf | grep -i zimbraSpamSubject
    zimbraSpamSubjectTag: **POSSIBLE SPAM**

    use mcf to modify the attribute value.

  4. #4
    Nox
    Nox is offline Active Member
    Join Date
    Jul 2008
    Location
    Michigan, USA
    Posts
    42
    Rep Power
    7

    Default

    Will this affect messages being scanned by ClamAV? The **unchecked** message appears to come from ClamAV not from SpamAssassin.

    Or maybe I am missing something and the two products are one in the same on Zimbra?

  5. #5
    Nox
    Nox is offline Active Member
    Join Date
    Jul 2008
    Location
    Michigan, USA
    Posts
    42
    Rep Power
    7

    Default

    Does anyone know how to remove the **UNCHECKED** heading that is appeaded to an email subject if the anti-virus does not check for viruses?

    I believe I earlier mistakenly thought this came from SpamAssassin, but it seems to come from the anti-virus.

  6. #6
    bonoboslr's Avatar
    bonoboslr is offline Special Member
    Join Date
    Jan 2008
    Location
    Pretoria
    Posts
    133
    Rep Power
    7

    Default

    I don't think that clamav modifies the subject line. I think that it must be done via amavisd - but don't hold me to it...

  7. #7
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Dig through /opt/zimbra/amavisd/sbin/amavisd (could move the value into /opt/zimbra/conf/amavisd.conf.in)
    Code:
    $undecipherable_subject_tag = '***UNCHECKED*** ';
    # doesn't seem to make it ineffective so try:
    Code:
    $undecipherable_subject_tag = 'undef'';
    or:
    Code:
    $undecipherable_subject_tag = '';
    Is this 5.0.9?
    There was a issue where /opt/zimbra/conf/clamav.conf.in > "%%uncomment VAR:zimbraVirusBlockEncryptedArchive%%ArchiveBlock Encrypted yes" wasn't used properly (don't remember what version we fixed it.)
    Don't forget about /opt/zimbra/conf/clamav.conf.in > "MaxFileSize 100M"
    Last edited by mmorse; 09-08-2008 at 11:34 AM. Reason: sbin & .in

  8. #8
    Nox
    Nox is offline Active Member
    Join Date
    Jul 2008
    Location
    Michigan, USA
    Posts
    42
    Rep Power
    7

    Default

    Modifying this code in AMAVISD fixed it:

    $undecipherable_subject_tag = '***UNCHECKED*** ';
    I finally found it on the web just before you posted, but thank you! We changed the value to just '* ' so that at least we know when messages are not being scanned for viruses but it is not so intrusive.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •