Results 1 to 2 of 2

Thread: imapsync problem between two zimbras - Missing NAMESPACE capability?

  1. #1
    mikelcu is offline Senior Member
    Join Date
    Oct 2007
    Posts
    54
    Rep Power
    7

    Default imapsync problem between two zimbras - Missing NAMESPACE capability?

    I'm having a problem migrating a user from a test instance of ZCS (5.0.4 I think) to our "real" install of ZCS (5.0.8 on Ubuntu 6.04). It would appear that the "real" instance does not advertise NAMESPACE support, so imapsync is failing as it connects. Normal IMAP access and web access to the same instance works fine. Is this an imapsync issue or a zibra problem or something else? Both zimbra installs use external LDAP auth, but are otherwise pretty vanilla.

    Code:
    $ imapsync --host1 host1.domain.com --ssl1 --user1 mailuser --passfile1 ~/.zimbrapass --host2 host2.domain.com --ssl2 --user2 mailuser   --passfile2 ~/.zimbrapass --noauthmd5
    $RCSfile: imapsync,v $ $Revision: 1.252 $ $Date: 2008/05/08 02:30:17 $
    Here is a [linux] system (Linux iridium 2.6.22.19 #1 SMP Fri May 30 12:36:42 PDT 2008 x86_64)
    with perl 5.10.0 and the module Mail::IMAPClient version used here is 2.2.9
    Command line used :
    /usr/bin/imapsync --host1 host1.domain.com --ssl1 --user1 mailuser --passfile1 /home/mailuser/.zimbrapass --host2 host2.domain.com --ssl2 --user2 mailuser --passfile2 /home/mailuser/.zimbrapass --noauthmd5
    Turned ON syncinternaldates, will set the internal dates on host2 same as host1.
    TimeZone :[PDT]
    Will try to use LOGIN authentication on host1
    Will try to use LOGIN authentication on host2
    From imap server [host1.domain.com] port [993] user [mailuser]
    To   imap server [host2.domain.com] port [993] user [mailuser]
    Banner : No banner
    Host host1.domain.com says it has NO CAPABILITY for AUTHENTICATE LOGIN
    Success login on [host1.domain.com] with user [mailuser] auth [LOGIN]
    Banner : No banner
    Host host2.domain.com says it has NO CAPABILITY for AUTHENTICATE LOGIN
    Success login on [host2.domain.com] with user [mailuser] auth [LOGIN]
    From capability : ID WITHIN QUOTA ESEARCH NAMESPACE MULTIAPPEND SASL-IR IDLE X-DRAFT-I05-SEARCHRES LOGIN-REFERRALS CONDSTORE UNSELECT ENABLE BINARY UIDPLUS CATENATE IMAP4REV1 X-DRAFT-W05-QRESYNC LIST-EXTENDED RIGHTS=EKTX AUTH=PLAIN ACL LITERAL+ CHILDREN
    To   capability : ID LITERAL+ SASL-IR AUTH=PLAIN IMAP4REV1
    From state Authenticated
    To   state Authenticated
    No NAMESPACE capability in imap server host2.domain.com
    Give the separator caracter with the --sep2 option

  2. #2
    mikelcu is offline Senior Member
    Join Date
    Oct 2007
    Posts
    54
    Rep Power
    7

    Default SOLVED - but possibly still a problem

    I seem to have solved the issue. We're using zimbra-proxy, so I tried running the sync directly to the real IMAP port (7993) instead of the proxy, and the sync works fine this way.

    While this is an easy workaround, is the missing capability when using the proxy port intended, or an actual problem?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 4.5.11 to 5.06 Migration Suggestion
    By newmember in forum Migration
    Replies: 15
    Last Post: 09-02-2008, 06:59 PM
  2. Missing Email Problem
    By prox in forum Zimbra Connector for Outlook
    Replies: 6
    Last Post: 03-16-2008, 10:01 PM
  3. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  4. Traslation SVN tree status
    By meikka in forum I18N/L10N - Translations
    Replies: 7
    Last Post: 02-13-2007, 11:13 AM
  5. imapsync problem missing emails
    By zimsteve in forum Administrators
    Replies: 3
    Last Post: 07-26-2006, 03:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •