Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: 500 Server Error when retrieving ICS

  1. #1
    autospy is offline Junior Member
    Join Date
    Jun 2007
    Location
    Philadelphia, PA
    Posts
    8
    Rep Power
    8

    Default 500 Server Error when retrieving ICS

    We have a small installation running Zimbra 4.5.11. We have a shared calendar (for external guests) with .ics file access.

    All of a sudden, we started to get a 500 error when downloading the ics file. We tried to remove and re-add the viewer email address, but it did no good. Below is the error.

    We should probably upgrade to the latest version, but its hard to take this server offline, and we'd appreciate if anyone had any idea of what to try next.

    Thanks

    ************

    type Exception report

    message

    description The server encountered an internal error () that prevented it from fulfilling this request.

    exception

    javax.servlet.ServletException: system failure: Unable to get calendar item notes MIME part
    com.zimbra.cs.service.UserServlet.doGet(UserServle t.java:287)
    javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
    com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:152)
    javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    com.zimbra.webClient.filters.SetHeaderFilter.doFil ter(SetHeaderFilter.java:276)

    root cause

    com.zimbra.common.service.ServiceException: system failure: Unable to get calendar item notes MIME part
    com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:165)
    com.zimbra.cs.mailbox.calendar.Invite.getDescripti on(Invite.java:720)
    com.zimbra.cs.mailbox.calendar.Invite.getDescripti on(Invite.java:634)
    com.zimbra.cs.mailbox.calendar.Invite.newToVCompon ent(Invite.java:1668)
    com.zimbra.cs.mailbox.CalendarItem.appendRawCalend arData(CalendarItem.java:1617)
    com.zimbra.cs.mailbox.Mailbox.getZCalendarForCalen darItems(Mailbox.java:2624)
    com.zimbra.cs.service.formatter.IcsFormatter.forma tCallback(IcsFormatter.java:88)
    com.zimbra.cs.service.formatter.Formatter$FormatOp eration.callback(Formatter.java:236)
    com.zimbra.cs.operation.Operation.schedule(Operati on.java:180)
    com.zimbra.cs.service.formatter.Formatter.format(F ormatter.java:77)
    com.zimbra.cs.service.UserServlet.doAuthGet(UserSe rvlet.java:370)
    com.zimbra.cs.service.UserServlet.doGet(UserServle t.java:279)
    javax.servlet.http.HttpServlet.service(HttpServlet .java:689)
    com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:152)
    javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    com.zimbra.webClient.filters.SetHeaderFilter.doFil ter(SetHeaderFilter.java:276)

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Look in recent events for content added to notes that it's getting stuck on.

    See if you can get more info (or nail it down to which event) by enabling the below then tail -f /opt/zimbra/log/mailbox.log while creating the error.
    zmprov aal shared@domain.com zimbra.calendar debug

    (Depending on which version you're running it disables on next server startup or remove it by using zmprov ral shared@domain.com zimbra.calendar)

    http://www.zimbra.com/forums/announc...html#post62754 with version information.
    Last edited by mmorse; 07-17-2008 at 09:32 PM.

  3. #3
    autospy is offline Junior Member
    Join Date
    Jun 2007
    Location
    Philadelphia, PA
    Posts
    8
    Rep Power
    8

    Default

    oops! updated the version info.

    zmprov doesn't seem to support the ability to add account loggers on our system. Is there another way to enable calendar debugging. Perhaps, on a global basis even? We plan to upgrade soon, but getting this fixed is a priority.

    It is a bit difficult for us to go back and find the event that is causing this because its been going on for a few weeks. However, searching through mailbox.log, I was able to find the following in the same stack trace...

    : javax.mail.internet.ParseException: Expected ';', got "Now"
    at javax.mail.internet.ParameterList.<init>(Parameter List.java:179)
    at javax.mail.internet.ContentType.<init>(ContentType .java:100)
    at com.zimbra.cs.mailbox.calendar.Invite.getDescripti on(Invite.java:704)

  4. #4
    autospy is offline Junior Member
    Join Date
    Jun 2007
    Location
    Philadelphia, PA
    Posts
    8
    Rep Power
    8

    Default

    Anyone have any hints here? We're stuck with this issue and don't want to take the chance of upgrading until this is resolved.

  5. #5
    Chadsel Chen is offline Active Member
    Join Date
    Jul 2007
    Location
    New York, NY
    Posts
    46
    Rep Power
    8

    Default

    I have exactly the same problem. Do you have a solution for this? Or this problem went away after your upgrade?

    Thanks

  6. #6
    autospy is offline Junior Member
    Join Date
    Jun 2007
    Location
    Philadelphia, PA
    Posts
    8
    Rep Power
    8

    Default

    Quote Originally Posted by Chadsel Chen View Post
    I have exactly the same problem. Do you have a solution for this? Or this problem went away after your upgrade?

    Thanks
    We're afraid to upgrade with an error like this. It is driving us bananas..I'm having someone look through all the notes of all the entries...but that is ridiculous.

    I'm hoping someone can tell us how to turn on calendar debug logging...!!

  7. #7
    Chadsel Chen is offline Active Member
    Join Date
    Jul 2007
    Location
    New York, NY
    Posts
    46
    Rep Power
    8

    Default

    Hi Autospy,

    Have you opened a ticket with Zimbra already? If not, I will open a ticket to them. I had a error for user can't purge Trash folder. I need to open a ticket to Zimbra in order to solve that since this kind of problems are more internal db and code related.

    Thanks

  8. #8
    autospy is offline Junior Member
    Join Date
    Jun 2007
    Location
    Philadelphia, PA
    Posts
    8
    Rep Power
    8

    Default

    We have a small research lab (10 - 15 people), so we are still running the Open Source version and don't have a support contract.

    (hint hint Zimbra...let us buy licenses for installations under 25 users!)

  9. #9
    Chadsel Chen is offline Active Member
    Join Date
    Jul 2007
    Location
    New York, NY
    Posts
    46
    Rep Power
    8

    Default

    Ok then. I will open a ticket with Zimbra. I will post the solution here. Wait for me. Thanks.

  10. #10
    autospy is offline Junior Member
    Join Date
    Jun 2007
    Location
    Philadelphia, PA
    Posts
    8
    Rep Power
    8

    Default

    was there a resolution to this?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. [SOLVED] Build Zimbra..a little problem...
    By Abdelmonam Kouka in forum Developers
    Replies: 33
    Last Post: 05-22-2008, 05:10 AM
  3. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 06:25 AM
  4. [SOLVED] Server migration/move for OS steps I used
    By newmember in forum Migration
    Replies: 0
    Last Post: 09-06-2007, 10:57 PM
  5. Installation Problem - Possibly LDAP
    By geroshea in forum Installation
    Replies: 5
    Last Post: 03-16-2007, 04:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •