Results 1 to 6 of 6

Thread: Service status change emails on nightly backup

  1. #1
    OverZealous's Avatar
    OverZealous is offline Active Member
    Join Date
    Mar 2007
    Location
    Michigan, USA
    Posts
    30
    Rep Power
    8

    Question Service status change emails on nightly backup

    Everytime my backup script restarts Zimbra at night, I get a series of emails telling me that the services have changed. They usually look like:

    Code:
    err: Service status change: [name of service] changed from stopped to running
    The backup script is a slightly modified version of the LogicalVolume backup script. It uses /etc/init.d/zimbra to start and stop Zimbra.

    I didn't use to get these messages, but they started occurring after a recent (major) upgrade to CentOS 5. I know that CentOS isn't officially supported, but is there anything I can do to prevent this? (Preferably without losing the notifications on true errors.)
    - Phil DeJarnett

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Quote Originally Posted by OverZealous View Post
    The backup script is a slightly modified version of the LogicalVolume backup script. It uses /etc/init.d/zimbra to start and stop Zimbra.

    I didn't use to get these messages, but they started occurring after a recent (major) upgrade to CentOS 5. I know that CentOS isn't officially supported, but is there anything I can do to prevent this? (Preferably without losing the notifications on true errors.)
    Those messages are from Zimbra, not CentOS. You will continue to get them as you are stopping and starting the Zimbra services, zimbra monitors the status and informs you of any problems.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    OverZealous's Avatar
    OverZealous is offline Active Member
    Join Date
    Mar 2007
    Location
    Michigan, USA
    Posts
    30
    Rep Power
    8

    Default

    So, I guess my only course of action then is to modify conf/swatchrc.in to not monitor when a service is started?
    - Phil DeJarnett

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    What's wrong with just receiving the email? You don't really want to stop or modify the monitoring just in case any of the services stop.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    OverZealous's Avatar
    OverZealous is offline Active Member
    Join Date
    Mar 2007
    Location
    Michigan, USA
    Posts
    30
    Rep Power
    8

    Default

    I already receive enough email every morning, and it just adds to the noise. It's the same reason why Vista's UAC is considered "bad" - too much noise and eventually I find myself ignoring messages.

    Besides, 6 separate messages just to tell me that the server restarted? That's fairly excessive. It seems like it could at least clump them together.

    It's more frustrating because the server shouldn't send those messages when it was a purposeful stop or start. (Of course, if it is the mail service itself that stops — the only one I care about — then I won't get the email anyway ;-)
    - Phil DeJarnett

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Well, you could just filter them out or modify the zimbra monitor it's your choice. If you think the messages are excessive or not appropriate then file an RFE for changes you'd like to see.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] mysql.server not running
    By king0770 in forum Administrators
    Replies: 23
    Last Post: 07-25-2009, 03:07 PM
  2. Error after installation
    By robsontuxlinux in forum Installation
    Replies: 13
    Last Post: 09-11-2008, 09:48 PM
  3. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 08:59 AM
  4. Replies: 4
    Last Post: 11-14-2007, 02:19 PM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •