Results 1 to 5 of 5

Thread: Must type http://xyz.com:81 for webmail service.

  1. #1
    nishith's Avatar
    nishith is offline Special Member
    Join Date
    Jun 2008
    Location
    india
    Posts
    123
    Rep Power
    6

    Default Must type http://xyz.com:81 for webmail service.

    Using zcs 5.0.5 Open Source Version.

    I am running "website" & "zimbra mail server" on a same system hardware.-Using FC7 i386 edition.

    My website & zimbra mail server is using http port. - zimbra admin works on https port.

    Now, I can open my site by typing " www.renovau.co.in" But,when going to open zimbra webmail service
    " http://webmail.renovau.co.in" it is giving me errors.

    The zimbra mail server can work if I type "http://webmail.renovau.co.in:81"

    Tell me what is the reason? Below is my basic entries.

    /etc/httpd/conf.d/vhost.conf file.


    NameVirtualHost *:80
    <VirtualHost *:80>
    ServerAdmin root@renovau.co.in
    DocumentRoot /var/www/html
    ServerName Carrier Grade Triple Play Class 5/4 Packet Switches and Services from Renovau
    ErrorLog /var/log/httpd/www-error.log
    CustomLog /var/log/httpd/www-access.log common
    </VirtualHost>


    <VirtualHost *:80>
    ServerName webmail.renovau.co.in
    ServerAdmin admin@renovau.co.in
    ProxyPass / http://webmail.renovau.co.in:81/
    ProxyPassReverse / http://webmail.renovau.co.in:81/
    ErrorLog /var/log/httpd/zimbra-error.log
    CustomLog /var/log/httpd/zimbra-access.log common
    </VirtualHost>



    below commands that i executed.

    zmprov ms renovau.co.in zimbraMailPort 81
    zmprov ms renovau.co.in zimbraMtaAuthHost webmail.renovau.co.in
    zmcontrol stop
    zmcontrol start
    /etc/init.d/zimbra restart

    But,Still it is not working.I don't want to give 81 port id to my clients.

    Tell me what to do.

    Nishith.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by nishith View Post
    But,Still it is not working.I don't want to give 81 port id to my clients
    You'll have to give them port 81 unless you a) set-up a proxy with Apache or b) make them use htps only. Search the forums and wiki for details on how to do that. I'll say this again, you should not be running a web server on the same machine as Zimbra. If you have any amount of traffic or users then performance will suffer for both of those applications.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    BTW, the address http://webmail.renovau.co.in:81 is not accessible from the internet
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    nishith's Avatar
    nishith is offline Special Member
    Join Date
    Jun 2008
    Location
    india
    Posts
    123
    Rep Power
    6

    Default

    Dear All,

    I have followd each n every steps as mentioned in this wiki.
    ZimbraApache - Zimbra :: Wiki

    Then,why it is not working same on my server?

    Now, the following URL is working.Please check.

    http://webmail.renovau.co.in:81/

    Waiting.

  5. #5
    nishith's Avatar
    nishith is offline Special Member
    Join Date
    Jun 2008
    Location
    india
    Posts
    123
    Rep Power
    6

    Default

    More status of my services.

    * Stopped httpd service in Linux.
    * zmcontrol status is normal.

    Host renovau.co.in
    antispam Running
    antivirus Running
    imapproxy Running
    ldap Running
    logger Running
    mailbox Running
    mta Running
    snmp Running
    spell Running
    stats Running


    I have disabled /etc/httpd/conf.d/vhost.conf file.then after zimbra works fine.What was the reason?

    As per the wiki,i didn't find any link in my linux!!!! (Please see below)

    for apache 2 :

    ln -s /etc/apache2/mods-available/proxy.load /etc/apache2/mods-enabled/proxy.load

    ln -s /etc/apache2/mods-available/proxy.conf /etc/apache2/mods-enabled/proxy.conf

    /etc/init.d/apache2 restart

    To do mod_proxy on the admin side do something along the following lines in httpd.conf

    <VirtualHost *:80>
    ServerName zimbras.domain.tld
    ServerAdmin admin@domain.tld
    SSLProxyEngine On
    ProxyPass / https://zimbra.domain.tld:7071/ (the hostname of the real zimbra server)
    ProxyPassReverse / https://zimbra.domain.tld:7071/ (the hostname of the real zimbra server)
    ErrorLog /var/log/zimbras.domain-error.log
    CustomLog /var/log/zimbras.domain-access.log combined
    CustomLog /var/log/all-access.log combined (something i have on all my hosts)
    </VirtualHost>


    Where to find above entries? I don't have any entries in /etc/httpd/conf.d/...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. Zimbra Server very slow - Too many SMTP connections
    By pc-nico in forum Administrators
    Replies: 23
    Last Post: 06-05-2008, 05:12 AM
  3. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  4. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  5. Mail not being delivered
    By EnglishDude in forum Administrators
    Replies: 11
    Last Post: 03-01-2007, 10:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •