Results 1 to 4 of 4

Thread: [SOLVED] Spell keeps stopping

  1. #1
    frankman is offline Senior Member
    Join Date
    Apr 2008
    Posts
    69
    Rep Power
    7

    Exclamation [SOLVED] Spell keeps stopping

    Hi everyone.

    Although Zimbra seems to be working nicely after 3-4 days of production, Spell has stopped for the 2nd or 3rd time after a few hours of starting up.

    I'm on ZCS 5.0.6 - 64-bit on CentOS 5.1 - 64-bit.
    Code:
    [zimbra@hostname ~]$ zmcontrol -v
    
    
    Release 5.0.6_GA_2313.RHEL5_64_20080522130456 CentOS5_64 FOSS edition
    From the directory name, this version seems to have aspell-0.60.6 (/opt/zimbra/aspell-0.60.6).

    I checked the /var/log/zimbra.log and found somewhere between Jun 20 05:20:06 and Jun 20 05:22:04, spell had stopped again. (host and domain replaced):
    Code:
    Jun 20 05:20:06 hostname zimbramon[21658]: 21658:info: 2008-06-20 05:20:01, STATUS: hostname.domain.com: antispam: Running
    Jun 20 05:20:06 hostname zimbramon[21658]: 21658:info: 2008-06-20 05:20:01, STATUS: hostname.domain.com: antivirus: Running
    Jun 20 05:20:06 hostname zimbramon[21658]: 21658:info: 2008-06-20 05:20:01, STATUS: hostname.domain.com: ldap: Running
    Jun 20 05:20:06 hostname zimbramon[21658]: 21658:info: 2008-06-20 05:20:01, STATUS: hostname.domain.com: logger: Running
    Jun 20 05:20:06 hostname zimbramon[21658]: 21658:info: 2008-06-20 05:20:01, STATUS: hostname.domain.com: mailhostname: Running
    Jun 20 05:20:06 hostname zimbramon[21658]: 21658:info: 2008-06-20 05:20:01, STATUS: hostname.domain.com: mta: Running
    Jun 20 05:20:06 hostname zimbramon[21658]: 21658:info: 2008-06-20 05:20:01, STATUS: hostname.domain.com: snmp: Running
    Jun 20 05:20:06 hostname zimbramon[21658]: 21658:info: 2008-06-20 05:20:01, STATUS: hostname.domain.com: spell: Running
    Jun 20 05:20:06 hostname zimbramon[21658]: 21658:info: 2008-06-20 05:20:01, STATUS: hostname.domain.com: stats: Running
    ...<snip>...
    Code:
    Jun 20 05:22:04 hostname zimbramon[22778]: 22778:info: 2008-06-20 05:22:01, STATUS: hostname.domain.com: antispam: Running
    Jun 20 05:22:04 hostname zimbramon[22778]: 22778:info: 2008-06-20 05:22:01, STATUS: hostname.domain.com: antivirus: Running
    Jun 20 05:22:04 hostname zimbramon[22778]: 22778:info: 2008-06-20 05:22:01, STATUS: hostname.domain.com: ldap: Running
    Jun 20 05:22:04 hostname zimbramon[22778]: 22778:info: 2008-06-20 05:22:01, STATUS: hostname.domain.com: logger: Running
    Jun 20 05:22:04 hostname zimbramon[22778]: 22778:info: 2008-06-20 05:22:01, STATUS: hostname.domain.com: mailhostname: Running
    Jun 20 05:22:04 hostname zimbramon[22778]: 22778:info: 2008-06-20 05:22:01, STATUS: hostname.domain.com: mta: Running
    Jun 20 05:22:04 hostname zimbramon[22778]: 22778:info: 2008-06-20 05:22:01, STATUS: hostname.domain.com: snmp: Running
    Jun 20 05:22:04 hostname zimbramon[22778]: 22778:info: 2008-06-20 05:22:01, STATUS: hostname.domain.com: spell: Stopped
    Jun 20 05:22:04 hostname zimbramon[22778]: 22778:info: 2008-06-20 05:22:01, STATUS: hostname.domain.com: stats: Running
    I couldn't find anything in between saying spell stopped for any reason. And I checked the wiki logs: Log Files, but there's nothing about aspell's log.

    I checked the logs in /opt/zimbra/log for anything related to spell:
    Code:
    [root@hostname log]# grep -i spell *log | more
    startup.log:    Stopping spell...Done
    startup.log:    Starting spell...Done.
    startup.log:    Stopping spell...Done
    startup.log:    Starting spell...Done.
    ...<snip>...
    startup.log:    Starting spell...Done.
    startup.log:    Starting spell...Done.
    startup.log:    Stopping spell...Done
    startup.log:    Starting spell...Done.
    [root@hostname log]#
    Is there anywhere else I can check to find out why spell keeps stopping?

    I'd really like to keep having a spell checker.
    Last edited by frankman; 06-21-2008 at 12:14 PM. Reason: (probably need a grammar checker too.

  2. #2
    frankman is offline Senior Member
    Join Date
    Apr 2008
    Posts
    69
    Rep Power
    7

    Default

    I was getting the same problem and error message as in this post and fixed it with phoenix's steps: [SOLVED] Remote Manager, Port 22 issue

    Just wondering if there's any connection, but does Apell need ssh?

  3. #3
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    What happens if you try restarting it manually (as the Zimbra user):

    Code:
    zmspellctl reload
    any errors thrown? Is this the only service that keeps failing?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    frankman is offline Senior Member
    Join Date
    Apr 2008
    Posts
    69
    Rep Power
    7

    Default

    Thanks, phoenix for the reply. Yes, spell was the only service that kept failing a few hours after startup, not immediately after startup, so it's kind of hard to find any errors. There wasn't any in /var/log/zimbra.log.

    I haven't tried the "zmspellctl reload", but when I had restarted Zimbra with "zmcontrol stop" and "zmcontrol start" (as zimbra user) and even "/etc/init.d/zimbra stop" and "/etc/init.d/zimbra start" (as root) all services including spell started and seemed to run fine, but spell would fail hours later.

    After fixing the ssh port, and since then, spell has been up and running solid again, so I'll mark this as solved, but I'm still wondering if spell needs to use ssh at all.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 658
    Last Post: 04-04-2014, 09:01 AM
  2. zmlogger not stopping on zimbra stop
    By holunde in forum Installation
    Replies: 2
    Last Post: 12-17-2007, 05:27 PM
  3. Clustering, RHEL5, Conga, Issues
    By chrisrios88 in forum Installation
    Replies: 7
    Last Post: 10-10-2007, 01:37 PM
  4. mysql.server is not running
    By Oswald-Kolle in forum Installation
    Replies: 27
    Last Post: 05-01-2007, 08:28 AM
  5. [SOLVED] Small problem stopping zimbra
    By jml75 in forum Administrators
    Replies: 13
    Last Post: 07-13-2006, 08:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •