Results 1 to 4 of 4

Thread: Administrator Questions - Recovering deleted mail, changing report email

  1. #1
    nufan is offline Senior Member
    Join Date
    Jun 2008
    Posts
    59
    Rep Power
    7

    Default Administrator Questions - Recovering deleted mail, changing report email

    Hi all, have a couple of questions for a Zimbra NE that I am administrator of. Am running 5.06

    1) When a user deletes an email from their inbox and then out of their trash, is there any way to recover it from the administration web page or from the console itself ? If so are there any step by step instructions for me to follow in order to do this ? Most of our users are synced using Mac Mail if this makes a difference. Not sure if they need to be using the web console in order for recovery to be available ?

    2) As I understand there is a report generated and emailed on a daily basis. Is there any way to see what email this is going to and change it ? I am not getting the emails so it must be either turned off or going to the previous admin's email inbox.

    3) During the upgrade process to 5.06 I was suprised to be stopped by a prompt wanting me to setup a spam training account. I put in a new email account not really knowing the implications and now I have two ''admin" accounts. Is there any way to change the email address that the spam training account uses ? I would rather use the existing admin account rather than use up another mailbox slot.

    Thanks for any assistance !
    Last edited by nufan; 06-20-2008 at 06:53 AM.

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Quote Originally Posted by nufan View Post
    1) When a user deletes an email from their inbox and then out of their trash, is there any way to recover it from the administration web page or from the console itself ? If so are there any step by step instructions for me to follow in order to do this ? Most of our users are synced using Mac Mail if this makes a difference. Not sure if they need to be using the web console in order for recovery to be available ?
    See the convo here: [SOLVED] Restoring a single mailbox

    Quote Originally Posted by nufan View Post
    2) As I understand there is a report generated and emailed on a daily basis. Is there any way to see what email this is going to and change it ? I am not getting the emails so it must be either turned off or going to the previous admin's email inbox.
    zmlocalconfig | grep smtp_destination
    zmlocalconfig -e smtp_destination=you@domain.com
    (or set forwarding on the default admin account)

    Values that deal with that:
    smtp_destination=admin@domain.com
    smtp_source=admin@domain.com
    smtp_notify=yes
    zimbra_mtareport_max_recipients=50
    zimbra_mtareport_max_senders=50

    Quote Originally Posted by nufan View Post
    3) During the upgrade process to 5.06 I was suprised to be stopped by a prompt wanting me to setup a spam training account. I put in a new email account not really knowing the implications and now I have two ''admin" accounts. Is there any way to change the email address that the spam training account uses ? I would rather use the existing admin account rather than use up another mailbox slot.
    You don't want it using an 'admin' account, there's a ham & spam that won't count against your license, admin accounts do.
    Let's start by:
    zmprov gacf | grep SpamAccount
    Should spit back your zimbraSpamIsNotSpamAccount & zimbraSpamIsSpamAccount current values.
    Search all your accounts and tell us what spam related stuff you have (zmaccts or zmprov gaa | grep whatever).

  3. #3
    nufan is offline Senior Member
    Join Date
    Jun 2008
    Posts
    59
    Rep Power
    7

    Default

    thanks for the reply !!

    1) I was pleasantly suprised to see I can restore mail accounts through the backups menu in the web administrator console. Although if i was to just need one email restored, is there any way to do that without restoring an entire account and potentially losing even more emails that have been sent/received since the restore point ?

    2) I see where the reports are being sent, for some reason there is an error email being sent to the admin account every 10 minutes which states:
    Code:
    Jun 20 14:00:04 xsrv1 zimbramon[13202]: 13202:crit: Disk warning: server.domain.com /dev/disk2s2 at 92%\n
    There appears to be plenty of disk space on the server, is this individual email accounts that are at their limit ?

    3) zmprov gacf |grep SpamAccount didn't return anything back for me. We have admin@server.domain.com account, and when i upgraded i put in myusername@server.domain.com as the spam training email address. I also have of course myusername@domain.com which is my personal email address. I think if i was able to make admin@server.domain.com the spam training filter it would mean i could delete one.

    thanks again

  4. #4
    alexkelly is offline Trained Alumni
    Join Date
    Oct 2007
    Location
    Columbus, OH
    Posts
    70
    Rep Power
    7

    Default

    I have been using zmmboxsearch for mail that I have synced to pull out particular messages. You could use this same logic to restore one piece of mail. So restore your mailbox to a new-prefixed username. Then do a search for the message on the restored account, and do an add message to the end-user's account.

    After you restore to restored_user, get the piece of mail you are looking for
    Code:
    zmmboxsearch -m restored_user@domain.com -q "query string" -d /tmp/
    That will dump anything that matches your query to /tmp with a format of sequence_accountid_messageid.

    You can then add that message to the original user by doing:
    Code:
    zmmailbox -z -m user@domain.com am /tmp/sequence_accountid_messageid

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. Problem with Postfix and MTA
    By ZMilton in forum Administrators
    Replies: 16
    Last Post: 04-16-2008, 06:47 AM
  3. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM
  4. MTA is Dying after yum update
    By tonyawbrey in forum Administrators
    Replies: 27
    Last Post: 04-02-2006, 06:11 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •