Results 1 to 9 of 9

Thread: Logging

  1. #1
    rmvg is offline Advanced Member
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    9

    Default Logging

    I am confused i have upgraded to version 5.0.0.6 and i am still getting a bunch of zimbra stuff in my syslog and zimbra.log. I thought that bug was fixed or do i need to do something during/after the upgrade?
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    The bug report & Release Notes have the details.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    rmvg is offline Advanced Member
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    9

    Default

    Ok i found zmsyslogsetup it is a script I have run it and reset the syslog
    /etc/init.d/sysklogd restart
    but still getting tonnes of zimbra stuff


    not sure what to make of the bug notes as i cannot find zmsyslogsetup file on my system. Thought upgrade from xxx2 to xxx6 would fix but i guess i would be considered an existing customer

    "ReleaseNotes: Only done on new installs, existing customers that would like to
    reduce their log volumes can rerun zmsyslogsetup"
    Last edited by rmvg; 06-17-2008 at 03:03 PM.
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  4. #4
    ArcaneMagus's Avatar
    ArcaneMagus is offline Moderator
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Run the following as root user with the Zimbra services stopped:
    /opt/zimbra/bin/zmsyslogsetup

  5. #5
    rmvg is offline Advanced Member
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    9

    Default

    hmmm not working after a zmcontrol stop command seems to run ok on running zimbra system but has no effect ie my syslog is still full of zimbra stuff.

    zimbra@mx1:/var/www$ zmcontrol stop
    Host mx1.canmail.org
    Stopping stats...Done
    Stopping mta...Done
    Stopping spell...Done
    Stopping snmp...Done
    Stopping archiving...Done
    Stopping antivirus...Done
    Stopping antispam...Done
    Stopping imapproxy...Done
    Stopping mailbox...Done
    Stopping logger...Done
    Stopping ldap...Done
    zimbra@mx1:/var/www$ exit
    exit
    root@mx1:/var/www# /opt/zimbra/bin/zmsyslogsetup
    ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException mx1.canmail.org:389)
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by rmvg View Post
    root@mx1:/var/www# /opt/zimbra/bin/zmsyslogsetup
    ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException mx1.canmail.org:389)
    This should give you the clue, you need to have zimbra running while you run the command.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    rmvg is offline Advanced Member
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    9

    Default

    ok maybe i am confused here but by executing the command /opt/zimbra/bin/zmsyslogsetup as root should stop all the zimbra log traffic in my syslog right?

    I have tried running the command with zimbra services started and still i get tonnes of zimbra noise in my /var/log/syslog, and my var/log/messages.

    something is not working here! probably me haha!
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

  8. #8
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    Looks like the bug only fixed syslog.conf and didn't catch syslog-ng changes needed. I'll reopen the bug and see if we can get it fixed in 5.0.8.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  9. #9
    rmvg is offline Advanced Member
    Join Date
    Sep 2005
    Location
    Calgary
    Posts
    208
    Rep Power
    9

    Default

    ok thanks for the reply, but not exactly sure what you mean by syslog-ng just guessing here as i a fairly new to ubuntu i do not think ubuntu uses syslog-ng.

    Fixed for 5.0.0.8 is cool call me impatient but is there something i can do disable or even drop the zimbra stuff in syslog? here is what the syslog looks like or am i looking in the wrong place here?

    #
    # For more information see syslog.conf(5)
    # manpage.

    #
    # First some standard logfiles. Log by facility.
    #

    auth,authpriv.* /var/log/auth.log
    *.*;auth,authpriv.none -/var/log/syslog
    #cron.* /var/log/cron.log
    daemon.* -/var/log/daemon.log
    kern.* -/var/log/kern.log
    lpr.* -/var/log/lpr.log
    user.* -/var/log/user.log
    uucp.* /var/log/uucp.log

    #
    # Logging for the mail system. Split it up so that
    # it is easy to write scripts to parse these files.
    #

    # Logging for INN news system
    #
    news.crit /var/log/news/news.crit
    news.err /var/log/news/news.err
    news.notice -/var/log/news/news.notice

    #
    # Some `catch-all' logfiles.
    #

    *.=debug;\
    auth,authpriv.none;\
    news.none;mail.none -/var/log/debug

    *.=info;*.=notice;*.=warn;\
    auth,authpriv.none;\
    cron,daemon.none;\
    mail,news.none -/var/log/messages

    #
    # Emergencies are sent to everybody logged in.
    #
    *.emerg *

    #
    # I like to have messages displayed on the console, but only on a virtual
    # console I usually leave idle.
    #
    #daemon,mail.*;\
    # news.=crit;news.=err;news.=notice;\
    # *.=debug;*.=info;\
    # *.=notice;*.=warn /dev/tty8

    # The named pipe /dev/xconsole is for the `xconsole' utility. To use it,
    # you must invoke `xconsole' with the `-file' option:
    #
    # $ xconsole -file /dev/xconsole [...]
    #
    # NOTE: adjust the list below, or you'll go crazy if you have a reasonably
    # busy site..
    #
    daemon.*;mail.*;\
    news.crit;news.err;news.notice;\
    *.=debug;*.=info;\
    *.=notice;*.=warn |/dev/xconsole

    local0.* -/var/log/zimbra.log
    auth.* -/var/log/zimbra.log
    mail.* -/var/log/zimbra.log
    kern.=debug -/var/log/bandwidth





    QUOTE=brian;97570]Looks like the bug only fixed syslog.conf and didn't catch syslog-ng changes needed. I'll reopen the bug and see if we can get it fixed in 5.0.8.[/QUOTE]
    Computer King

    http://www.computerking.ca

    Sales, Service, and Hosting
    Email, Data, and Web Packages
    Ask about web design specials

    Affiliates
    http://www.computerking.ca/pages/lin...affiliates.htm

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 10-26-2010, 04:42 AM
  2. Problems logging in
    By jooray in forum Administrators
    Replies: 2
    Last Post: 08-07-2007, 03:00 PM
  3. Multiple Server Logging
    By jstrat in forum Administrators
    Replies: 1
    Last Post: 09-01-2006, 08:07 AM
  4. Reducing server load by not logging every minute ?
    By basjes in forum Administrators
    Replies: 3
    Last Post: 02-25-2006, 11:36 AM
  5. MTA logging question
    By jescombe in forum Administrators
    Replies: 5
    Last Post: 02-16-2006, 12:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •