Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Surgemail to Zimbra

  1. #1
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default Surgemail to Zimbra

    I wish to migrate from Surgemail to Zimbra. I have tried the tools such as imapsync, migrationtool, IMAPCopy, imapcp, etc. However, none of these yielded good results.

    I had about 2000 emails and about 100 contacts in one email account on Server1. After the migration I could not exceed about 650 emails in folders names starting with a "."(dot). I also, did not see emails which were dated from April 2005 to until today (approx. last 10 months). I could see emails dated earlier. I had also lost contacts.



    I have 500 such accounts which I want to migrate to a server running Zimbra. Isn't there some solution for migration that may be implemented in production environment?
    Last edited by czaveri; 02-24-2006 at 07:45 PM. Reason: Incomplete post

  2. #2
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    Any errors in the sync? Any errors in the folder access?

  3. #3
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default Errors in imapsync

    Given below is an extract from the response, I received. As we notice, 634 messages have been transferred, which I confirmed by entering the Zimbra User Interface and counting them. However, there are 2038 messages in this account, which I can check using http://mail2web.com

    In addition, all these 634 messages are not transferred by imapsync. They were transferred by IMAPCopy (http://home.arcor.de/armin.diehl/imapcopy/imapcopy.html). I just executed imapsync after I executed IMAPCopy. The below given code is a result of this.

    But, I did run imapsync before IMAPCopy once earlier and that was when barely 100 emails had migrated. I then deleted all folders and emails to try out other migration options. The response received by me at that time was also similar to the one we see below.

    Code:
    + Copying msg #597:129040 to folder sent-mail
    flags from : [\Seen]["17-Apr-2005 08:30:48 -0500"]
    Copied msg id [597] to folder sent-mail msg id [3407]
    + NO msg #598 [UiBeinACbwIciK2mDsvjhQ:296770] in sent-mail
    + Copying msg #598:296770 to folder sent-mail
    flags from : [\Seen]["17-Apr-2005 08:34:24 -0500"]
    Copied msg id [598] to folder sent-mail msg id [3408]
    + NO msg #599 [Np7d+Sgub/HecV9srstIrA:1786] in sent-mail
    + Copying msg #599:1786 to folder sent-mail
    flags from : [\Seen]["17-Apr-2005 12:26:59 -0500"]
    Copied msg id [599] to folder sent-mail msg id [3409]
    + NO msg #600 [vwlSUE8p0sZtTC80ICQZvA:931] in sent-mail
    + Copying msg #600:931 to folder sent-mail
    flags from : [\Seen]["17-Apr-2005 13:45:54 -0500"]
    Copied msg id [600] to folder sent-mail msg id [3411]
    Time : 168 s
    ++++ Statistics ++++
    Time                   : 185 sec
    Messages transfered    : 634
    Messages skipped       : 0
    Total bytes transfered : 15844552
    Total bytes skipped    : 0
    Total bytes error      : 0
    Detected 0 errors
    Please, rate imapsync at http://freshmeat.net/projects/imapsync/
    [root@zimbra ~]#
    Last edited by czaveri; 02-24-2006 at 08:54 PM. Reason: Improvement

  4. #4
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    What version of zimbra? Can you tell if it's failing to read from the old system, or deliver to the new?

    Any errors in the zimbra logs?

    People have had great luck with imapsync to migrate email to zimbra.

  5. #5
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default Logs

    I think it is failing to read from old system which runs Surgemail. I am running zimbra 3.0.1 - bug release on CentOS. Yes, people have seen much success using imapsync, and I was sad when it didn't work perfectly in my case.

    FYI, I am enclosing a few logs, below in code section.

    Code:
    [root@zimbra log]# date
    Fri Feb 24 23:27:01 EST 2006
    [root@zimbra log]# tail -f zimbra.log
    2006-02-24 22:56:57,075 INFO  [LmtpServer-1] [] ProtocolHandler - Handler exiting normally
    2006-02-24 22:57:53,950 INFO  [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (1ms)
    2006-02-24 22:58:53,951 INFO  [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (0ms)
    2006-02-24 22:59:53,952 INFO  [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (0ms)
    2006-02-24 23:00:53,954 INFO  [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (0ms)
    2006-02-24 23:01:53,957 INFO  [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (1ms)
    2006-02-24 23:02:53,958 INFO  [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (0ms)
    2006-02-24 23:03:53,960 INFO  [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (0ms)
    2006-02-24 23:04:53,963 INFO  [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=0, after=1 (0ms)
    2006-02-24 23:05:54,015 INFO  [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=1, after=0 (50ms)
    [root@zimbra log]# tail -f zimbrastats-20060224-1358.csv
    02/24/2006 23:22:50,,,,,,4,0.75,,,,,,,,,,,,,,26,38,0,2,780,5391,1000,0,0,0,1
    02/24/2006 23:23:50,,,,,,4,1.00,,,,,,,,,,,,,,26,38,0,2,780,5391,1000,0,0,0,1
    02/24/2006 23:24:50,,,,,,4,0.75,,,,,,,,,3,199999.67,,,,26,38,0,2,780,5391,1000,0,0,0,1
    02/24/2006 23:25:50,,,,,,4,1.00,1,3.00,,,,,1,7.00,,,,,,26,38,0,2,780,5391,1000,0,0,0,1
    02/24/2006 23:26:50,,,,,,4,0.75,,,,,,,,,,,,,,26,38,0,2,780,5391,1000,0,0,0,1
    02/24/2006 23:27:50,,,,,,4,1.00,,,,,,,,,,,,,,26,38,0,2,780,5391,1000,0,0,0,1
    02/24/2006 23:28:50,,,,,,4,0.75,,,,,,,,,,,,,,26,38,0,2,780,5391,1000,0,0,0,1
    02/24/2006 23:29:50,,,,,,4,0.75,,,,,,,,,,,,,,26,38,0,2,780,5391,1000,0,0,0,1
    02/24/2006 23:30:50,,,,,,4,0.50,,,,,,,1,3.00,,,,,,26,38,0,2,780,5391,1000,0,0,0,1
    02/24/2006 23:31:50,,,,,,4,1.00,,,,,,,,,,,,,,26,38,0,2,780,5391,1000,0,0,0,1
    [root@zimbra log]#

  6. #6
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    I'm not what I can tell you if the imapsync is failing to read from your existing mail server - perhaps you should debug it on that side.

  7. #7
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default Yes, you are right

    Yes, you are right. I must find out more information on Surgemail and try to debug the problem from that side.

    I really appreciate your help and such prompt responses.

    Thank-you very much, marcmac and Zimbra.



    I will post again if I can figure out some solution and if it may be helpful to other members.

  8. #8
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default What format does Zimbra use for mail?

    I think one of the reasons for the mail not being correctly migrated could possiby lie in the format of mail. Surgemail uses maildir format.

  9. #9
    bobby is offline Zimbra Employee
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    Surgemail uses maildir format.
    that shouldn't matter; the imap protocol stays the same no matter how the mail is stored

    are there errors in the surgemail\mail*.log during the sync?

  10. #10
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default Will post back tomorrow

    Thank-you for your reply bobby. I will be out until Monday morning. Will post again then.
    Last edited by czaveri; 02-25-2006 at 11:27 PM. Reason: spell

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 31
    Last Post: 12-15-2007, 09:05 PM
  2. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  3. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  4. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 07:18 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •