Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: what are the basic configuration after installing zimbra "mails are not received"

  1. #1
    nskmdu is offline Senior Member
    Join Date
    Jun 2008
    Posts
    62
    Rep Power
    7

    Default what are the basic configuration after installing zimbra "mails are not received"

    hi pals


    i am new to zimbra. just now i installed. i am able to login admin console and noraml

    but if i send mails. i am not able to receive. so what is the basic configuration needed after

    installing zimbra.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    Are you behind a NAT router? Did you set-up a Split DNS? Did you set-up correct DNS A & MX records and /etc/hosts file? Your question has been asked many times in the forums, did you search for an answer?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    nskmdu is offline Senior Member
    Join Date
    Jun 2008
    Posts
    62
    Rep Power
    7

    Default

    no, i want to use zimbra for local intranet.

    my dns setting
    #vim /etc/named.conf

    options {
    directory "/var/lib/named";
    };
    zone "mobi.in" {
    type master;
    file "mobi.in.zone";
    };

    # vim /var/lib/named/mobi.in.zone

    $TTL 1W
    @ IN SOA mobi.in. root (
    42 ; serial (d. adams)
    2D ; refresh
    4H ; retry
    6W ; expiry
    1W ) ; minimum

    @ IN NS email.mobi.in
    @ IN A 10.100.0.250
    @ IN MX 10 email.mobi.in

    email IN A 10.100.0.250
    my " /etc/hosts " file

    #
    # hosts This file describes a number of hostname-to-address
    # mappings for the TCP/IP subsystem. It is mostly
    # used at boot time, when no name servers are running.
    # On small systems, this file can be used instead of a
    # "named" name server.
    # Syntax:
    #
    # IP-Address Full-Qualified-Hostname Short-Hostname
    #

    127.0.0.1 localhost

    # special IPv6 addresses
    ::1 localhost ipv6-localhost ipv6-loopback

    fe00::0 ipv6-localnet

    ff00::0 ipv6-mcastprefix
    ff02::1 ipv6-allnodes
    ff02::2 ipv6-allrouters
    ff02::3 ipv6-allhosts
    10.100.0.250 email.mobi.in email
    but when i installing zimbra. there is a message that there is no MX record entries for "email.mobi.in" so i think it is taking "email.mobi.in" as host name instedof taking only "email".

    it asks the MX record for "email.mobi.in.mobi.in" (first "email.mobi.in" as hostname, second "mobi.in" as domain name)

    so at the time of installation i set no for creating new doamin.

    why this problem happend when installing.

    how to solve.

    ok anyway i installed with this error.

    after installing i am able to open zimbra thru adming console and normal login.
    using admin password.

    but i am not able to send / receive mails.

    so what is the basic configuration.

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    Quote Originally Posted by nskmdu View Post
    no, i want to use zimbra for local intranet.
    I presume that's a 'no' to all of my questions? Whether it's on an intranet, or not, you'll still need to configure it correctly.

    Quote Originally Posted by nskmdu View Post
    but when i installing zimbra. there is a message that there is no MX record entries for "email.mobi.in" so i think it is taking "email.mobi.in" as host name instedof taking only "email".
    That's incorrect, Postfix will do a DNS lookup for the domain name (it can't find it) and that's 'mob.in' for your example. That's partly why it's failing.

    Quote Originally Posted by nskmdu View Post
    it asks the MX record for "email.mobi.in.mobi.in" (first "email.mobi.in" as hostname, second "mobi.in" as domain name)
    Your hostname is actually 'email' not email.mob.in - that's the FQDN of the server.

    Quote Originally Posted by nskmdu View Post
    so at the time of installation i set no for creating new doamin.
    Then you should have done.

    Quote Originally Posted by nskmdu View Post
    so what is the basic configuration.
    The basic configuration is to install Zimbra correctly. Read the Split DNS documentation at the link I gave you above, that will tell you what DNS records you need. You also need to correct your /etc/hosts file, read the Installation Quick Start Guide and correct your hosts file. Remove the current installation with './install.sh -u' the reinstall after making the changes to correct your configuration.

    All of these questions have been asked previously on the forums, please search if you encounter any other problems.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    nskmdu is offline Senior Member
    Join Date
    Jun 2008
    Posts
    62
    Rep Power
    7

    Default

    thanks a lot

    i configured split dns in zimbra server. and zimbra installed successfully. now i am able to
    open zimbra from zimbra server web browser only. and i am able to send and receive the mails between users.

    the mail sending address is

    but i want to send and receive emails to domain names such as

    for that i configure primary dns (mobi.in) in anohter computer of my lan (ip - 10.100.0.254)

    configurations made in zimbra server (ip - 10.100.0.250)

    i am using open suse 10.2 in zimbra installed server

    # vim /etc/named.conf

    options {
    directory "/var/lib/named";
    };
    zone "email.mobi.in" {
    type master;
    file "mobi.in.zone";
    };
    # vim /var/lib/named/mobi.in.zone


    $TTL 1W
    @ IN SOA mobi.in. root (
    42 ; serial (d. adams)
    2D ; refresh
    4H ; retry
    6W ; expiry
    1W ) ; minimum

    @ IN NS 10.100.0.250
    @ IN A 10.100.0.250
    @ IN MX 10 email.mobi.in.
    # vim /etc/resolv.conf

    domain email.mobi.in
    nameserver 10.100.0.250
    configuration of my primary dns ( ip 10.100.0.250)

    i am using centos 4.4 in primary dns.

    #vim /var/named/chroot/etc/named.conf


    options {
    directory "/var/named";
    };
    zone "mobi.in" {
    type master;
    file "mobi.in.zone";
    };
    # vim /var/named/chroot/var/named/mobi.in.zone

    $TTL 86400
    @ IN SOA mobi.in. root (
    42 ; serial (d. adams)
    3H ; refresh
    15M ; retry
    1W ; expiry
    1D ) ; minimum

    @ IN NS 10.100.0.254
    @ IN A 10.100.0.254
    @ IN MX 10 email.mobi.in.

    email IN A 10.100.0.250
    # vim /etc/resolv.conf

    search mobi.in
    nameserver 10.100.0.254
    these are all my configuration.

    now i am able to ping "email.mobi.in" from primary dns (10.100.0.254)

    but i am not able to open zimbra thru web browser from primary dns (10.100.0.254)

    even i entered the ip of zimbra sever (10.100.0.250) in the web browser of the primary dns (10.100.0.254)

    so what is the problem

    how to solve this

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    Quote Originally Posted by nskmdu View Post
    t
    the mail sending address is

    senthil@email.mobi.in
    admin@email.mobi.in

    but i want to send and receive emails to domain names such as

    senthil@mobi.in
    admin@mobi.in
    Why didn't you change the domain name when you did the install? It asks if you want to change it. If you don't make the change it will assume you want to use the FQDN of your server as the domain name.

    Did you change the hosts file to the correct format?

    Run the foillowing commands on the zimbra server:

    Code:
    host `hostname`  <-- type as-is with backticks not single quotes
    dig mob.in mx
    dig mob.in any
    cat /etc/hosts
    and post the output here.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    nskmdu is offline Senior Member
    Join Date
    Jun 2008
    Posts
    62
    Rep Power
    7

    Default

    my setting is


    # hostname
    email.mobi.in
    # vim /etc/hosts

    #
    # hosts This file describes a number of hostname-to-address
    # mappings for the TCP/IP subsystem. It is mostly
    # used at boot time, when no name servers are running.
    # On small systems, this file can be used instead of a
    # "named" name server.
    # Syntax:
    #
    # IP-Address Full-Qualified-Hostname Short-Hostname
    #

    127.0.0.1 localhost

    # special IPv6 addresses
    ::1 localhost ipv6-localhost ipv6-loopback

    fe00::0 ipv6-localnet

    ff00::0 ipv6-mcastprefix
    ff02::1 ipv6-allnodes
    ff02::2 ipv6-allrouters
    ff02::3 ipv6-allhosts
    10.100.0.250 email.mobi.in email
    # dig mobi.in mx


    ; <<>> DiG 9.3.2 <<>> mobi.in mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53794
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mobi.in. IN MX

    ;; AUTHORITY SECTION:
    mobi.in. 3202 IN SOA dns1.name-services.com. info.name-services.com. 2002050701 10001 1801 604801 181

    ;; Query time: 0 msec
    ;; SERVER: 10.100.0.250#53(10.100.0.250)
    ;; WHEN: Tue Jun 3 09:21:27 2008
    ;; MSG SIZE rcvd: 88
    # dig mobi.in a

    ; <<>> DiG 9.3.2 <<>> mobi.in a
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36412
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 5, ADDITIONAL: 5

    ;; QUESTION SECTION:
    ;mobi.in. IN A

    ;; ANSWER SECTION:
    mobi.in. 3600 IN A 8.15.231.132

    ;; AUTHORITY SECTION:
    mobi.in. 3600 IN NS dns1.name-services.com.
    mobi.in. 3600 IN NS dns2.name-services.com.
    mobi.in. 3600 IN NS dns3.name-services.com.
    mobi.in. 3600 IN NS dns4.name-services.com.
    mobi.in. 3600 IN NS dns5.name-services.com.

    ;; ADDITIONAL SECTION:
    dns1.name-services.com. 98821 IN A 69.25.142.42
    dns2.name-services.com. 98821 IN A 216.52.184.248
    dns3.name-services.com. 98821 IN A 63.251.92.200
    dns4.name-services.com. 98821 IN A 69.64.145.225
    dns5.name-services.com. 172374 IN A 70.42.37.7


    ;; Query time: 2374 msec
    ;; SERVER: 10.100.0.250#53(10.100.0.250)
    ;; WHEN: Tue Jun 3 09:21:55 2008
    ;; MSG SIZE rcvd: 233
    these all are my settings

    where is the problem

    here what is the additional sections
    where it displays all public ips. i ididn't mention this. is this automatically updated

  8. #8
    nskmdu is offline Senior Member
    Join Date
    Jun 2008
    Posts
    62
    Rep Power
    7

    Default

    the following is my installation details


    # ./install.sh

    Operations logged to /tmp/install.log.6631
    Checking for existing installation...
    zimbra-ldap...NOT FOUND
    zimbra-logger...NOT FOUND
    zimbra-mta...NOT FOUND
    zimbra-snmp...NOT FOUND
    zimbra-store...NOT FOUND
    zimbra-apache...NOT FOUND
    zimbra-spell...NOT FOUND
    zimbra-proxy...NOT FOUND
    zimbra-archiving...NOT FOUND
    zimbra-cluster...NOT FOUND
    zimbra-core...NOT FOUND


    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

    License Terms for the Zimbra Collaboration Suite:
    http://www.zimbra.com/license/zimbra..._eula_2.1.html


    Press Return to continue

    Checking for prerequisites...
    NPTL...FOUND
    sudo...FOUND sudo-1.6.8p12-40
    libidn...FOUND libidn-0.6.8-11
    fetchmail...FOUND fetchmail-6.3.5-23.2
    gmp...FOUND gmp-4.2.1-13
    /usr/lib/libstdc++.so.5...FOUND
    Prerequisite check complete.
    Checking for standard system perl...

    Checking for installable packages

    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell
    Found zimbra-proxy


    Select the packages to install

    Install zimbra-ldap [Y] y

    Install zimbra-logger [Y] y

    Install zimbra-mta [Y] y

    Install zimbra-snmp [Y] y

    Install zimbra-store [Y] y

    Install zimbra-apache [Y] y

    Install zimbra-spell [Y] y

    Install zimbra-proxy [N] n
    Checking required space for zimbra-core
    checking space for zimbra-store

    Installing:
    zimbra-core
    zimbra-ldap
    zimbra-logger
    zimbra-mta
    zimbra-snmp
    zimbra-store
    zimbra-apache
    zimbra-spell

    The system will be modified. Continue? [N] y

    Removing /opt/zimbra
    Installing packages

    zimbra-core......zimbra-core-5.0.6_GA_2313.openSUSE_10.2-20080522133539.i386.rpm...done
    zimbra-ldap......zimbra-ldap-5.0.6_GA_2313.openSUSE_10.2-20080522133539.i386.rpm...done
    zimbra-logger......zimbra-logger-5.0.6_GA_2313.openSUSE_10.2-20080522133539.i386.rpm...done
    zimbra-mta......zimbra-mta-5.0.6_GA_2313.openSUSE_10.2-20080522133539.i386.rpm...done
    zimbra-snmp......zimbra-snmp-5.0.6_GA_2313.openSUSE_10.2-20080522133539.i386.rpm...done
    zimbra-store......zimbra-store-5.0.6_GA_2313.openSUSE_10.2-20080522133539.i386.rpm...done
    zimbra-apache......zimbra-apache-5.0.6_GA_2313.openSUSE_10.2-20080522133539.i386.rpm...done
    zimbra-spell......zimbra-spell-5.0.6_GA_2313.openSUSE_10.2-20080522133539.i386.rpm...done
    Operations logged to /tmp/zmsetup.01001900-0000139128244.log
    Setting defaults... MX: email.mobi.in (10.100.0.250)

    Interface: 10.100.0.250
    Interface: 127.0.0.1
    10.100.0.250
    done.
    Checking for port conflicts

    Main menu

    1) Common Configuration:
    2) zimbra-ldap: Enabled
    3) zimbra-store: Enabled
    +Create Admin User: yes
    +Admin user to create: admin@email.mobi.in
    ******* +Admin Password UNSET
    +Enable automated spam training: yes
    +Spam training user: spam.b9cxvrnqeq@email.mobi.in
    +Non-spam(Ham) training user: ham.hheuhi0iv@email.mobi.in
    +Global Documents Account: wiki@email.mobi.in
    +SMTP host: email.mobi.in
    +Web server HTTP port: 80
    +Web server HTTPS port: 443
    +Web server mode: http
    +IMAP server port: 143
    +IMAP server SSL port: 993
    +POP server port: 110
    +POP server SSL port: 995
    +Use spell check server: yes
    +Spell server URL: chat rooms dating services mobi at mobi.in

    4) zimbra-mta: Enabled
    5) zimbra-snmp: Enabled
    6) zimbra-logger: Enabled
    7) zimbra-spell: Enabled
    8) Default Class of Service Configuration:
    r) Start servers after configuration yes
    s) Save config to file
    x) Expand menu
    q) Quit

    Address unconfigured (**) items (? - help)
    at this we where i have to change my domain as "mobi.in"

    pls tell me

  9. #9
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    Run the following command:

    Code:
    host `hostname`  <-- type it EXACTLY as you see it here or better yet, copy/paste
    post the output from that. The output from that command will show that your /etc/hosts file is incorrect, fix it as per the documentation in the Quick Start Installation Guide.

    According to the information in your dig command, you don't have an MX record for the domain, follow the instructions in the Split DNS guide. Uninstall zimbra with the './install.sh -u' command (that will remove everything of zimbra from your system) run the installation again after you've fixed the DNS.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    nskmdu is offline Senior Member
    Join Date
    Jun 2008
    Posts
    62
    Rep Power
    7

    Default

    hi

    i uninstalled zimbra.

    and i installed zimbra newly.

    then i issued following command as you told.

    # host `hostname`

    email.mobi.in has address 10.100.0.250
    email.mobi.in mail is handled by 10 email.mobi.in.
    is this correct?

    what is the problem.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 09:36 AM
  2. Replies: 31
    Last Post: 12-15-2007, 09:05 PM
  3. [SOLVED] Error Installing Zimbra on RHEL 5
    By harris7139 in forum Installation
    Replies: 10
    Last Post: 09-25-2007, 11:39 AM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  5. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 06:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •