Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29

Thread: https login and zmcertinstall

  1. #11
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    Sorry - CURRENTVALUE was to be replaced with the current value of the auth host. Since you've only got one host, that would be "dmrmail01.dmrcom.com".

    So
    Code:
    zmprov ms dmrmail01.dmrcom.com zimbraMtaAuthHost dmrmail01.dmrcom.com
    zmsaslauthdctl stop
    zmsaslauthdctl start

  2. #12
    DMRDave is offline Active Member
    Join Date
    Feb 2006
    Location
    Southern California
    Posts
    49
    Rep Power
    9

    Default

    No apologies needed. My bad. Here is the latest.

    zimbra@dmrmail01:~/log> zmprov ms dmrmail01.dmrcom.com zimbraMtaAuthHost dmrmail01.dmrcom.com
    zimbra@dmrmail01:~/log> zmsaslauthdctl stop
    /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/sbin/saslauthd: no process killed
    zimbra@dmrmail01:~/log> zmsaslauthdctl start
    zimbra@dmrmail01:~/log> zmprov gs SERVERNAME | grep zimbraMtaAuthHost
    ERROR: account.NO_SUCH_SERVER (no such server: SERVERNAME)
    zimbra@dmrmail01:~/log> zmprov gs SERVERNAME | grep zimbraMailMode
    ERROR: account.NO_SUCH_SERVER (no such server: SERVERNAME)

  3. #13
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    zmprov gs dmrmail01.dmrcom.com | grep zimbraMtaAuthUrl
    zmprov gs dmrmail01.dmrcom.com | grep zimbraMailMode

  4. #14
    DMRDave is offline Active Member
    Join Date
    Feb 2006
    Location
    Southern California
    Posts
    49
    Rep Power
    9

    Default

    Thanks for your patience Marc. Everything you have given me so far works but i'm still having the same issue of not being able to send from my IMAP Client that i was able to send from before restoring my ssl certs. The error i'm getting is - TLS not available due to local problem. I don't see anything in the zimbra.log that shows any errors? Where else can i look to see what's going on?

  5. #15
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    /var/log/zimbra.log is where I'd check.

    Which imap client are you using, and what do you have configured for smtp auth?

  6. #16
    DMRDave is offline Active Member
    Join Date
    Feb 2006
    Location
    Southern California
    Posts
    49
    Rep Power
    9

    Default

    /var/log/zimbra.log is empty right now.

    -rw-r--r-- 1 zimbra zimbra 0 Feb 23 05:00 zimbra.log
    -rw-r--r-- 1 root root 96319 Feb 23 05:00 zimbra.log.1.gz
    -rw-r--r-- 1 root root 123398 Feb 22 04:45 zimbra.log.2.gz
    -rw-r--r-- 1 root root 63710 Feb 20 04:15 zimbra.log.3.gz
    -rw-r--r-- 1 root root 62276 Feb 19 04:00 zimbra.log.4.gz

    I'm testing the following IMAP clients. Entourage 2004. Outlook Express 6. I have a domain configured on the mail server - poboxdmr.com and i'm running dns on the same box as zimbra. mail.poboxdmr.com is my smtp server and i have both of the following checked in entourage account settings.

    smtp service requires a secure connection (SSL)
    my server requries authentication (use same settings as incoming mail server)

    Additionally, before i messed with the ssl certs, i could send and recieve successfully from these clients.

  7. #17
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    When you sent successfully before, and you got the cert warning (self signed cert, do you wish to accept) did you say "accept for this session" or "accept forever"?

    If the latter, your clients may be choking because they've got a saved cert that doesn't match the one they're getting from the server now.

    There should be a way to remove saved certs from these clients, but you'll probably have to dig thru the prefs.

  8. #18
    DMRDave is offline Active Member
    Join Date
    Feb 2006
    Location
    Southern California
    Posts
    49
    Rep Power
    9

    Default

    Every time i started the clients (check for new messages in the inbox), I have the following message. See attached. I could just click OK - and then i could recieve. If i attempted to send a message from the imap account, the same message popped up, i could click ok, then i could send/recieve without the popup(s) reappearing until i restarted the mail client. same behavior in Outlook express.

    I now get the pop up when checking mail (once - just as before) but cannot send. I've removed the imap account all together and recreated, but i have the same behavior. i will mess around with some app prefs and let you know how things go. Thank you again.
    Attached Images Attached Images

  9. #19
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    yeah, that kind of looks like it's got the cert stored somewhere.

    Try a completely different client (eg, thunderbird) and see if that changes the behaviour.

    The fact that imap is working makes me think the cert itself is ok.

  10. #20
    DMRDave is offline Active Member
    Join Date
    Feb 2006
    Location
    Southern California
    Posts
    49
    Rep Power
    9

    Default

    Thanks Marc. I created an IMAP account on a differnet xp workstation via outlook express. When trying to send, the following is the error message.

    Unable to establish a ssl conneciton with the server. Protocol SMTP. Server Response "454 TLS not available due to local problem" port 25, Secure (SSL)

    Same symptoms as my other IMAP clients. If you think it would help, i can recreate the ssl certs on my server again. I've gotten really good at it in the last 24 hrs <laughing>.

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •