Results 1 to 3 of 3

Thread: java.lang.NullPointerException viewing Documents

  1. #1
    paul_thomas is offline New Member
    Join Date
    Feb 2008
    Posts
    3
    Rep Power
    7

    Question java.lang.NullPointerException viewing Documents

    Hi,

    We are seeing the error below when viewing the 'Documents' link in the Zimbra web client, or, when accessing the URL given in the error directly. Does anyone have any suggestion of possible problems? We are running zcs-NETWORK-5.0.5_GA_2201.RHEL5 on centos5. The problem was not present after install, this initially worked, the problem has presented since. Before the problem arose the customer says that their documents disappeared.

    HTTP ERROR: 500

    INTERNAL_SERVER_ERROR

    RequestURI=/service/home/userreplaced@domainreplaced.co.uk/test
    Caused by:
    at com.zimbra.cs.httpclient.URLUtil.getServiceUrl(URL Util.java:171)
    at com.zimbra.cs.httpclient.URLUtil.getSoapURL(URLUti l.java:56)
    at com.zimbra.cs.wiki.Wiki$WikiByPath.load(Wiki.java: 381)
    at com.zimbra.cs.wiki.Wiki$WikiByPath.lookupWiki(Wiki .java:417)
    at com.zimbra.cs.wiki.Wiki.getChrome(Wiki.java:486)
    at com.zimbra.cs.wiki.Wiki.getChromeTemplate(Wiki.jav a:689)
    at com.zimbra.cs.wiki.Wiki.getTemplate(Wiki.java:680)
    at com.zimbra.cs.service.formatter.WikiFormatter.getT emplate(WikiFormatter.java:122)
    at com.zimbra.cs.service.formatter.WikiFormatter.getT emplate(WikiFormatter.java:108)
    at com.zimbra.cs.service.formatter.WikiFormatter.hand leWikiFolder(WikiFormatter.java:138)
    at com.zimbra.cs.service.formatter.WikiFormatter.form atCallback(WikiFormatter.java:209)
    at com.zimbra.cs.service.formatter.Formatter.format(F ormatter.java:83)
    at com.zimbra.cs.service.UserServlet.doAuthGet(UserSe rvlet.java:449)
    at com.zimbra.cs.service.UserServlet.doGet(UserServle t.java:355)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:707)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:187)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:487)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1093)
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA gentFilter.java:81)
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1084)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:360)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:181)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:716)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:406)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:211)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:315)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.Server.handle(Server.java:313)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:506)
    at org.mortbay.jetty.HttpConnection$RequestHandler.he aderComplete(HttpConnection.java:830)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:514)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:211)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:381)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:396)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:442)

    Powered by Jetty://

    Any suggestions?

    Cheers,
    Paul

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Looks like zimbraServiceHostname (first entry) is at odds with something.
    (zimbraPublicServiceHostname is used to make the url as well)

    You probably hit this: Bug 13641 - Changing zimbraServiceHostname independently of zimbraServerName doesn't work

    Check all those values listed in the bug, for instance:
    zmprov gs server.domain.com | grep ServiceHostname

  3. #3
    paul_thomas is offline New Member
    Join Date
    Feb 2008
    Posts
    3
    Rep Power
    7

    Default Doesn't seem to be the same bug

    Hi,

    Many thanks for your reply. I have finally gotten around to looking into this. I have checked the bug and investigated the values of zimbraServerHostname zimbraServiceHostname as indicated. I have found that only one of the values specified exists in my setup that being zimbraServiceHostname so I am not sure this is the same issue?

    On an aside I have need to recover a document while this page is inaccessible, is there somewhere either on the filesystem or in the database I can recover it from?

    Cheers,
    Paul

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] 5.0.1 to 5.0.2 NE - Documents Gone!
    By jhoelz in forum Installation
    Replies: 1
    Last Post: 02-02-2008, 12:45 AM
  2. [SOLVED] Can't open documents (4.5.7 > 5.0rc2)
    By RJB in forum Administrators
    Replies: 3
    Last Post: 12-13-2007, 10:38 AM
  3. Documents & Notebooks Woes
    By torusgrp in forum Administrators
    Replies: 0
    Last Post: 05-11-2007, 10:19 PM
  4. Replies: 26
    Last Post: 02-12-2007, 07:23 PM
  5. Documents Feature Messed up
    By frogstarr78 in forum Installation
    Replies: 1
    Last Post: 11-07-2006, 07:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •