Results 1 to 6 of 6

Thread: Can't Send Email or View Mail Queue after restoring from Backup

  1. #1
    StuMac is offline Member
    Join Date
    May 2008
    Location
    Scotland
    Posts
    11
    Rep Power
    6

    Default Can't Send Email or View Mail Queue after restoring from Backup

    Hi,

    I'm running ZCS 4.5.10 (Community Edition) on Centos 5.

    I restored a backup copy of my /opt/zimbra/ directory on my live server, having broke the original by running zmsetservername on my test server which seemed to make changes to ldap on the live machine.(both machines had the same name at one point).

    There were no problems with using the backup - all services started ok, but when I try to view the mail queues, I get a server error:

    Message: system failure: exception during auth {RemoteManager: mailserver1.ourcorp.local->zimbra@mailserver1.ourcorp.local:22}
    Error code: service.FAILURE
    Method: ZmCsfeCommand.prototype.invoke
    Details:soap:Receiver

    When users try to send mail, they get a network service error:
    msg - system failure: IOException
    code - service.FAILURE
    method - ZmCsfeCommand.prototype.invoke
    detail - soap:Receiver

    I've searched for a solution in the forums and the wiki and checked hosts, dns etc but with no joy.

    I'd be grateful for any help provided.

  2. #2
    StuMac is offline Member
    Join Date
    May 2008
    Location
    Scotland
    Posts
    11
    Rep Power
    6

    Default Update

    I've sorted the mail queue issue (I had regenerated the keys then tried to load them with zimbra down- bring zimbra back up then loading the keys worked).

    I now a a queue full of mail waiting to be delivered, as well as users being unable to send mail, either locally or outside.

    The maillog says the mail system is down.

    Can someone give me some pointers?

    Thanks

  3. #3
    soxfan is offline Moderator
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    Permissions problem maybe?

  4. #4
    StuMac is offline Member
    Join Date
    May 2008
    Location
    Scotland
    Posts
    11
    Rep Power
    6

    Default

    Yip, That's it. was a permssions problem with the message store.
    chown -R zimbra:zimbra /opt/zimbra/st* fixed it.
    Many Thanks

  5. #5
    soxfan is offline Moderator
    Join Date
    Mar 2006
    Location
    Massachusetts
    Posts
    965
    Rep Power
    10

    Default

    Glad you got it fixed. Just a thought, but you may want to run 'zmfixperms' to avoid any other permissions problems. I've never had to run it myself so I don't know a lot about it, but I believe it is one of the recommended steps after restoring from backup.

  6. #6
    StuMac is offline Member
    Join Date
    May 2008
    Location
    Scotland
    Posts
    11
    Rep Power
    6

    Smile zmfixperms -extended

    Just a little caveat I want to add about zmfixperms, as I can't see it documented anywhere else.

    By default (in our verion 4.5.10 anyway) it doesn't fix the permissions on the store, backup , and index directories. To fix these,and the rest, you have to run it with the -extended switch, so

    Code:
    ./zmfixperms -extended -verbose
    will do it, and let see you what's happening.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. zmamavisdctl stopped and won't restart
    By alto in forum Installation
    Replies: 2
    Last Post: 04-18-2008, 12:41 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. Installed OK - Can send but not recieve email
    By gregbazar in forum Installation
    Replies: 3
    Last Post: 11-05-2005, 04:56 PM
  5. Mail not getting to mail boxes
    By ehults in forum Installation
    Replies: 5
    Last Post: 10-31-2005, 09:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •