Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Changing the FQDN of a server

  1. #1
    DJ Ghost is offline Senior Member
    Join Date
    May 2008
    Location
    FRANCE
    Posts
    58
    Rep Power
    7

    Default Changing the FQDN of a server

    Hi,

    I have a domain ending in .fr, when I installed zimbra I named the server srv1.domain.fr.
    Now I have domain.org, I would like this server to become the main server of all others. DNS have been updated and MX record created. I would like this server to host the primary Zimbra server. In the futur I will have other servers hosting zimbra too.

    I would like all accounts ending in @domain.org and not @srv1.domain.org and this even if all acounts are not hosted on the primary Zimbra server.

    Can someone provide a step by step instructions to rename the server. By now there are only a few accounts on this server and only one domain but in the futur I may have other domains.

    Thanks

  2. #2
    p24t is offline Moderator
    Join Date
    Mar 2007
    Location
    Austin
    Posts
    441
    Rep Power
    8

    Default

    Try out the wiki documentation here:

    ZmSetServerName - Zimbra :: Wiki

  3. #3
    DJ Ghost is offline Senior Member
    Join Date
    May 2008
    Location
    FRANCE
    Posts
    58
    Rep Power
    7

    Default

    Thanks, it seems changes are not set everywhere.
    In the administration console it seems that accounts have been updated (I changed the domain name of the domain too) but, as an exemple :
    the domain's account I created before is here but when I login, mail's folders are here but not Notebooks. Notebooks in the left pane are here but I select I have an error in the view panel saying
    HTTP ERROR: 500

    error: no such account wiki@srv1.domain.fr

    All references to the old FQDN have not been replaced by the new...
    In fact it's the same for all accounts. I cannot access notebooks in any accounts

    What is the magic command line ? :-)
    Last edited by DJ Ghost; 05-21-2008 at 08:08 AM.

  4. #4
    p24t is offline Moderator
    Join Date
    Mar 2007
    Location
    Austin
    Posts
    441
    Rep Power
    8

    Default

    You may want to check this value:

    Code:
    [zimbra@mail ~]$ zmprov gacf |grep -i wiki
    zimbraNotebookAccount: wiki@domain.com
    If yours is not set properly, then change it using

    Code:
    zmprov mcf zimbraNotebookAccount wiki@[your domain]

  5. #5
    DJ Ghost is offline Senior Member
    Join Date
    May 2008
    Location
    FRANCE
    Posts
    58
    Rep Power
    7

    Default

    Notebooks, Friends in Instant Messenger are not here anymore. I can well see for notebooks that the requested URL in the ZWC is pointing to the new domain but things are probably at the old location. I don't know well enough where things are located but I hope old data are intact.
    If someone can help to provide a command line that will search in all files for the old domain name and replace it with the new and do the same for the database too that may restore everything ?

  6. #6
    p24t is offline Moderator
    Join Date
    Mar 2007
    Location
    Austin
    Posts
    441
    Rep Power
    8

    Default

    Run the same command (zmprov gacf) but instead of looking for 'wiki' look for your old domain name instead. Most settings are stored in there. You might also want to run zmlocalconfig just to make sure there are no settings there for your old domain either.

  7. #7
    DJ Ghost is offline Senior Member
    Join Date
    May 2008
    Location
    FRANCE
    Posts
    58
    Rep Power
    7

    Default

    Thanks fro your help,

    I stopped zimbra and rebooted the server, I issued zm control start end...

    root@scs:~# su - zimbra
    zimbra@scs:~$ zmcontrol start
    Host scs.domain.org
    Starting ldap...Done.
    FAILED
    Failed to start slapd. Attempting debug start to determine error.
    TLS: error:0906D06C:PEM routines:PEM_read_bio:no start line pem_lib.c:647
    TLS: error:140AD009:SSL routines:SSL_CTX_use_certificate_file:PEM lib ssl_rsa.c:491
    main: TLS init def ctx failed: -1

    So I cannot start zimbra anymore...

  8. #8
    DJ Ghost is offline Senior Member
    Join Date
    May 2008
    Location
    FRANCE
    Posts
    58
    Rep Power
    7

    Default

    Just an idea...
    If I uninstall zimbra and reinstall it with the new domain name would it be possible to recover data from the automatic backup made by the NE edition and put everything in the new domain ?

  9. #9
    DJ Ghost is offline Senior Member
    Join Date
    May 2008
    Location
    FRANCE
    Posts
    58
    Rep Power
    7

    Default

    Yeahhh... A bad day...
    So, I reinstalled zimbra with the new domain name, and really I don't see how I can manage things to not have the host name into email address as the isntall procédure put it into everything during the install process...
    I thought automatic backups made everyday would be rock solide but maybe they are... Maybe it's just the restore procedure that is not rock solide !

    I've not been able to recover all notebooks I had on my admin account. I get the HTTP ERROR 505 when I go to the notebooks pane.

    Then.. More than 10 hours lost to just change a domain name on a server...

    If someone can understand what's going on here will try to understand myself tomorrow... :-(

  10. #10
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    You haven't mentioned this but did you also change your /etc/hosts file to reflect the new FQDN name? Did you also search through your server for remnants of the old name as mentioned earlier with the following:

    Code:
    zmprov gacf |grep -i srv1.domain.fr
    Once you've done that you should be able to see what needs changing. I'm also assuming that your email accounts had the format xxx@srv1.domain.fr - would that be correct?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Error after installation
    By robsontuxlinux in forum Installation
    Replies: 13
    Last Post: 09-11-2008, 09:48 PM
  2. Changing server name
    By lilwong in forum Administrators
    Replies: 24
    Last Post: 03-26-2007, 01:09 PM
  3. Zimbra Installation Problem
    By AnilKumarYalla in forum Developers
    Replies: 0
    Last Post: 09-10-2006, 09:33 PM
  4. MTA is Dying after yum update
    By tonyawbrey in forum Administrators
    Replies: 27
    Last Post: 04-02-2006, 06:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •