Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Perl_Tstack_sp_ptr

  1. #1
    sonnessa is offline Starter Member
    Join Date
    May 2008
    Posts
    1
    Rep Power
    7

    Default Perl_Tstack_sp_ptr

    I have Zimbra 5.0 installed on Debian 4.0. After updating system I got perl 5.10 and now Zimbra does not work anymore.

    When I type zmcontrol status I get the following message:
    /usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/IO/IO.so: undefined symbol: Perl_Tstack_sp_ptr

    The problem is in i486-linux-gnu-thread-multi libraries which are not compatible with perl 5.10.

    Does anyone face the same problem?

    Thanks,
    Michele

  2. #2
    McDaeMonD is offline Starter Member
    Join Date
    Jul 2008
    Posts
    2
    Rep Power
    7

    Default

    /usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/i586-linux-thread-multi/auto/IO/IO.so: undefined symbol: Perl_Tstack_sp_ptr

    I have same problem, im using OpenSuSE-11 with zcs-NETWORK-5.0.8_GA_2462.SuSEES10.20080709154010 package, may be wrong package but i same in debian, don't know at ubuntu

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    Quote Originally Posted by McDaeMonD View Post
    I have same problem, im using OpenSuSE-11 with zcs-NETWORK-5.0.8_GA_2462.SuSEES10.20080709154010 package, may be wrong package but i same in debian, don't know at ubuntu
    No version of openSUSE is supported Network Edition, you must use a supported distribution for Network Edition.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    McDaeMonD is offline Starter Member
    Join Date
    Jul 2008
    Posts
    2
    Rep Power
    7

    Default

    how about Ubuntu 8.04, this version supported by NE?, because 6.06 is to old for us

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    Quote Originally Posted by McDaeMonD View Post
    how about Ubuntu 8.04, this version supported by NE?, because 6.06 is to old for us
    The only supported distributions are the ones on this list.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    wcbenyip is offline Senior Member
    Join Date
    Jun 2007
    Location
    Hong Kong
    Posts
    62
    Rep Power
    8

    Unhappy

    I also reached the same problem while installing the zcs 5.0.10 on ubuntu 8.1, does any advise / recommendation could be provided by Zimbra? The root cause seems to be come from the latest perl 5.10.0 ~ (I have also manually installed the additional libstdc++5 & libltdl3 to fulfill the prerequisites of zcs 5.0.10)

    Anyway, any help from Zimbra ?
    OS=Ubuntu 8.04 LTS
    Current: Release 5.0.10_GA_2638.UBUNTU8 UBUNTU8 FOSS edition
    OS=openSUSE 10.3
    Current: Release 5.0.2_GA_1975.openSUSE_10.2_20080130231825 UNKNOWN FOSS edition
    Prior: Release 4.5.6_GA_1044.SuSE10_20070706142147 openSUSE_10.2 FOSS edition

  7. #7
    elcorazon is offline Member
    Join Date
    Nov 2008
    Posts
    10
    Rep Power
    6

    Default Ubuntu 8.10 Intripid running

    Quote Originally Posted by wcbenyip View Post
    I also reached the same problem while installing the zcs 5.0.10 on ubuntu 8.1, does any advise / recommendation could be provided by Zimbra? The root cause seems to be come from the latest perl 5.10.0 ~ (I have also manually installed the additional libstdc++5 & libltdl3 to fulfill the prerequisites of zcs 5.0.10)

    Anyway, any help from Zimbra ?
    Hi,
    I got Zimbra to run in Ubuntu 8.10 after installing some old Perl packages:
    • liblocale-gettext-perl_1.05-2ubuntu1_amd64.deb
    • libperl5.8_5.8.8-12_amd64.deb
    • perl_5.8.8-12_amd64.deb
    • perl-base_5.8.8-12_amd64.deb
    • perl-modules_5.8.8-12_all.deb
    • libterm-readkey-perl_2.30-3ubuntu1_amd64.deb


    Those packages can be found on launchpad.net

    Only problem left are some unresolved dependencies when I try to update the system now... working on that...

    I wonder if one could replace the Zimbra-Version of amavisd with some current version to work around the problem..?

  8. #8
    elcorazon is offline Member
    Join Date
    Nov 2008
    Posts
    10
    Rep Power
    6

    Default

    I partially solved the problem of the outdated perl packages with apt-pinning as described here:
    https://help.ubuntu.com/community/DowngradeHowto

    I did not want to reinstall the server because there's already some data on it. I added deb sources for both, Ubuntu Intrepid and Hardy and pinned the versions. Now aptitude full-upgrade does not complain any more (and hopefully I will get all security updates in the future :-)

  9. #9
    ToroLoco is offline Member
    Join Date
    Jan 2009
    Posts
    12
    Rep Power
    6

    Default

    Why Zimbra don't support the new perl package and the ubuntu 8.10 version??

    I have the Ubuntu Server running and I have received the 60days test ticket, but I cannot test it. How I am suppose to test it?

    I tried the above solution from elcorazon, but didn't worked the apt-get couldn't downgrade the perl version and still I have the error message:

    /usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/i486-linux-gnu-thread-multi/auto/IO/IO.so: undefined symbol: Perl_Tstack_sp_ptr

    Is there any other way that I could install the server?

  10. #10
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    UBUNTU 8.10 IS NOT SUPPORTED. How difficult is this to understand? Use 8.04 LTS:
    Zimbra - Products: Network Edition Downloads

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •