Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: Mailbox stopped, redo.log permissons problem

  1. #11
    Crexis's Avatar
    Crexis is offline Senior Member
    Join Date
    Feb 2006
    Posts
    54
    Rep Power
    9

    Default

    Quote Originally Posted by marcmac
    Can you verify that it's being run, and that zimbra is shutting down on a reboot?
    Ah, I would dearly love to do that haven't got a clue how to though. Would there be a log file I can check or is it a case of sitting in front of machine during shutdown/startup? Funny thing is, I just rebooted my server again (due to changes under global in the Admin console) and I thought to check the file permissions after doing a zmcontrol stop, before restarting the box. It had changed to root:root. I did a chown+chmod to fix it, rebooted the box did a zmcontrol start and it worked first time. I'm guessing that this means the zmcontrol script is creating/modifying this file as root user during a zmcontrol stop? Any pointers greatly appreciated.
    Last edited by Crexis; 03-14-2006 at 02:35 AM.

  2. #12
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    /opt/zimbra/log/zimbra.log
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #13
    Crexis's Avatar
    Crexis is offline Senior Member
    Join Date
    Feb 2006
    Posts
    54
    Rep Power
    9

    Default

    Quote Originally Posted by KevinH
    /opt/zimbra/log/zimbra.log
    Code:
    mail:~ # ls -l /opt/zimbra/redolog/redo.log
    -rw-rw----  1 root zimbra 1024 Mar 14 17:01 /opt/zimbra/redolog/redo.log
    mail:~ # su - zimbra
    zimbra@mail:~> zmcontrol stop
    Host mail.yellodot.co.za
            Stopping antispam...Done
            Stopping antivirus...Done
            Stopping ldap...Done
            Stopping logger...Done
            Stopping mailbox...Done
            Stopping mta...FAILED
    /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/sbin/saslauthd: no process killed
    
    
            Stopping snmp...Done
            Stopping spell...Done
    zimbra@mail:~> logout
    mail:~ # ls -l /opt/zimbra/redolog/redo.log
    -rw-r-----  1 root root 512 Mar 14 17:46 /opt/zimbra/redolog/redo.log
    mail:~ #
    Output to /opt/zimbra/log/zimbra.log from "zmcontrol stop"
    Code:
    2006-03-14 17:46:52,221 INFO  [Thread-261] [] StatsImageServlet - Servlet StatsImageServlet shutting down
    2006-03-14 17:46:52,222 INFO  [Thread-261] [] soap - Servlet AdminServlet shutting down
    2006-03-14 17:46:52,222 INFO  [Thread-261] [] TcpServer/7025 - LmtpServer initiating shutdown
    2006-03-14 17:46:52,223 INFO  [LmtpServer] [] TcpServer/7025 - finished accept loop
    2006-03-14 17:46:52,230 INFO  [Thread-261] [] TcpServer/7025 - LmtpServer shutting down idle thread pool
    2006-03-14 17:46:52,231 INFO  [Thread-261] [] TcpServer/110 - Pop3Server initiating shutdown
    2006-03-14 17:46:52,231 INFO  [Pop3Server] [] TcpServer/110 - finished accept loop
    2006-03-14 17:46:52,231 INFO  [Thread-261] [] TcpServer/110 - Pop3Server shutting down idle thread pool
    2006-03-14 17:46:52,231 INFO  [Thread-261] [] TcpServer/995 - Pop3Server initiating shutdown
    2006-03-14 17:46:52,232 INFO  [Pop3Server] [] TcpServer/995 - finished accept loop
    2006-03-14 17:46:52,232 INFO  [Thread-261] [] TcpServer/995 - Pop3Server shutting down idle thread pool
    2006-03-14 17:46:52,232 INFO  [Thread-261] [] TcpServer/143 - ImapServer initiating shutdown
    2006-03-14 17:46:52,232 INFO  [ImapServer] [] TcpServer/143 - finished accept loop
    2006-03-14 17:46:52,232 INFO  [Thread-261] [] TcpServer/143 - ImapServer shutting down idle thread pool
    2006-03-14 17:46:52,232 INFO  [Thread-261] [] TcpServer/993 - ImapSSLServer initiating shutdown
    2006-03-14 17:46:52,232 INFO  [ImapSSLServer] [] TcpServer/993 - finished accept loop
    2006-03-14 17:46:52,233 INFO  [Thread-261] [] TcpServer/993 - ImapSSLServer shutting down idle thread pool
    2006-03-14 17:46:52,233 INFO  [Thread-261] [] SessionCache - shutdown: clearing SessionCache
    2006-03-14 17:46:52,233 INFO  [IndexWritersSweeper] [] MailboxIndex - IndexWritersSweeper thread exiting
    2006-03-14 17:46:52,233 INFO  [Thread-261] [] MailboxIndex - Flushing all open index writers
    2006-03-14 17:46:52,235 INFO  [Thread-263] [] im - Executing IMEvent: com.zimbra.cs.im.IMNullEvent@73bc22
    2006-03-14 17:46:52,352 INFO  [Thread-261] [] RedoLogManager - Logged: 8 items, 2.0ms/item
    2006-03-14 17:46:52,353 INFO  [IncomingDirectorySweeper] [] FileBlobStore - IncomingDirectorySweeper thread exiting
    2006-03-14 17:46:52,353 INFO  [Thread-261] [] extensions - Destroying extensions
    2006-03-14 17:46:52,376 INFO  [Thread-261] [] extensions - Destroyed extension clamscanner: com.zimbra.clam.ClamScanner@com.zimbra.cs.extension.ZimbraExtensionClassLoader@68cd79
    2006-03-14 17:46:52,377 INFO  [Thread-261] [] ContentServlet - Servlet ContentServlet shutting down
    2006-03-14 17:46:52,377 INFO  [Thread-261] [] PublicICalServlet - Servlet PublicICalServlet shutting down
    2006-03-14 17:46:52,379 INFO  [Thread-261] [] soap - Servlet SoapServlet shutting down
    2006-03-14 17:46:52,379 INFO  [Thread-261] [] account - Servlet PreAuthServlet shutting down
    2006-03-14 17:46:52,380 INFO  [Thread-261] [] mailbox - Servlet UserServlet shutting down
    2006-03-14 17:46:52,380 INFO  [Thread-261] [] FileUploadServlet - Servlet FileUploadServlet shutting down
    Can see the reference to redolog but don't see an error (not that I really know what I'm looking at/for). As you can see from the excerpt at the top the rights on the redo.log file change after the stop command.

  4. #14
    Crexis's Avatar
    Crexis is offline Senior Member
    Join Date
    Feb 2006
    Posts
    54
    Rep Power
    9

    Default

    Hello, just wondering if you've thrown your hands up on this one or are deep in thought? Let me know if I can provide more info/logs from the box. Thanks.

  5. #15
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Are you always using the zimbra user to stop/start?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  6. #16
    Crexis's Avatar
    Crexis is offline Senior Member
    Join Date
    Feb 2006
    Posts
    54
    Rep Power
    9

    Default

    Quote Originally Posted by KevinH
    Are you always using the zimbra user to stop/start?
    That would be a definate yes. When I manually stop/start, I do it after an "su - zimbra"

  7. #17
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Hard to say what's going on then. Doesn't seem like anyone else is having this problem.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  8. #18
    Crexis's Avatar
    Crexis is offline Senior Member
    Join Date
    Feb 2006
    Posts
    54
    Rep Power
    9

    Default

    Ok, I appreciate that it's not really worth your while to devote time to a problem that only one person is having. Especially when there's so much else going on

    Please could you provide a little more help on this issue? I have an idea for a workaround but I'm not sure how viable it is.

    Could I stick a chown & chmod command at the end of the zmcontrol stop script? I think it would need to run under some kind of sudo type thing as it would need root rights to execute. I have absolutely no clue as to what the syntax for that would be. Only other issue that occurs to me is that if I do an upgrade the zmcontrol script may be overwritten meaning I would have to re-insert those commands. Would you be able to help me with the syntax for those commands or at least confirm it's efficacy?

    TIA

  9. #19
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Since we have no idea why your permissions keep changing it's hard to say if adding a chmod will even fix it. It's worth a shot so feel free to try it.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  10. #20
    phalen is offline Junior Member
    Join Date
    Apr 2006
    Posts
    6
    Rep Power
    9

    Default

    I am having this issue on a SLES9 server (OSS version). The box is at work so I will check the logs tomorrow to see if I can see anything in the logs.

    phalen

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 210
    Last Post: 01-17-2012, 01:19 AM
  2. Upgrade Trouble woooo
    By RobertW in forum Installation
    Replies: 3
    Last Post: 06-15-2006, 05:24 PM
  3. Tomcat hanging
    By Morg0 in forum Administrators
    Replies: 42
    Last Post: 04-19-2006, 08:06 PM
  4. Replies: 14
    Last Post: 12-22-2005, 04:59 PM
  5. Mailbox Stopped
    By jono in forum Installation
    Replies: 23
    Last Post: 11-24-2005, 10:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •