Results 1 to 7 of 7

Thread: Zimbra LDAP with Squid

  1. #1
    fnetmohan is offline Active Member
    Join Date
    Apr 2008
    Location
    Chennai
    Posts
    25
    Rep Power
    7

    Default Zimbra LDAP with Squid

    Hi All,

    I am currently using the Zimbra 5.0.5_GA Open source version. I would like to integrate the LDAP authentication for squid with zimbra ldap.

    The below line i have included in squid.conf file but it is not working. Can someone please help me to configure?

    auth_param basic program /usr/lib/squid/squid_ldap_auth -b "dc=example,dc=com" -f "uid=%s" -h ldap.example.com

    from the below url, i have done changes in squid file but it is not working.

    Configure squid for LDAP authentication using squid_ldap_auth helper


    Thanks,
    Mohan. U
    Last edited by mmorse; 05-13-2008 at 08:29 AM. Reason: url stuck in moderation

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Welcome to the forums

    Do you get any sort of error message in your squid log files ? Are you using the correct DC combination for your ZCS LDAP server ?

  3. #3
    fnetmohan is offline Active Member
    Join Date
    Apr 2008
    Location
    Chennai
    Posts
    25
    Rep Power
    7

    Default

    Hi uxbod,

    I didn't find any error message in squid log file. The DC combination is also seems to be correct. Can you help the syntax which we can check the DC combination is working right or wrong?

    Thanks,
    Mohan. U

  4. #4
    goabaskar is offline Junior Member
    Join Date
    Jun 2007
    Location
    Chennai, INDIA
    Posts
    5
    Rep Power
    8

    Default

    Hi,

    You can try this

    /usr/lib/squid/squid_ldap_auth -v 3 -b dc=zimbra,dc=example,dc=com -f "(&(uid=%s)(objectClass=zimbraAccount))" -h zimbra.example.com

    M.Baskar

  5. #5
    fnetmohan is offline Active Member
    Join Date
    Apr 2008
    Location
    Chennai
    Posts
    25
    Rep Power
    7

    Default

    Hi,

    Thanks. It's working great

    Regards,
    Mohan. U

  6. #6
    begeto is offline Starter Member
    Join Date
    Sep 2008
    Posts
    1
    Rep Power
    6

    Default

    Quote Originally Posted by fnetmohan View Post
    Hi,

    Thanks. It's working great

    Regards,
    Mohan. U
    didn't work for me!!!

  7. #7
    kkimani is offline Active Member
    Join Date
    Sep 2009
    Location
    kenya
    Posts
    31
    Rep Power
    5

    Default Zimbra LDAP with squid

    Hi,

    I have configured zimbra to be in collaboration with samba so it also acts as the domain controller. i would like to authenticate users while accessing the internet.
    I have been able to authenticate users individually and would like to do so using groups. I have been unsuccessful so far. would someone please point me to the right direction?
    "external_acl_type InetGroup %LOGIN /usr/lib/squid/squid_ldap_group -v 3 -b dc=openit,dc=co,dc=ke -f "(&(uid=%u)(objectClass=*))" -h 192.168.111.100"
    i would like to use the groups i have created in posix .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 31
    Last Post: 12-15-2007, 09:05 PM
  2. [SOLVED] Error Installing Zimbra on RHEL 5
    By harris7139 in forum Installation
    Replies: 10
    Last Post: 09-25-2007, 11:39 AM
  3. upgrade woes -made into new thread
    By JustinHarlow in forum Installation
    Replies: 18
    Last Post: 06-08-2007, 12:11 PM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  5. Replies: 16
    Last Post: 09-07-2006, 06:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •