Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: unable to get zmmailboxdctl running after trying to change the pop3 port

  1. #11
    mannes is offline Active Member
    Join Date
    Sep 2007
    Posts
    36
    Rep Power
    7

    Default

    dns records and the machine name are properly configured, as well as the hostname entry

    what about this:

    CompilerOracle: exclude com/zimbra/cs/session/SessionMap.putAndPrune
    0 INFO [main] log - Logging to org.slf4j.impl.Log4jLoggerAdapter(org.mortbay.log) via org.mortbay.log.Slf4jLog
    Zimbra server reserving server socket port=110 bindaddr=110 ssl=false
    Fatal error: exception while binding to ports
    java.net.BindException: Cannot assign requested address
    at java.net.PlainSocketImpl.socketBind(Native Method)
    at java.net.PlainSocketImpl.bind(PlainSocketImpl.java :359)
    at java.net.ServerSocket.bind(ServerSocket.java:319)
    at com.zimbra.common.util.NetUtil.newBoundServerSocke t(NetUtil.java:106)

  2. #12
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Code:
    su - zimbra
    zmprov gs server.domain.com | grep BindPort

  3. #13
    mannes is offline Active Member
    Join Date
    Sep 2007
    Posts
    36
    Rep Power
    7

    Default

    [zimbra@dce-lam06 log]$ zmprov gs dce-lam06.pentalog.fr | grep BindPort
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)
    [zimbra@dce-lam06 log]$

  4. #14
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    You're getting that because the mailboxd service obviously isn't up, however your LDAP reports running so that's good.
    zmprov -l gs server.domain.com | grep BindPort
    (Lower case -l ELL to run the command via LDAP instead of SOAP.)
    Quote Originally Posted by mannes View Post
    After disabling the imap/pop proxy, the listener remained on the port 7110. I tryed to set him on the regular 110, but in doing this opperation, zmmailboxdctl refused to start after a zimbra restart.
    Is this a single server setup? - in which case you normally don't run imap/pop proxy.

    If it's single server do the following:
    zmprov -l ms server.domain.com -zimbraServiceEnabled imapproxy
    zmprov -l ms server.domain.com -zimbraServiceInstalled imapproxy
    (Notice the minus infront of -zimbraServiceEnabled, that way you can just remove one service. If you weren't to use the minus (or plus) you'd have to specify all the services desired. Just a warning because I don't want you to forget the minus and just set your box to nothing but imapproxy on accident.)

    Next, run the following all on one line:
    zmprov -l ms server.domain.com zimbraPop3BindPort 110 zimbraPop3SSLBindPort 995 zimbraPop3ProxyBindPort 7110 zimbraPop3SSLProxyBindPort 7995 zimbraImapBindPort 143 zimbraImapSSLBindPort 993 zimbraImapProxyBindPort 7143 zimbraImapSSLProxyBindPort 7993
    (Your putting a 7 in front of anything with proxy in it & correcting the ports.)

    Then:
    zmcontrol stop
    zmcontrol start

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 08:59 AM
  2. Can't seem to get global in BES
    By sdemeyer in forum Zimbra Connector for BlackBerry
    Replies: 12
    Last Post: 03-19-2008, 08:22 AM
  3. Replies: 4
    Last Post: 11-14-2007, 02:19 PM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •