Results 1 to 5 of 5

Thread: [SOLVED] "Enable POP clear text login" doesn't work in Zimbra Proxy

  1. #1
    kai.liao is offline Junior Member
    Join Date
    May 2008
    Posts
    8
    Rep Power
    7

    Default [SOLVED] "Enable POP clear text login" doesn't work in Zimbra Proxy

    Hello Experts
    I have installed 2 ZCS(5.0.5 GA Release) servers and one of them with Zimbra Proxy in it. I enabled "pop clear text login" on these 2 ZCS servers, but the server with zimbra proxy always responded with "-ERR cleartext logins disabled", the other one without zimbra proxy worked well.
    I checked conf/nginx.conf and found that it doesn't change to enable clear text login in zimbra proxy. I think this function is not applied on zimbra proxy.
    Can zimbra experts tell me how to enable clear text login in zimbra proxy?


    conf/nginx.conf

    server {
    listen 110;
    protocol pop3;
    proxy on;
    sasl_service_name "pop";
    # starttls=on implies cleartext login enabled
    # starttls=only implies cleartext login requires SSL/TLS
    starttls only;
    Last edited by kai.liao; 05-07-2008 at 07:25 PM.

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Welcome to the forums

    To check the setting do
    Code:
    su - zimbra
    zmprov gs zcs.server.name | grep zimbraReverseProxyPop3StartTlsMode
    I am sure it will be set to only, so to change that do
    Code:
    zmprov ms zcs.server.name zimbraReverseProxyPop3StartTlsMode=on

  3. #3
    kai.liao is offline Junior Member
    Join Date
    May 2008
    Posts
    8
    Rep Power
    7

    Default

    Thanks a lot. It worked. It should be added on UI.

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Feel free to raise a RFE

  5. #5
    cciardi is offline Member
    Join Date
    Aug 2007
    Posts
    10
    Rep Power
    8

    Default

    Take the '=' sign out of the code line. so line should read. Thanks for the quick fix. I also ran into the same issue with IMAP and clear text login. Second code line addresses that.

    Code:
    zmprov ms zcs.server.name zimbraReverseProxyPop3StartTlsMode on

    zmprov ms zcs.server.name zimbraReverseProxyImapStartTlsMode on
    Last edited by cciardi; 05-08-2008 at 09:53 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. slapd message error
    By smoke in forum Administrators
    Replies: 7
    Last Post: 04-27-2008, 03:23 PM
  2. Replies: 22
    Last Post: 12-02-2007, 05:05 PM
  3. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  4. Replies: 8
    Last Post: 02-27-2007, 04:10 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •