Results 1 to 9 of 9

Thread: Delivery disabled ?

  1. #1
    Nic
    Nic is offline Intermediate Member
    Join Date
    Mar 2008
    Location
    France
    Posts
    17
    Rep Power
    7

    Default Delivery disabled ?

    Hello all,

    Since a week, or more, emails are temporarily not delivred to some mailbox


    mailbox.log file

    Code:
    2008-04-24 13:36:12,449 INFO  [LmtpServer-9977] [name=r.n@mydomain.com;] ZimbraLmtpBackend - accepted and discarded message for y.m@mydomain.com: local delivery is disabled
    and zimbra.log at the same time

    Code:
    Apr 24 13:36:06 zimbra postfix/qmgr[4771]: 66ADC1254B9F: from=<do-1187-8000324-5642856-9--y.m@mydomain.com@return.do08.net>, size=11960, nrcpt=1 (queue active)
    Apr 24 13:36:06 zimbra amavis[20131]: (20131-07) ESMTP::10024 /opt/zimbra/amavisd/tmp/amavis-20080424T131934-20131: <do-1187-8000324-5642856-9--y.m@mydomain.com@return.do08.net> -> <yy.m@mydomain.com> SIZE=11960 BODY=8BITMIME Received: from zimbra.vet-lyon.fr ([127.0.0.1]) by localhost (zimbra.vet-lyon.fr [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <y.monlien@vet-lyon.fr>; Thu, 24 Apr 2008 13:36:06 +0200 (CEST)
    Apr 24 13:36:07 zimbra amavis[20131]: (20131-07) Checking: 0lhu3GMcM2GK [192.168.20.252] <do-1187-8000324-5642856-9--y.m@mydomain.com@return.do08.net> -> <y.m@mydomain.com>
    Apr 24 13:36:12 zimbra amavis[20131]: (20131-07) FWD via SMTP: <do-1187-8000324-5642856-9--y.m@mydomain.com@return.do08.net> -> <y.m@mydomain.com>, BODY=8BITMIME 250 2.6.0 Ok, id=20131-07, from MTA([127.0.0.1]:10025): 250 Ok: queued as 03E6C125499D
    Apr 24 13:36:12 zimbra postfix/qmgr[4771]: 03E6C125499D: from=<do-1187-8000324-5642856-9--y.m@mydomain.com@return.do08.net>, size=11636, nrcpt=1 (queue active)
    Apr 24 13:36:12 zimbra amavis[20131]: (20131-07) Passed CLEAN, LOCAL [192.168.*.*] [80.118.49.244] <do-1187-8000324-5642856-9--y.m@mydomain.com@return.do08.net> -> <y.m@mydomain.com>, Message-ID: <48107094.000006DF@pm49-244.do09.net>, mail_id: 0lhu3GMcM2GK, Hits: -2.046, queued_as: 03E6C125499D, 5601 ms
    Apr 24 13:36:12 zimbra postfix/smtp[21894]: 66ADC1254B9F: to=<y.m@mydomain.com>, relay=127.0.0.1[127.0.0.1], delay=6, status=sent (250 2.6.0 Ok, id=20131-07, from MTA([127.0.0.1]:10025): 250 Ok: queued as 03E6C125499D)
    Apr 24 13:36:12 zimbra postfix/lmtp[21898]: 03E6C125499D: to=<y.m@mydomain.com>, relay=zimbra.vet-lyon.fr[192.168.20.2], delay=0, status=sent (250 2.1.5 OK)


    I don't find anything about this on the forum.

    Thanks in advance for your help

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,568
    Rep Power
    57

    Default

    Which operating system is this and which version/release of Zimbra.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Nic
    Nic is offline Intermediate Member
    Join Date
    Mar 2008
    Location
    France
    Posts
    17
    Rep Power
    7

    Default

    Sorry I forgot

    I'm running zimbra opensource edition 4.5.6 on red Hat enterprise 4 (zcs-4.5.6_GA_1044.RHEL4)

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,568
    Rep Power
    57

    Default

    Check the file descriptors settings from this thread: [SOLVED] Mail deferred due to too many files open and see if that's your problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Nic
    Nic is offline Intermediate Member
    Join Date
    Mar 2008
    Location
    France
    Posts
    17
    Rep Power
    7

    Default

    Seems to be same problem

    On my system I've got this results:

    [root@zimbra ~]# ulimit -n
    1024
    [root@zimbra ~]# su - zimbra
    [zimbra@zimbra ~]$ ulimit -n
    10000
    Last edited by Nic; 04-24-2008 at 08:22 AM.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,568
    Rep Power
    57

    Default

    You can update the limits as described in that thread, this is also fixed in Zimbra 5.0.5
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Nic
    Nic is offline Intermediate Member
    Join Date
    Mar 2008
    Location
    France
    Posts
    17
    Rep Power
    7

    Default

    Sorry but I'm not sure how following that :

    nano /etc/pam.d/su
    Uncomment/remove the # so a line reads:
    session required pam_limits.so

    nano /etc/pam.d/common-session
    Make it read:
    session required pam_limits.so

    Check the /etc/security/limits.conf as well

    zmcontrol stop
    zmcontrol start
    I don't have the "session required pam_limits.so" line in /etc/pam.d/su . Should I add it ?

    I don't have /etc/pam.d/common-session file ...

    My /etc/security/limits.conf have lines zimbra soft nofile 10000 and zimbra hard nofile 10000, do I need to change both values to 524288 ?

    Thank you for your help
    Last edited by Nic; 04-25-2008 at 07:29 AM.

  8. #8
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Quote Originally Posted by Nic View Post
    Since a week, or more, emails are temporarily not delivred to some mailbox
    mailbox.log file
    2008-04-24 13:36:12,449 INFO [LmtpServer-9977] [name=r.n@mydomain.com;] ZimbraLmtpBackend - accepted and discarded message for y.m@mydomain.com: local delivery is disabled
    and zimbra.log at the same time
    Code:
    Apr 24 13:36:06 zimbra postfix/qmgr[4771]: 66ADC1254B9F: from=<do-1187-8000324-5642856-9--y.m@mydomain.com@return.do08.net>, size=11960, nrcpt=1 (queue active)
    Apr 24 13:36:06 zimbra amavis[20131]: (20131-07) ESMTP::10024 /opt/zimbra/amavisd/tmp/amavis-20080424T131934-20131: <do-1187-8000324-5642856-9--y.m@mydomain.com@return.do08.net> -> <yy.m@mydomain.com> SIZE=11960 BODY=8BITMIME Received: from zimbra.vet-lyon.fr ([127.0.0.1]) by localhost (zimbra.vet-lyon.fr [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <y.monlien@vet-lyon.fr>; Thu, 24 Apr 2008 13:36:06 +0200 (CEST)
    Apr 24 13:36:07 zimbra amavis[20131]: (20131-07) Checking: 0lhu3GMcM2GK [192.168.20.252] <do-1187-8000324-5642856-9--y.m@mydomain.com@return.do08.net> -> <y.m@mydomain.com>
    Apr 24 13:36:12 zimbra amavis[20131]: (20131-07) FWD via SMTP: <do-1187-8000324-5642856-9--y.m@mydomain.com@return.do08.net> -> <y.m@mydomain.com>, BODY=8BITMIME 250 2.6.0 Ok, id=20131-07, from MTA([127.0.0.1]:10025): 250 Ok: queued as 03E6C125499D
    Apr 24 13:36:12 zimbra postfix/qmgr[4771]: 03E6C125499D: from=<do-1187-8000324-5642856-9--y.m@mydomain.com@return.do08.net>, size=11636, nrcpt=1 (queue active)
    Apr 24 13:36:12 zimbra amavis[20131]: (20131-07) Passed CLEAN, LOCAL [192.168.*.*] [80.118.49.244] <do-1187-8000324-5642856-9--y.m@mydomain.com@return.do08.net> -> <y.m@mydomain.com>, Message-ID: <48107094.000006DF@pm49-244.do09.net>, mail_id: 0lhu3GMcM2GK, Hits: -2.046, queued_as: 03E6C125499D, 5601 ms
    Apr 24 13:36:12 zimbra postfix/smtp[21894]: 66ADC1254B9F: to=<y.m@mydomain.com>, relay=127.0.0.1[127.0.0.1], delay=6, status=sent (250 2.6.0 Ok, id=20131-07, from MTA([127.0.0.1]:10025): 250 Ok: queued as 03E6C125499D)
    Apr 24 13:36:12 zimbra postfix/lmtp[21898]: 03E6C125499D: to=<y.m@mydomain.com>, relay=zimbra.vet-lyon.fr[192.168.20.2], delay=0, status=sent (250 2.1.5 OK)
    It really looks like the user is just forwarding & has the 'disable local delivery box' unchecked in their options tab > mail tab
    Or via your admin console gui > forwarding tab

    CLI:
    su - zimbra
    zmprov ga y.m@mydomain.com | grep zimbraPrefMailLocalDeliveryDisabled

    If it's TRUE, you can change that by:
    zmprov ma y.m@mydomain.com zimbraPrefMailLocalDeliveryDisabled FALSE

    Note: Your outgoing forward might be differed if you entered the wrong address, or the server you're forwarding to is down or wont accept the mail etc.

    Quote Originally Posted by Nic View Post
    I'm running zimbra opensource edition 4.5.6 on red Hat enterprise 4 (zcs-4.5.6_GA_1044.RHEL4)
    I would highly suggest updating to 4.5.11 first, then 5.0.5 when you get a chance. (No need to stop of at 4.5./7.8/.9/.10 or 5.0.0/.1/.2/.3/.4)
    Don't forget to take backups each time!
    4.5.11 & 5.0.2 Released!
    5.0.5 is Released!
    Last edited by mmorse; 04-26-2008 at 12:53 PM.

  9. #9
    Nic
    Nic is offline Intermediate Member
    Join Date
    Mar 2008
    Location
    France
    Posts
    17
    Rep Power
    7

    Default

    Thank you for the reply mmorse

    PrefMailLocalDeliveryDisabled is set to FALSE for y.m@mydomain.com ... Very strange ...
    According with him, he has made no change on his account ...

    So, I'm planning to upgrade to 4.5.11 and 5.0.5 as soon as possible ;-)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 04-16-2008, 11:00 AM
  2. Replies: 45
    Last Post: 11-28-2007, 06:39 PM
  3. Perceived delay in message delivery
    By dwlogical in forum Administrators
    Replies: 0
    Last Post: 09-10-2007, 02:09 PM
  4. [SOLVED] Zimbra/Samba integration: posix user not created
    By bucketoftruth in forum Administrators
    Replies: 9
    Last Post: 09-08-2007, 12:17 AM
  5. Replies: 1
    Last Post: 08-13-2007, 10:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •