Results 1 to 9 of 9

Thread: Rewrite urls in multimailbox install!

  1. #1
    inotabi is offline Active Member
    Join Date
    Mar 2008
    Posts
    29
    Rep Power
    7

    Default Rewrite urls in multimailbox install!

    Dear all,
    We're on mutilmailbox install including 2 mailbox server: mail1.abc.com and mail2.abc.com. Our virtual hosting address is: mail.abc.com. Each time, users login via mail.abc.com, they are redirected to their mailbox server and on address bar displaying their url mailbox server. Do you any ways to rewrite this url, make users transparent to mail.abc.com (They only see mail.abc.com)? Could you help me showing the right direction to go?

    Thanks,

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    We have HTTP proxying in 5.0.5. You might want to try that.

  3. #3
    inotabi is offline Active Member
    Join Date
    Mar 2008
    Posts
    29
    Rep Power
    7

    Default

    Thanks jholder,
    I'll try it.

  4. #4
    inotabi is offline Active Member
    Join Date
    Mar 2008
    Posts
    29
    Rep Power
    7

    Default

    Sorry Jholder. I don't see any documents about HTTP Proxying in 5.0.5. Can you show me your guides?

    Regards,

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Quote Originally Posted by inotabi View Post
    Sorry Jholder. I don't see any documents about HTTP Proxying in 5.0.5. Can you show me your guides?

    Regards,
    Zimbra Proxy Guide - Zimbra :: Wiki
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    inotabi is offline Active Member
    Join Date
    Mar 2008
    Posts
    29
    Rep Power
    7

    Default

    Hi Phoenix,
    It is for POP/IMAP connections. I'm looking forward using Load Balancing on ZCS 5.0 (accessing via Zimbra Web Client Browser).
    At present, Our users can access to browser at http://mail.abc.com, but later, http://mail.abc.com be redirected to http://mail2.abc.com. Do you have any ways to rewrite the url to http://mail.abc.com and the users never see http://mail2.abc.com.

    Thanks for regards,

  7. #7
    su_A_ve is offline Advanced Member
    Join Date
    Dec 2006
    Posts
    183
    Rep Power
    8

    Default

    here's an option... Provide HTTP(s) Integration with Apache - Zimbra :: Wiki

    Not sure how this would work on multiple servers though...

  8. #8
    inotabi is offline Active Member
    Join Date
    Mar 2008
    Posts
    29
    Rep Power
    7

    Default

    I also think it wouldn't work on multiple mailbox servers installation. :-)
    Anyway???

  9. #9
    inotabi is offline Active Member
    Join Date
    Mar 2008
    Posts
    29
    Rep Power
    7

    Default

    I see the solution for the problem at admin document or OSmulti-server-install 5.0.6 (not see in 5.0.5). However, it is unclear. If i have 2 mailbox server (has been setup with IMAP/POP proxy server) and i want to use http proxy, must i install zimbra-proxy package on both mailbox servers or only enable http proxy on the current IMAP/POP proxy?
    To enable the proxy for the web, document ask to type:
    /opt/zimbra/libexec/zmproxyinit -e -w proxy.node.service.hostname

    I don't understand what does "proxy.node.service.hostname" mean? Is it hostname of mailbox servers?


    Thanks for regards,
    Last edited by inotabi; 06-12-2008 at 06:24 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. install oss fc7 not run well
    By epelaez in forum Installation
    Replies: 1
    Last Post: 03-05-2008, 03:26 PM
  2. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  3. Replies: 21
    Last Post: 09-27-2007, 11:49 AM
  4. Replies: 16
    Last Post: 11-29-2006, 10:36 AM
  5. OS X Server 10.4.3 install issues
    By jono in forum Installation
    Replies: 10
    Last Post: 11-22-2005, 09:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •