Results 1 to 4 of 4

Thread: memcached and nginx pop3/imap auth problem.

  1. #1
    serivo is offline OpenSource Builder
    Join Date
    Sep 2007
    Posts
    46
    Rep Power
    7

    Default memcached and nginx pop3/imap auth problem.

    I have a strange problem with memcached. When I have commented out all memcached lines in my /opt/zimbra/conf/nginx.conf pop3 authentication works perfectly. But with these lines I have one successfull login and then during about a minute - all logins are failing When I have started memcached with -vv option, I see something like this:
    ---
    <3 server listening
    <7 new client connection
    <8 new client connection
    <8 incr ip:192.0.2.1 1
    >8 NOT_FOUND
    <8 add ip:192.0.2.1 0 60 1
    >8 STORED
    <8 incr usr:test@test.example.com 1
    >8 NOT_FOUND
    <8 add usr:test@test.example.com 0 60 1
    >8 STORED
    <8 get POP3:test@test.example.com
    >8 END
    <8 add POP3:test@test.example.com 0 3600 18
    >8 STORED
    <8 incr ip:192.0.2.1 1
    >8 2
    <8 incr usr:test@test.example.com 1
    >8 2
    <8 get POP3:test@test.example.com
    >8 sending key POP3:test@test.example.com
    >8 END
    <8 connection closed.
    <7 incr ip:192.0.2.1 1
    >7 3
    <7 incr usr:test@test.example.com 1
    >7 3
    <7 get POP3:test@test.example.com
    >7 sending key POP3:test@test.example.com
    >7 END
    <7 connection closed.
    ---
    Zimbra version 5.0.3.
    --
    WBR,
    Sergey.

  2. #2
    mansoor is offline Former Zimbran
    Join Date
    Feb 2008
    Posts
    3
    Rep Power
    7

    Default Please attach the rate limiting parameters

    Hello,

    Could you please paste the values of the following configuration directives from /opt/zimbra/conf/nginx.conf ?

    mail_login_user_max
    mail_login_user_ttl
    mail_login_ip_max
    mail_login_ip_ttl

    Regards,
    Mansoor Peerbhoy

  3. #3
    serivo is offline OpenSource Builder
    Join Date
    Sep 2007
    Posts
    46
    Rep Power
    7

    Default

    Quote Originally Posted by mansoor View Post
    Hello,

    Could you please paste the values of the following configuration directives from /opt/zimbra/conf/nginx.conf ?

    mail_login_user_max
    mail_login_user_ttl
    mail_login_ip_max
    mail_login_ip_ttl

    Regards,
    Mansoor Peerbhoy
    Here they are:
    ---
    # egrep '^\s*mail_login.*(max|ttl)' /opt/zimbra/conf/ngin*.conf
    /opt/zimbra/conf/nginx.conf: mail_login_ip_max 0;
    /opt/zimbra/conf/nginx.conf: mail_login_ip_ttl 3600s;
    /opt/zimbra/conf/nginx.conf: mail_login_user_max 0;
    /opt/zimbra/conf/nginx.conf: mail_login_user_ttl 3600s;
    ---

  4. #4
    mansoor is offline Former Zimbran
    Join Date
    Feb 2008
    Posts
    3
    Rep Power
    7

    Default

    Hm,

    From your config, it's clear that the rate limiting for user-logins and ip-logins is turned off. The only other use to which memcached is put, by NGINX POP/IMAP proxy, is to cache the POP/IMAP routes of users.

    Do all POP accounts face the problem of logging in ? If so, can you please paste the relevant section of nginx.log ? Also, if it is specific to a single mailbox only, was the mailbox moved from one mailhost to another ?

    Regards,
    Mansoor

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •