Results 1 to 4 of 4

Thread: external ldap authentification failed

  1. #1
    ygov1 is offline Starter Member
    Join Date
    Apr 2008
    Posts
    2
    Rep Power
    7

    Default external ldap authentification failed

    I test the Zimbra open source edition by making a fresh install on a fresh
    fedora 7(zimbra.foo.com).
    No problem to install and to connect to the admin UI.
    We have a fedora directory server installed on a different machine
    (ldp02.foo.com), so I try to authenticate the user through external LDAP
    functionality.
    No problem to configure and authenticate users with the test windows of external
    authentication.
    But when I try to connect a user with a web browser (FF2 or IE7), with the url http:// zimbra . foo .com, I can see in my log : SoapEngine - handler exception: authentication failed for foo@foo.com, account not found
    Moreover I “tcpdump” the traffic between zimbra server and external directory
    server, and the result : don’t show traffic, no more on the firewall.
    Did I miss something ?

    Configuration:
    External LDAP: ldap://ldp02.foo.com:389
    LDAP filter : (&(mail=%u@%d)(nsrole=cn=webmessagerie,dc=foo,dc=c om))
    Base search : dc=foo,dc=com

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    You have to create the user on your Zimbra server first, have you done that?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    ygov1 is offline Starter Member
    Join Date
    Apr 2008
    Posts
    2
    Rep Power
    7

    Default

    No I don't.
    Which is the goal of a directory, if we have to duplicate users ?
    Maybe integreating zimbra schema in my directory is a best idea?
    Thanks.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    Quote Originally Posted by ygov1 View Post
    No I don't.
    Which is the goal of a directory, if we have to duplicate users ?
    There's an RFE in bugzilla for automatic provisioning if you want to vote on it.

    Quote Originally Posted by ygov1 View Post
    Maybe integreating zimbra schema in my directory is a best idea?
    No, you can't do that. You must provision the users in Zimbra (it's used for more than just user details).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My Zimbra server down ... please help :)
    By frankb in forum Administrators
    Replies: 2
    Last Post: 12-12-2007, 11:29 AM
  2. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 09:23 PM
  3. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  4. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  5. Replies: 4
    Last Post: 11-15-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •