Page 1 of 5 123 ... LastLast
Results 1 to 10 of 47

Thread: [SOLVED] Server statistics does not working

  1. #1
    boblin is offline Senior Member
    Join Date
    Jun 2007
    Location
    Czech Republic, Prague
    Posts
    66
    Rep Power
    8

    Default [SOLVED] Server statistics does not working

    Hi all,
    for past few weeks zimbra does not generate statistics (message count, message volume, antispam, disk).

    I don't know why.

    There is no change after upgrade from 5.0.2 to 5.0.4. Statistics still not working.

    Any help how to solve this?

    Thanks.

    Bo.
    Attached Images Attached Images

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Anything in your Log Files - Zimbra :: Wiki ?

  3. #3
    boblin is offline Senior Member
    Join Date
    Jun 2007
    Location
    Czech Republic, Prague
    Posts
    66
    Rep Power
    8

    Default

    I found there is no file:
    /opt/zimbra/log/zimbrastats.csv

    Is this ok?

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    That file should be created under /opt/zimbra/zmstats. Check for /tmp/zmlogger.out also ensure zmlogger is running so do a
    Code:
    su - zimbra
    zmcontrol status

  5. #5
    boblin is offline Senior Member
    Join Date
    Jun 2007
    Location
    Czech Republic, Prague
    Posts
    66
    Rep Power
    8

    Default

    Quote Originally Posted by uxbod View Post
    That file should be created under /opt/zimbra/zmstats. Check for /tmp/zmlogger.out
    $ ls /tmp/zmlogger.out
    ls: /tmp/zmlogger.out: No such file or directory

    Quote Originally Posted by uxbod View Post
    also ensure zmlogger is running so do a
    Code:
    su - zimbra
    zmcontrol status
    Stats are running:
    Code:
            antispam                Running
            antivirus               Running
            ldap                    Running
            logger                  Running
            mailbox                 Running
            mta                     Running
            snmp                    Running
            spell                   Running
            stats                   Running
    in /opt/zimbra/zmstat
    Code:
    ...
    2008-04-06
    2008-04-07
    2008-04-08
    2008-04-09
    cpu.csv
    fd.csv
    imap.csv
    mailboxd.csv
    mtaqueue.csv
    mysql.csv
    pid
    pop3.csv
    proc.csv
    soap.csv
    threads.csv
    vm.csv
    zmstat.out
    i found some errors in zmstat.out, but maybe this is not a problem
    Code:
    Warning: Not possible to monitor process stats
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=**** --database=z
    imbra --batch --skip-column-names'. at /opt/zimbra/zimbramon/lib/Zimbra/DB/DB.pm line 73.
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException dog.ucetn
    ictvi-on-line.cz:389)
    Warning: Not possible to monitor process stats
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=******* --database=z
    imbra --batch --skip-column-names'. at /opt/zimbra/zimbramon/lib/Zimbra/DB/DB.pm line 73.
    Warning: Not possible to monitor process stats
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    Warning: Not possible to monitor process stats
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    Warning: Not possible to monitor process stats
    04/09/2008 15:47:00: ERROR: No such process: '17252'
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    Warning: Not possible to monitor process stats
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    Warning: Not possible to monitor process stats
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    Warning: Not possible to monitor process stats
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    Warning: Not possible to monitor process stats
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    Warning: Not possible to monitor process stats
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    Warning: Not possible to monitor process stats
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    No iostat installed on this host at /opt/zimbra/libexec/zmstat-io line 29.
    Warning: Not possible to monitor process stats
    04/10/2008 12:16:30: ERROR: No such process: '16235'
    Thanks for help!

  6. #6
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Two things :-

    1) apt-get install sysstat <- that will install iostat for you
    2) Hmmm, looks like the password is incorrect for the zimbra_logger database.

    So, run the following :-

    Code:
    su - zimbra
    zmlocalconfig -s | grep -i mysql | grep -i logger
    You should see the password for that database. You can then run
    Code:
    mysql --socket=/opt/zimbra/logger/db/mysql.sock -p
    Enter the password and see if it connects you. If not you can then follow Resetting LDAP & MySQL Passwords - Zimbra :: Wiki

  7. #7
    boblin is offline Senior Member
    Join Date
    Jun 2007
    Location
    Czech Republic, Prague
    Posts
    66
    Rep Power
    8

    Default

    Quote Originally Posted by uxbod View Post
    Two things :-

    1) apt-get install sysstat <- that will install iostat for you
    ..now is installed.


    Quote Originally Posted by uxbod View Post
    2) Hmmm, looks like the password is incorrect for the zimbra_logger database.

    So, run the following :-

    Code:
    su - zimbra
    zmlocalconfig -s | grep -i mysql | grep -i logger
    You should see the password for that database. You can then run
    Code:
    mysql --socket=/opt/zimbra/logger/db/mysql.sock -p
    Enter the password and see if it connects you. If not you can then follow Resetting LDAP & MySQL Passwords - Zimbra :: Wiki
    Password from zmlocalconfig (zimbra_logger_mysql_password) is OK. But i see in zmstat.out different password (maybe some old password?).

  8. #8
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Hmmm, could you check to see what MySQL processes are running
    Code:
    ps auxww | grep sql | grep logger
    . Perhaps their is a old MySQL process running.

    I would then look at resetting the MySQL passwords for the logger as the next step.

  9. #9
    boblin is offline Senior Member
    Join Date
    Jun 2007
    Location
    Czech Republic, Prague
    Posts
    66
    Rep Power
    8

    Default

    Code:
    $ ps auxww | grep sql | grep logger
    zimbra   16350  0.0  0.0   3048  1544 ?        S    02:44   0:00 /bin/sh /opt/zimbra/logger/mysql/bin/mysqld_safe --defaults-file=/opt/zimbra/conf/my.logger.cnf --external-locking --ledir=/opt/zimbra/logger/mysql/libexec
    zimbra   16394  0.0  0.7 101792 15296 ?        Sl   02:44   0:06 /opt/zimbra/logger/mysql/libexec/mysqld --defaults-file=/opt/zimbra/conf/my.logger.cnf --basedir=/opt/zimbra/logger/mysql --datadir=/opt/zimbra/logger/db/data --pid-file=/opt/zimbra/logger/db/mysql.pid --skip-external-locking --port=7307 --socket=/opt/zimbra/logger/db/mysql.sock --external-locking
    
    $ zmmylogpasswd newpasswd
    * Changed zimbra mysql user password

    .. i will wait if it helps

  10. #10
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    stop and start the logger service aswell after the password change.

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. server statistics for disk usage
    By melody in forum Administrators
    Replies: 2
    Last Post: 03-27-2008, 06:28 AM
  2. XMPP server to server not working
    By Spliff in forum Administrators
    Replies: 3
    Last Post: 01-31-2008, 10:48 AM
  3. [Network Edition Trial] OS X Installation
    By dmg in forum Installation
    Replies: 4
    Last Post: 02-07-2007, 05:25 PM
  4. Intallation on FC5
    By rsharpe in forum Installation
    Replies: 24
    Last Post: 06-13-2006, 05:15 AM
  5. Send mail to test server, not working
    By eXtremeSG in forum Administrators
    Replies: 10
    Last Post: 02-16-2006, 08:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •