Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: install not work

  1. #1
    rungsun is offline Intermediate Member
    Join Date
    Feb 2008
    Posts
    24
    Rep Power
    7

    Default install not work

    Dear All

    you introduce install zimbra step by step.
    I try install zimbra on centos 5.1 not work.

    tar xzvf zcs-5.0.4_GA_2101.RHEL5.20080321150546.tgz

    You appear to be installing packages on a platform different
    than the platform for which they were built.

    This platform is CentOS5
    Packages found: RHEL5
    This may or may not work.

    Installation can not continue without manual override.
    You can override this safety check with ./install.sh --platform-override

    WARNING: Bypassing this check may result in an install or
    upgrade that is NOT usable.



    thak you

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    That's because CentOS isn't supported. RHEL is. I'm not going to get into another debate, but they're not the same. They may be compatible, but they're different. One is supported, the other is not.

    However, you can override it, by following the instructions.

  3. #3
    raj's Avatar
    raj
    raj is offline Moderator
    Join Date
    Oct 2005
    Location
    USA, Canada and India
    Posts
    777
    Rep Power
    10

    Default

    Hi..do the following and try the install after that

    ** for CentOS 5 please install the following Prereq's
    # yum install libidn curl fetchmail gmp compat-libstdc++-296 compat-libstdc++-33 compat-db libtool-ltdl

    ** Settings needed in CentOS 5 before install
    1) Edit the /etc/sudoers and comment out “defaults requiretty” (put # in front of it).
    2) Edit the /etc/sysconfig/i18n and delete the line LANG=”en_US.UTF-8”.
    3) Edit the /etc/redhat-release file
    replace:
    CentOS release 5 (Final)
    With
    Red Hat Enterprise Linux ES release 5 (Nahant Update x)

    ** you can replace it back to orignal after zimbra install
    ** Reboot the server

    after you do the above you should be able to install.

    Raj
    i2k2 Networks
    Dedicated & Shared Zimbra Hosting Provider

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    or just do :-

    Code:
    ./install.sh --platform-override
    as the instructions say.

  5. #5
    rungsun is offline Intermediate Member
    Join Date
    Feb 2008
    Posts
    24
    Rep Power
    7

    Default

    thak you

    I install zimbra success but apple zimbra popup error

    * CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes]
    Save config in file: [/opt/zimbra/config.6123]
    Saving config in /opt/zimbra/config.6123...done.
    The system will be modified - continue? [No] y
    Operations logged to /tmp/zmsetup.03272008-074004.log
    Setting local config values...done.
    Setting up CA...done.
    Deploying CA to /opt/zimbra/conf/ca ...done.
    Creating SSL certificate...done.
    Installing SSL certificates...done.
    Initializing ldap...failed. (28416)


    ERROR



    Configuration failed

    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration.

    Errors have been logged to /tmp/zmsetup.03272008-074004.log

  6. #6
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    could you post the error messages from /tmp/zmsetup.03272008-074004.log please.

  7. #7
    rungsun is offline Intermediate Member
    Join Date
    Feb 2008
    Posts
    24
    Rep Power
    7

    Default

    Error log

    [root@linux tmp]# vi zmsetup.log
    Operations logged to /tmp/zmsetup.03272008-081926.log
    Getting installed packages
    checking isEnabled zimbra-core
    zimbra-core not in enabled cache
    enabled packages
    Newinstall enabling all installed packages
    Enabling zimbra-core
    Enabling zimbra-ldap
    Enabling zimbra-store
    Enabling zimbra-mta
    Enabling zimbra-snmp
    Enabling zimbra-logger
    Enabling zimbra-apache
    Enabling zimbra-spell
    Setting defaults...
    Setting local config zimbra_java_home to /opt/zimbra/java
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_java_home='/opt/zimbra/java' 2> /dev/null
    checking isEnabled zimbra-cluster
    zimbra-cluster not in enabled cache
    enabled packages zimbra-logger zimbra-store zimbra-mta zimbra-core zimbra-apache zimbra-snmp zimbra-ldap zimbra-spell
    Newinstall enabling all installed packages
    Enabling zimbra-core
    Enabling zimbra-ldap
    "zmsetup.log" 235L, 10156C

  8. #8
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    you only posted the zmsetup.log so would you please post /tmp/zmsetup.03272008-081926.log as that should contain the really useful information

    a useful link Log Files - Zimbra :: Wiki
    Last edited by uxbod; 03-27-2008 at 01:33 AM.

  9. #9
    rungsun is offline Intermediate Member
    Join Date
    Feb 2008
    Posts
    24
    Rep Power
    7

    Default

    vi zmsetup.03272008-072239.log


    Initializing ldap...
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    sudo: /etc/sudoers is mode 0777, should be 0440
    sudo: /etc/sudoers is mode 0777, should be 0440
    sudo: /etc/sudoers is mode 0777, should be 0440
    sudo: /etc/sudoers is mode 0777, should be 0440
    sudo: /etc/sudoers is mode 0777, should be 0440
    sudo: /etc/sudoers is mode 0777, should be 0440
    sudo: /etc/sudoers is mode 0777, should be 0440
    IO::Socket::INET: connect: Connection refused at /opt/zimbra/libexec/zmldapinit line 160.
    failed. (28416)


    ERROR

  10. #10
    rungsun is offline Intermediate Member
    Join Date
    Feb 2008
    Posts
    24
    Rep Power
    7

    Default

    I am install zimbra server sucess.
    I am https://mail.thaisekson.com:7071/zimbraAdmin not work.
    How setup zimbra server ?

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. install oss fc7 not run well
    By epelaez in forum Installation
    Replies: 1
    Last Post: 03-05-2008, 03:26 PM
  2. Replies: 21
    Last Post: 09-27-2007, 11:49 AM
  3. Replies: 16
    Last Post: 11-29-2006, 10:36 AM
  4. Calendar Only Install, Would this work?
    By asv in forum Installation
    Replies: 3
    Last Post: 11-20-2006, 04:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •