Results 1 to 3 of 3

Thread: [SOLVED] Backup says SUCCESS...reality - who knows?

  1. #1
    Centurion's Avatar
    Centurion is offline Active Member
    Join Date
    Apr 2007
    Location
    NSW, Australia
    Posts
    38
    Rep Power
    7

    Default [SOLVED] Backup says SUCCESS...reality - who knows?

    Hi All,

    As of the upgrade from 4.5.6_GA Network Ed to 4.5.10 we noticed the backups seem to be giving some odd output for the full backups:

    Mail Subject: ZCS Backup Report: SUCCESS

    Mail Body:
    Server: mail.office.our.fqdn

    Label: full-20080323.140009.371
    Type: full
    Status: completed
    Started: Mon, 2008/03/24 01:00:09.371 EST
    Ended: Mon, 2008/03/24 01:00:09.445 EST
    Redo log sequence range: -1 .. ?
    Number of accounts: 0

    However, the incremental backups show the following:

    Mail Subject: ZCS Backup Report: SUCCESS

    Mail Body:
    Server: mail.office.our.fqdn

    Label: incr-20080323.140008.888
    Type: incremental
    Status: completed
    Started: Mon, 2008/03/24 01:00:08.888 EST
    Ended: Mon, 2008/03/24 01:00:09.364 EST
    Redo log sequence range: 334 .. 334
    Number of accounts: 27

    The weird thing is that running a full backup from the command line appears to have the desired effect and fully backs up all our accounts/schema etc. The other weird thing is that these backups (incremental and full) are running at the same time but I can't see how (see below)....locking issue?

    #
    # Backups
    #
    # BACKUP BEGIN
    0 1 * * 6 /opt/zimbra/bin/zmbackup -f -a all
    0 1 * * 0-5 /opt/zimbra/bin/zmbackup -i -a all
    0 0 * * * /opt/zimbra/bin/zmbackup -del 1m
    # BACKUP END


    We're planning on moving to 5.0.3_GA Network Ed, but the "powers that be" are reluctant to do so until we've isolated and rectified the backup problem. I've explained that a cold dump of /opt/zimbra is the best backup we can have (and is done before the upgrade anyway) but they want to fix the automated backups before then (we rsync the /opt/zimbra/backup directory off-site and that's the added insurance they want).

    Cheers,

    James
    Last edited by Centurion; 03-23-2008 at 04:37 PM. Reason: Added Zimbra crontab stub.

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    You're hitting a 4.5.x bug: Bug 20785 - Full backup starts everyday
    I would suggest upgrading to 5.0.2 (if you're running a LDAP replica I highly suggest you step through 4.5.11 first).
    Taking an rsync backup can't hurt:
    su - zimbra
    zmcontrol stop
    switch back to root
    mkdir /backuprsync (wherever)
    rsync -avHK /opt/zimbra/ /backuprsync/zimbra
    You can also force a full: CLI - zmbackup Network Edition Only - Zimbra :: Wiki
    4.5.11 & 5.0.2 Released!

  3. #3
    Centurion's Avatar
    Centurion is offline Active Member
    Join Date
    Apr 2007
    Location
    NSW, Australia
    Posts
    38
    Rep Power
    7

    Cool Thanks

    Excellent. This is all I really needed to know. It's a bug in 4.5.10, gone in 5.0.3. I've done a test migration between those two versions on my test system and it went through without a problem. I'll pass this along and I'm sure the command line backup followed by a cold rsync will satisfy our requirement for roll-back and/or disaster recovery

    Cheers,

    James

    PS - please mark as solved.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 658
    Last Post: 04-04-2014, 09:01 AM
  2. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  3. FYI: ZCS NE backup to fuse/sshfs mount, worked.
    By jagipson in forum Administrators
    Replies: 0
    Last Post: 09-28-2007, 06:37 AM
  4. Backup best practice
    By Eyfi in forum Administrators
    Replies: 2
    Last Post: 06-29-2007, 07:52 AM
  5. NE Backup best practises
    By Klug in forum Administrators
    Replies: 3
    Last Post: 05-29-2006, 08:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •