Results 1 to 5 of 5

Thread: Pre-Compiled DBD::mysql PERL Module?

  1. #1
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    10

    Default Pre-Compiled DBD::mysql PERL Module?

    Has anyone compiled this perl module against the environment used for the Zimbra mysql version used in 32-bit 4.5.11 on SLES9?

    We'd like to see if we can't tweak my.cnf by seeing the output from the mysqlreport utility.

    mysqlreport uses this perl module to query mysql, but, (surprise) it doesn't work with the DBD::mysql module provided by SLES9.

    More info on using this neat script is at:
    The Guide To Understanding mysqlreport

    Someone inside Zimbra have this per chance? :-)

    Thanks!
    Mark

  2. #2
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    Just use the procompiled one that ships with ZCS. /opt/zimbra/zimbramon/lib/i586-linux-thread-multi/DBD/mysql.pm

    Code:
    use lib "/opt/zimbra/zimbramon/lib";
    use DBD::mysql;
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    10

    Default

    Quote Originally Posted by brian View Post
    Just use the procompiled one that ships with ZCS. /opt/zimbra/zimbramon/lib/i586-linux-thread-multi/DBD/mysql.pm

    Code:
    use lib "/opt/zimbra/zimbramon/lib";
    use DBD::mysql;
    Hi Brian,

    Progress, but no joy yet:

    viognier:~ # /home/lmstone/mysqlreport/mysqlreport --user zimbra --password <snip> --host localhost --port 7306 --socket /opt/zimbra/db/mysql.sock

    install_driver(mysql) failed: DBD::mysql object version 2.9003 does not match bootstrap parameter 4.005 at /usr/lib/perl5/5.8.3/i586-linux-thread-multi/DynaLoader.pm line 249.
    Compilation failed in require at (eval 5) line 3.

    at /home/lmstone/mysqlreport/mysqlreport line 148
    viognier:~ # locate DynaLoader.pm
    /usr/lib/perl5/5.8.3/i586-linux-thread-multi/DynaLoader.pm

    I'm not a perl expert, but at least with the DBD::mysql module a locate showed both your version and the SuSE version. With Dynaloader.pm, I see only the SuSE version.

    Thanks,
    Mark

  4. #4
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    Sorry, probably want to do

    use DBI;
    instead of
    use DBD::msyql; directly.

    I've never used mysqlreport so not sure what its trying to call directly.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #5
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    10

    Default

    Quote Originally Posted by brian View Post
    Sorry, probably want to do

    use DBI;
    instead of
    use DBD::msyql; directly.

    I've never used mysqlreport so not sure what its trying to call directly.

    Brian,

    Thanks but, as I mentioned, I'm a perl newbie!

    I use mysqlreport because I just have to run the script, enter the username, password, port and email address to which I want the report sent, and mysqlreport does the rest.

    It really is a neat tool and worth a look; my first post in this thread has a link to author's web site.

    Thanks,
    Mark

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Antivirus is blocking emails in deffered queue
    By sergiumartin in forum Administrators
    Replies: 15
    Last Post: 07-14-2007, 03:04 PM
  2. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  3. Configuring and using DSPAM
    By JoshuaPrismon in forum Administrators
    Replies: 55
    Last Post: 03-02-2007, 09:08 AM
  4. Problems when making and installing Perl
    By wildhuman in forum Developers
    Replies: 10
    Last Post: 09-08-2006, 05:36 AM
  5. Help Please... Zimbra error message too slow...
    By nazeeronline in forum Installation
    Replies: 20
    Last Post: 09-06-2006, 05:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •