Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: [SOLVED] "Public service host name" in domain creation

  1. #21
    fyd
    fyd is offline Elite Member
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    4

    Default

    Quote Originally Posted by MACscr View Post
    Is there not a per server or global option instead of having to always set this per domain?

    Also, i have zmtlsctl mode set to https, yet its still giving out urls to shared contacts for example in http form. Why is that?
    Hi, check zimbraPublicServiceProtocol and zimbraPublicServicePort in your server config.

    # su - zimbra
    $ zmprov gs `zmhostname` zimbraPublicServiceProtocol
    $ zmprov gs `zmhostname` zimbraPublicServicePort

    Try setting both to https and 443

    $ zmprov ms `zmhostname` zimbraPublicServiceProtocol https
    $ zmprov ms `zmhostname` zimbraPublicServicePort 443

  2. #22
    MACscr is offline Special Member
    Join Date
    Jun 2010
    Posts
    126
    Rep Power
    5

    Default

    Quote Originally Posted by fyd View Post
    Hi, check zimbraPublicServiceProtocol and zimbraPublicServicePort in your server config.

    # su - zimbra
    $ zmprov gs `zmhostname` zimbraPublicServiceProtocol
    $ zmprov gs `zmhostname` zimbraPublicServicePort

    Try setting both to https and 443

    $ zmprov ms `zmhostname` zimbraPublicServiceProtocol https
    $ zmprov ms `zmhostname` zimbraPublicServicePort 443
    zimbra@wheelie:/root$ zmprov ms 'wheelie.blah.com' zimbraPublicServiceProtocol https
    ERROR: service.INVALID_REQUEST (invalid request: LDAP schema violation: [LDAP: error code 65 - attribute 'zimbraPublicServiceProtocol' not allowed])
    zimbra@wheelie:/root$ zmprov ms 'wheelie.blah.com' zimbraPublicServicePort 443
    ERROR: service.INVALID_REQUEST (invalid request: LDAP schema violation: [LDAP: error code 65 - attribute 'zimbraPublicServicePort' not allowed])

    So basically im assuming this cant be done globally or per server =/
    Last edited by MACscr; 02-16-2012 at 09:59 AM.

  3. #23
    alexvg75 is offline New Member
    Join Date
    Feb 2012
    Posts
    3
    Rep Power
    3

    Default

    $ zmprov md `zmhostname` zimbraPublicServiceProtocol https
    $ zmprov md `zmhostname` zimbraPublicServicePort 443

  4. #24
    MACscr is offline Special Member
    Join Date
    Jun 2010
    Posts
    126
    Rep Power
    5

    Default

    Quote Originally Posted by alexvg75 View Post
    $ zmprov md `zmhostname` zimbraPublicServiceProtocol https
    $ zmprov md `zmhostname` zimbraPublicServicePort 443
    Unfortunately thats not done for the hostname, that has to be done per domain. My question was being able to do to it globally/set a default for the server so I dont have to manually set those settings everytime a domain is added to the server. From what I am seeing, thats not possible.

  5. #25
    alexvg75 is offline New Member
    Join Date
    Feb 2012
    Posts
    3
    Rep Power
    3

    Default

    May be zmtlsctl [mode]?
    Or via admin console set global settings for the individual services (pop, imap)?
    Last edited by alexvg75; 02-17-2012 at 07:33 AM.

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 04-27-2009, 02:49 AM
  2. zmclamdctl is not running after upgrade
    By Darren in forum Installation
    Replies: 24
    Last Post: 10-10-2008, 09:10 AM
  3. Suddenly loads of errors in my daily report
    By BarefootPanda in forum Administrators
    Replies: 1
    Last Post: 07-21-2008, 04:09 AM
  4. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  5. GAL not working with Active Directory
    By ardiederich in forum Installation
    Replies: 13
    Last Post: 02-12-2008, 08:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •