Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 45

Thread: Changing localhost (localhost.localdomain [127.0.0.1]) in message headers

  1. #31
    tikal is offline Senior Member
    Join Date
    Mar 2008
    Location
    Seattle
    Posts
    52
    Rep Power
    7

    Default

    Yes, localhost and localhost.localdomain are still there in the headers.

    Here is what I have been experimenting with in postfix_header_checks.in:

    /^Received:.*localhost/ IGNORE
    /^Received:.*127\.0\.0\.1/ IGNORE
    /^Received:.*from localhost (localhost.localdomain [127.0.0.1])/ IGNORE

    Evidently not having .* is important as it throws errors if you don't have it.

    This link was where I got some ideas from:
    http://www.mail-archive.com/plug@lis.../msg10578.html

    However he has spaces after his Received: lines then .*
    Received: .*
    I think it should be
    Received:.*
    You can see that he gets errors at the top of his post. I do as well if I have the word "from" more than twice.

  2. #32
    tikal is offline Senior Member
    Join Date
    Mar 2008
    Location
    Seattle
    Posts
    52
    Rep Power
    7

    Default

    This could be part of my problem as I am trying to remove a "From" part of message headers.

    From:
    Postfix manual - header_checks(5)

    Message headers added by the cleanup(8) daemon itself are excluded from inspection. Examples of such message headers are From:, To:, Message-ID:, Date:.

    When I tried to send a message with a certain Subject: line that I had blocked in the header checks it threw an error in the webmail GUI. To me this means that the header checks are taking place, but the cleanup daemon is re-adding or wont let me take out the from localhost:
    Last edited by tikal; 03-17-2008 at 03:19 PM.

  3. #33
    iskondi is offline Intermediate Member
    Join Date
    Mar 2008
    Posts
    15
    Rep Power
    7

    Default I'm having the same issue...

    Hey guys, just stumbled across this thread and I'm having the same thing show up in my outbound emails and would like to clean em up.

    Here is an example of internet headers from zimbra to a yahoo email address:

    X-Apparently-To: septurious_iskondi@yahoo.com via 69.147.97.42; Tue, 18 Mar 2008 19:21:36 -0700
    X-YahooFilteredBulk: 207.47.42.18
    X-Originating-IP: [207.47.42.18]
    Return-Path: <davidl@matissenetworks.com>
    Authentication-Results: mta132.mail.re2.yahoo.com from=matissenetworks.com; domainkeys=neutral (no sig)
    Received: from 207.47.42.18 (EHLO hydra.matissenetworks.com) (207.47.42.18) by mta132.mail.re2.yahoo.com with SMTP; Tue, 18 Mar 2008 19:21:36 -0700
    Received: from localhost (localhost.localdomain [127.0.0.1]) by hydra.matissenetworks.com (Postfix) with ESMTP id 664AFAF8563 for <septurious_iskondi@yahoo.com>; Tue, 18 Mar 2008 19:21:36 -0700 (PDT)
    X-Virus-Scanned: amavisd-new at
    X-Spam-Flag: NO
    X-Spam-Score: -0.999
    X-Spam-Level:
    X-Spam-Status: No, score=-0.999 tagged_above=-10 required=6.6 tests=[AWL=-1.100, BAYES_50=0.001, RDNS_NONE=0.1]
    Received: from hydra.matissenetworks.com ([127.0.0.1]) by localhost (hydra.matissenetworks.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id lIY50OcYtQKg for <septurious_iskondi@yahoo.com>; Tue, 18 Mar 2008 19:21:36 -0700 (PDT)
    Received: from hydra.matissenetworks.com (hydra.matissenetworks.com [192.168.1.48]) by hydra.matissenetworks.com (Postfix) with ESMTP id 2EBE1AF84E8 for <septurious_iskondi@yahoo.com>; Tue, 18 Mar 2008 19:21:36 -0700 (PDT)
    Date: Tue, 18 Mar 2008 19:21:36 -0700 (PDT)
    From: "David Levinger" <davidl@matissenetworks.com> Add Mobile Alert
    To: "septurious iskondi" <septurious_iskondi@yahoo.com>
    Message-ID: <7709700.69341205893296148.JavaMail.root@hydra.mat issenetworks.com>
    Subject: How about now?
    MIME-Version: 1.0
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: 7bit
    X-Originating-IP: [192.168.100.165]
    Content-Length: 13


    Here is an example of internet headers from gmail to the same yahoo email address:

    X-Apparently-To: septurious_iskondi@yahoo.com via 69.147.97.48; Tue, 18 Mar 2008 19:42:42 -0700
    X-Originating-IP: [209.85.132.248]
    Return-Path: <iskondi@gmail.com>
    Authentication-Results: mta202.mail.re4.yahoo.com from=gmail.com; domainkeys=pass (ok)
    Received: from 209.85.132.248 (EHLO an-out-0708.google.com) (209.85.132.248) by mta202.mail.re4.yahoo.com with SMTP; Tue, 18 Mar 2008 19:42:42 -0700
    Received: by an-out-0708.google.com with SMTP id c28so58000ana.67 for <septurious_iskondi@yahoo.com>; Tue, 18 Mar 2008 19:42:42 -0700 (PDT)
    DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=beta; h=domainkey-signature:received:received:message-id:date:from:to:subject:mime-version:content-type; bh=Rwpe9V8WhSAPu24tM8CsA/9/rwBLgC6QYRluS7Irqzw=; b=cOhP3xIrY8SerAJuA7Uq3QWpxn/GO9k63bPEVIxaulelUjfGCxG4t41bC+GRclfdsGFMHBzmJ9cuY CwfMuNKr93DcRVLlYjrHAS3cfkdcXbzL62Tyn+hHVXsfbQIZSS WIsIed1II5jwcDPzAmOinNJVJj1byHYlUWdkoT7QI0e8=
    DomainKey-Signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=message-id:date:from:to:subject:mime-version:content-type; b=ExKBR7l7iQpqNRJsOmGReIWDikcGtSXa1n5LyspU8I6bWf9t c7OdO7ikcRE+ymB0iBolEnTJ1Mg+25uHfusb+lmG8idPBLZJiO uuQIGFPvZBQw7/IwrzT27SmKgQtlYjT2t5w4qHtBSbnMgm8gLGeQEz1xeeEiKKuz 2uhIF6F0U=
    Received: by 10.100.112.9 with SMTP id k9mr807333anc.78.1205894562306; Tue, 18 Mar 2008 19:42:42 -0700 (PDT)
    Received: by 10.100.10.14 with HTTP; Tue, 18 Mar 2008 19:42:42 -0700 (PDT)
    Message-ID: <30c7f2560803181942v786f0231q5c6b7a2729eea0a1@mail .gmail.com>
    Date: Tue, 18 Mar 2008 19:42:42 -0700
    From: "David Levinger" <iskondi@gmail.com> Add Mobile Alert
    Yahoo! DomainKeys has confirmed that this message was sent by gmail.com. Learn more
    To: septurious_iskondi@yahoo.com
    Subject: Checking on headers
    MIME-Version: 1.0
    Content-Type: multipart/alternative; boundary="----=_Part_15219_2901791.1205894562312"
    Content-Length: 378


    How can we clean up the outgoing headers to omit all of the unneeded X-headers (like X-Originating-IP and X-Virus-Scanned) as well as removing all references to localhost?
    The main reason we're so concerned is that our mail is getting marked as spam and we've had customers say they didn't receive our mail, which probably means their spam filter dropped it entirely.
    Either way we'd like to clean up the headers and look much more like gmail.

    Thanks in advance guys,
    David

  4. #34
    tikal is offline Senior Member
    Join Date
    Mar 2008
    Location
    Seattle
    Posts
    52
    Rep Power
    7

    Default

    You can turn off X-Originating IP in the Zimbra admin web GUI.

    Click on Global Settings, then click on MTA.

    You will see a check box for add X-Originating IP to messages.

    I am still trying to figure out how to remove localhost.localdomain from the message headers. Does anyone else have any ideas?
    Last edited by tikal; 03-18-2008 at 08:56 PM.

  5. #35
    iskondi is offline Intermediate Member
    Join Date
    Mar 2008
    Posts
    15
    Rep Power
    7

    Default

    Yup! That worked for the X-Originating IP but I too am still trying to get rid of the localhost stuff.

    Anyone out there have some other things we can try?

    David

  6. #36
    mjp
    mjp is offline Active Member
    Join Date
    Feb 2008
    Location
    Austria
    Posts
    32
    Rep Power
    7

    Default

    if the header_checks really do not work (perhaps they are run before amavis) you could try the amavis config. I think there is an option to prevent amavis from adding headers. But can't remember exactly so you'd have to search for it...
    regards

  7. #37
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    The headers will be being added by Postfix IMHO. I have a MTA in-front of Zimbra, as I use MailScanner to pre-process, but I am stripping headers with Postfix so will check them. I am not home till tomorrow night so cannot test it out myself until then. Sorry

  8. #38
    tikal is offline Senior Member
    Join Date
    Mar 2008
    Location
    Seattle
    Posts
    52
    Rep Power
    7

    Default

    I figured out how to remove the Amavis headers that say localhost and 127.0.0.1 that are injected into emails.

    Open /opt/zimbra/amavisd/sbin/amavisd

    Find:

    $append_header_fields_to_bottom

    $prepend_header_fields_hdridx

    $remove_existing_x_scanned_headers

    $remove_existing_spam_headers

    Make sure they are all set to 0 [zero] and the Amavis headers should be gone after you restart the MTA.

    I also learned that if you install zimbra and you have localhost.mydomain.com in your hosts file, the install still works fine, and your message headers will say 127.0.0.1 localhost.mydomain.com instead of localhost.localdomain.

    However, that dosent help me much as I would rather them say myhostname.mydomain.com and at least my LAN ip address but would prefer my public WAN ip address.

    Is there anybody on this forum that can help with this matter?
    Last edited by tikal; 03-24-2008 at 03:33 PM.

  9. #39
    iskondi is offline Intermediate Member
    Join Date
    Mar 2008
    Posts
    15
    Rep Power
    7

    Default

    Hey Tikal,

    What you suggested actually added another localhost header for me...

    from hydra.matissenetworks.com ([127.0.0.1]) by localhost (hydra.matissenetworks.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id OH0EddAEpcNU for <septurious_iskondi@yahoo.com>; Mon, 24 Mar 2008 16:04:34 -0700 (PDT)

    The ones I want to get rid of are:

    Received: from localhost (localhost.localdomain [127.0.0.1]) by hydra.matissenetworks.com (Postfix) with ESMTP id 99102AF8562 for <septurious_iskondi@yahoo.com>; Tue, 18 Mar 2008 19:19:36 -0700 (PDT)

    Received: from hydra.matissenetworks.com ([127.0.0.1]) by localhost (hydra.matissenetworks.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id HqK+60z91w48 for <septurious_iskondi@yahoo.com>; Tue, 18 Mar 2008 19:19:36 -0700 (PDT)

    Received: from hydra.matissenetworks.com (hydra.matissenetworks.com [192.168.1.48]) by hydra.matissenetworks.com (Postfix) with ESMTP id 5D6B2AF84E8 for <septurious_iskondi@yahoo.com>; Tue, 18 Mar 2008 19:19:36 -0700 (PDT)

    If there is someone out there that can assist I'd greatly appreciate it!

    Thanks,

    Iskondi

  10. #40
    tikal is offline Senior Member
    Join Date
    Mar 2008
    Location
    Seattle
    Posts
    52
    Rep Power
    7

    Default

    Sorry to hear that. Making those changes on a Debian 4 test setup worked for me.

Page 4 of 5 FirstFirst ... 2345 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Why is Tomcat shuting down ever nights?
    By trapanator in forum Administrators
    Replies: 2
    Last Post: 11-30-2006, 11:57 PM
  2. fetchmail: SMTP< 250 Ok: queued as
    By daly1 in forum Installation
    Replies: 4
    Last Post: 08-04-2006, 04:23 AM
  3. Problem sending mails
    By fmodola in forum Administrators
    Replies: 3
    Last Post: 04-12-2006, 08:39 AM
  4. MTA is Dying after yum update
    By tonyawbrey in forum Administrators
    Replies: 27
    Last Post: 04-02-2006, 06:11 PM
  5. emails don't show up in inbox in browser
    By pstelzer in forum Installation
    Replies: 10
    Last Post: 12-13-2005, 10:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •