Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 45

Thread: Changing localhost (localhost.localdomain [127.0.0.1]) in message headers

  1. #11
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Okay zmmta.cf is actually in /opt/zimbra/conf. As Postfix is already performing header checks you can just add the IGNORE line to the file /opt/zimbra/conf/postfix_header_checks and then do a postfix reload.

  2. #12
    tikal is offline Senior Member
    Join Date
    Mar 2008
    Location
    Seattle
    Posts
    52
    Rep Power
    7

    Default

    After I added:
    echo "/^Received: from 127.0.0.1/ IGNORE" > header_checks
    to the file /opt/zimbra/conf/postfix_header_checks and did a postfix reload the changes I made to the file were gone. What shoud I do?

  3. #13
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    The file you want is postfix_header_checks.in
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #14
    tikal is offline Senior Member
    Join Date
    Mar 2008
    Location
    Seattle
    Posts
    52
    Rep Power
    7

    Default

    just so I make sure i understand correctly, should i be adding this whole line to postfix_header_checks.in?

    Code:
    echo "/^Received: from 127.0.0.1/  	IGNORE" > header_checks
    or just:
    Code:
    IGNORE" > header_checks

  5. #15
    mjp
    mjp is offline Active Member
    Join Date
    Feb 2008
    Location
    Austria
    Posts
    32
    Rep Power
    7

    Default

    you want the the first one.
    regards

  6. #16
    tikal is offline Senior Member
    Join Date
    Mar 2008
    Location
    Seattle
    Posts
    52
    Rep Power
    7

    Default

    ok well i added
    echo "/^Received: from 127.0.0.1/ IGNORE" > header_checks
    to postfix_header_checks.in and did a postfix reload and the changes to the file were still saved after reload. I sent a message from a test account to my gmail account and all the headers looked the same as before.

  7. #17
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    can you post the headers as the regex may require tweaking ?

  8. #18
    tikal is offline Senior Member
    Join Date
    Mar 2008
    Location
    Seattle
    Posts
    52
    Rep Power
    7

    Default

    Delivered-To: me@my-email.com
    Received: by 10.142.171.20 with SMTP id t20cs111629wfe;
    Sun, 16 Mar 2008 04:05:28 -0700 (PDT)
    Received: by 10.100.140.2 with SMTP id n2mr8189498and.115.1205665527744;
    Sun, 16 Mar 2008 04:05:27 -0700 (PDT)
    Return-Path: <test@testaccount.com>
    Received: from QMTA01.emeryville.ca.mail.comcast.net (qmta01.emeryville.ca.mail.comcast.net [76.96.30.16])
    by mx.google.com with ESMTP id j13si5682684rne.16.2008.03.16.04.05.26;
    Sun, 16 Mar 2008 04:05:27 -0700 (PDT)
    Received-SPF: neutral (google.com: 76.96.30.16 is neither permitted nor denied by best guess record for domain of test@testaccount.com) client-ip=76.96.30.16;
    Authentication-Results: mx.google.com; spf=neutral (google.com: 76.96.30.16 is neither permitted nor denied by best guess record for domain of test@testaccount.com) smtp.mail=test@testaccount.com
    Received: from OMTA11.emeryville.ca.mail.comcast.net ([76.96.30.36])
    by QMTA01.emeryville.ca.mail.comcast.net with comcast
    id 1n1f1Z0030mlR8UA100B00; Sun, 16 Mar 2008 11:04:33 +0000
    Received: from hostname.serverdomain.net ([Public IP])
    by OMTA11.emeryville.ca.mail.comcast.net with comcast
    id 1n5S1Z0014WvaLr8X00000; Sun, 16 Mar 2008 11:05:26 +0000
    X-Authority-Analysis: v=1.0 c=1 a=GfgsIE7YKycUsJPX8fwA:9
    a=W5_n38A0yy-UdlJK9UNwPW5uOyoA:4 a=XF7b4UCPwd8A:10 a=B4wIy5B8x_4V8FaCJIwA:9
    a=WDkidrgk2Hp06zSlv5EA:7 a=I8Rq0ix1ZePGwSMUL4oddnhxhOAA:4 a=37WNUvjkh6kA:10
    Received: from localhost (localhost.localdomain [127.0.0.1])
    by hostname.serverdomain.net (Postfix) with ESMTP id 139C1248130
    for <test@testaccount.com>; Sun, 16 Mar 2008 04:05:25 -0700 (PDT)
    X-Virus-Scanned: amavisd-new at
    X-Spam-Flag: NO
    X-Spam-Score: -3.098
    X-Spam-Level:
    X-Spam-Status: No, score=-3.098 tagged_above=-10 required=6.6
    tests=[ALL_TRUSTED=-1.8, AWL=1.300, BAYES_00=-2.599,
    HTML_MESSAGE=0.001]
    Received: from hostname.serverdomain.net ([127.0.0.1])
    by localhost (hostname.serverdomain.net [127.0.0.1]) (amavisd-new, port 10024)
    with ESMTP id aT7WXjtcPWrs for <test@testaccount.com>;
    Sun, 16 Mar 2008 04:05:19 -0700 (PDT)
    Received: from hostname.serverdomain.net (hostname.serverdomain.net [192.168.1.30])
    by hostname.serverdomain.net (Postfix) with ESMTP id 2043424812E
    for <test@testaccount.com>; Sun, 16 Mar 2008 04:05:19 -0700 (PDT)
    Date: Sun, 16 Mar 2008 04:05:18 -0700 (PDT)
    From: Test Account <test@testaccount.com>
    To: me@my-email.com
    Message-ID: <5057297.01205665518623.JavaMail.root@hostname.ser verdomain.net>
    Subject: test message from zimbra account
    MIME-Version: 1.0
    Content-Type: multipart/alternative;
    boundary="----=_Part_0_32187507.1205665518579"
    X-Originating-IP: [192.168.1.99]

    ------=_Part_0_32187507.1205665518579
    Content-Type: text/plain; charset=utf-8
    Content-Transfer-Encoding: 7bit
    Last edited by tikal; 03-17-2008 at 04:35 AM.

  9. #19
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Okay change the line to :-

    Code:
    echo "/^Received: from localhost/ IGNORE" > header_checks
    and reload Postfix again.

  10. #20
    tikal is offline Senior Member
    Join Date
    Mar 2008
    Location
    Seattle
    Posts
    52
    Rep Power
    7

    Default

    putting that in /opt/zimbra/conf/postfix_header_checks.in did not do anything. The headers in another test message look identical to what I posted above.

    Maybe I should restart the whole server and try another test message?

Page 2 of 5 FirstFirst 1234 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Why is Tomcat shuting down ever nights?
    By trapanator in forum Administrators
    Replies: 2
    Last Post: 11-30-2006, 11:57 PM
  2. fetchmail: SMTP< 250 Ok: queued as
    By daly1 in forum Installation
    Replies: 4
    Last Post: 08-04-2006, 04:23 AM
  3. Problem sending mails
    By fmodola in forum Administrators
    Replies: 3
    Last Post: 04-12-2006, 08:39 AM
  4. MTA is Dying after yum update
    By tonyawbrey in forum Administrators
    Replies: 27
    Last Post: 04-02-2006, 06:11 PM
  5. emails don't show up in inbox in browser
    By pstelzer in forum Installation
    Replies: 10
    Last Post: 12-13-2005, 10:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •