I've got quite a bit of experience with Zimbra since about 4.0 or so, and have been more or less happy with it.

This deployment is a fresh 5.0GA build, and I've noticed that every day or so, only pop3 craps out, while everything else performs fantastically. Its not really viable to have to login and restart zimbra services that frequently.

Transcripts of a POP3 connection during the problem and after follow...

+OK POP3 ready
USER test@test.com
+OK
PASS test
-ERR internal server error
Connection to host lost.

then I restart zimbra services (zmcontrol stop, zmcontrol start)
+OK POP3 ready
USER test@test.com
+OK
PASS test
+OK server ready

the only thing I can see in my logs are


Code:
2008-02-08 10:06:10,557 WARN  [btpool0-7 - Acceptor0 SelectChannelConnector@0.0.0.0:80] [] log - EXCEPTION
java.io.IOException: Too many open files
        at sun.nio.ch.ServerSocketChannelImpl.accept0(Native Method)
        at sun.nio.ch.ServerSocketChannelImpl.accept(ServerSocketChannelImpl.java:145)
        at org.mortbay.jetty.nio.SelectChannelConnector$1.acceptChannel(SelectChannelConnector.java:75)
        at org.mortbay.io.nio.SelectorManager$SelectSet.doSelect(SelectorManager.java:485)
        at org.mortbay.io.nio.SelectorManager.doSelect(SelectorManager.java:168)
        at org.mortbay.jetty.nio.SelectChannelConnector.accept(SelectChannelConnector.java:124)
        at org.mortbay.jetty.AbstractConnector$Acceptor.run(AbstractConnector.java:514)
        at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:442)
2008-02-08 10:06:10,558 WARN  [btpool0-7 - Acceptor0 SelectChannelConnector@0.0.0.0:80] [] log - EXCEPTION