Results 1 to 4 of 4

Thread: hypothetical restore question

  1. #1
    jeffw is offline Loyal Member
    Join Date
    Oct 2007
    Posts
    88
    Rep Power
    7

    Default hypothetical restore question

    Hi:

    If I have a tape backup of /opt/zimbra/backup from many months ago, and I need to restore one account from the backup.

    Is there any way to selectively restore parts of the full-* directory so that I don't have to restore the entire backup into /opt/zimbra/backup just to restore one mailbox?

    Thanks!

    -j

  2. #2
    Rich Graves is offline Outstanding Member
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    718
    Rep Power
    9

    Default

    Yes.

    First you need to restore ldap/, sys/, and session.xml. Find the account in ldap/ldap.bak. Note the line like zimbraId: 8726ed78-82a9-34c8-bb9a-19aa0196b660

    The account blobs and metadata are stored in a two-level hash tree based on zimbraId. Restore accounts/872/6ed/8726ed78-82a9-34c8-bb9a-19aa0196b660

  3. #3
    SPremeau is offline Intermediate Member
    Join Date
    Aug 2007
    Posts
    19
    Rep Power
    7

    Default

    This was logical to me, but what about accounts that have shared blobs?

    Are they somehow included in the accounts path too or would this skip them?

    Steve.

  4. #4
    jeffw is offline Loyal Member
    Join Date
    Oct 2007
    Posts
    88
    Rep Power
    7

    Default

    Quote Originally Posted by SPremeau View Post
    This was logical to me, but what about accounts that have shared blobs?

    Are they somehow included in the accounts path too or would this skip them?

    Steve.
    Yeah, I'm curious about that too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to restore the mail(/opt/zimbra/store)?
    By victorLeong in forum Administrators
    Replies: 11
    Last Post: 04-24-2009, 09:41 PM
  2. Disaster Recovery Restore of Zimbra on Apple OS X
    By k.beeby@albion.co.uk in forum Administrators
    Replies: 2
    Last Post: 03-11-2008, 08:40 AM
  3. [SOLVED] Zimbra 5.0.1 restore from 4.5.10
    By kpatton in forum Administrators
    Replies: 2
    Last Post: 01-17-2008, 02:04 PM
  4. Multiple Domains Question
    By kristiaan_d in forum Administrators
    Replies: 2
    Last Post: 03-14-2007, 04:38 AM
  5. Network Edition restore problems??
    By jdell in forum Administrators
    Replies: 0
    Last Post: 10-25-2006, 05:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •