Results 1 to 8 of 8

Thread: SMTP authentication problem

  1. #1
    old-cow is offline Intermediate Member
    Join Date
    Dec 2007
    Location
    China
    Posts
    22
    Rep Power
    7

    Default SMTP authentication problem

    Hi all.

    I have problem in SMTP authentication .

    My zimbra version is zcs-4.5.8_GA_1394.RHEL4 .

    My /opt/zimbra/postfix/conf/main.cf is :

    sender_canonical_maps = ldap:/opt/zimbra/conf/ldap-scm.cf
    virtual_alias_domains = ldap:/opt/zimbra/conf/ldap-vad.cf
    recipient_delimiter =
    smtpd_tls_cert_file = /opt/zimbra/conf/smtpd.crt
    smtpd_tls_auth_only = yes
    myhostname = xx.xxx.com
    virtual_mailbox_domains = ldap:/opt/zimbra/conf/ldap-vmd.cf
    mydestination = localhost
    mailbox_size_limit = 0
    smtpd_client_restrictions = reject_unauth_pipelining
    virtual_alias_maps = ldap:/opt/zimbra/conf/ldap-vam.cf
    transport_maps = ldap:/opt/zimbra/conf/ldap-transport.cf
    sendmail_path = /opt/zimbra/postfix-2.2.9/sbin/sendmail
    message_size_limit = 102400000
    broken_sasl_auth_clients = yes
    alias_maps = hash:/etc/aliases
    manpage_directory = /opt/zimbra/postfix-2.2.9/man
    smtpd_helo_required = yes
    daemon_directory = /opt/zimbra/postfix-2.2.9/libexec
    virtual_transport = error
    smtpd_recipient_restrictions = reject_non_fqdn_recipient, permit_sasl_authenticated, permit_mynetworks, reject_unlisted_recipient, reject_unauth_destination, permit
    smtpd_tls_loglevel = 1
    relayhost =
    disable_dns_lookups = no
    content_filter =
    virtual_mailbox_maps = ldap:/opt/zimbra/conf/ldap-vmm.cf
    version = 2.2.9
    mailq_path = /opt/zimbra/postfix-2.2.9/sbin/mailq
    header_checks = pcre:/opt/zimbra/conf/postfix_header_checks
    smtpd_use_tls = yes
    queue_directory = /opt/zimbra/postfix-2.2.9/spool
    newaliases_path = /opt/zimbra/postfix-2.2.9/sbin/newaliases
    smtpd_data_restrictions = reject_unauth_pipelining
    smtpd_reject_unlisted_recipient = no
    smtpd_tls_key_file = /opt/zimbra/conf/smtpd.key
    command_directory = /opt/zimbra/postfix-2.2.9/sbin
    smtpd_sasl_auth_enable = yes
    smtp_sasl_security_options = noanonymous


    [zimbra@vmk ~]$ zmprov gs xx.xx.com | grep -i Auth
    zimbraMtaAuthEnabled: TRUE
    zimbraMtaAuthHost: xx.xx.com
    zimbraMtaAuthURL: xx.com
    zimbraMtaTlsAuthOnly: TRUE
    [zimbra@vmk ~]$

    [zimbra@vmk ~]$ zmprov gs xx.xx.com | grep Mode
    zimbraMailMode: http
    [zimbra@vmk ~]$

    test by test :

    [ computing-lab ~ ]$ telnet xx.xx.com 25
    Trying xxx.xxx.xxx.xxx
    Connected to xx.xx.com
    Escape character is '^]'.
    220 xx.xx.com ESMTP Postfix
    helo
    501 Syntax: HELO hostname
    helo pp
    250 mxt.siat.ac.cn
    auth login
    538 Encryption required for requested authentication mechanism


    I setup an account in outlook , and I can send email without password.

    sometime I use outlook to send mail to outside domain from Internet, it
    say relay access denied .

    I read some wiki, but I can not fix it . can anynoe show me a way?

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    The usual reason for getting that message is an incorrect mynetworks setting, read this wiki article and follow the instructions there.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    old-cow is offline Intermediate Member
    Join Date
    Dec 2007
    Location
    China
    Posts
    22
    Rep Power
    7

    Default

    Thakns !

    The people who use this mail server do not have static IP ,
    so I think setup ZimbraMtaMyNetworks can not fix the problem.

    and I want to know the SMTP authentication do not work ?

    thanks !

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    It is necessary to have a correct mynetworks setting whether your user are on your LAN or external - you do not need to add the external IPs to that setting. Please check the link I've given you and make sure it''s correct.

    You also need to have a correct /etc/hosts file and DNS A & MX records. Run the following (on the Zimbra server):

    Code:
    host `hostname`  <-- type as-is with backticks not single quotes
    dig yourdomain.com mx
    dig yourdomain.com any
    post the output here.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    MGSteve is offline Senior Member
    Join Date
    Oct 2008
    Posts
    56
    Rep Power
    6

    Default

    Sorry to ressurect an old thread, but I've got the same problem. I see the advice above was to set the networks up, but I need SMTP authentication to be enabled for any computer on the net. Note, users must log in through SMTP authentication to send email, I don't want an open relay!

    How would I set this up?

    Update: I've added the IP address of the web server trying to send mail via the Zimbra box into the mynetworks, but it had no effect.

    [zimbra@ds-43755 ~]$ postconf mynetworks
    mynetworks = 127.0.0.0/8 79.170.0.0/16 79.170.xx.107/32

    Error log when sending mail....

    R:220 delenn.xxx.co.uk ESMTP Postfix
    S:EHLO mail.xxx.co.uk
    R:250-delenn.xxx.co.uk
    R:250-PIPELINING
    R:250-SIZE 10240000
    R:250-VRFY
    R:250-ETRN
    R:250-STARTTLS
    R:250-ENHANCEDSTATUSCODES
    R:250-8BITMIME
    R:250 DSN
    S:AUTH LOGIN
    R:538 5.7.0 Encryption required for requested authentication mechanism
    S:RSET
    R:250 2.0.0 Ok
    Last edited by MGSteve; 11-05-2008 at 11:50 AM.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Your users should not use port 25 for external user submission, you should use the correct submission port 587. There are several threads in the forums that cover the necessary setting for that and how to set authentication. You don't say which version/release of Zimbra you're using nor what you've tried and what errors/problems you're having - that information would help.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    MGSteve is offline Senior Member
    Join Date
    Oct 2008
    Posts
    56
    Rep Power
    6

    Default

    erm, port 25 is how the current mail system works! All I want is for them to have to login, I don't want / need SSL login support.

    The version is the current version, only installed it last week. I've updated my original post with some more info.

    Its running on CentOS 5.2, btw.

  8. #8
    MGSteve is offline Senior Member
    Join Date
    Oct 2008
    Posts
    56
    Rep Power
    6

    Default

    nevermind! I turned TLS Auth only off and it works fine now

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SMTP authentication problems continue
    By EdMartin in forum Installation
    Replies: 2
    Last Post: 01-11-2008, 03:23 AM
  2. [SOLVED] NE Migration: SMTP AUTH Failure
    By markpr in forum Installation
    Replies: 14
    Last Post: 10-03-2007, 12:51 PM
  3. smtp table lookup problem
    By s_c_johnson in forum Installation
    Replies: 5
    Last Post: 09-21-2007, 05:46 AM
  4. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •