Results 1 to 8 of 8

Thread: "Spam message lifetime" not work in 5.0.0

  1. #1
    KennyDeb is offline Intermediate Member
    Join Date
    Sep 2007
    Location
    Thailand
    Posts
    24
    Rep Power
    7

    Unhappy "Spam message lifetime" not work in 5.0.0

    After upgrade to 5.0.0 it not work anymore. I try to use
    Code:
    zmpurgemessages
    but it does not appear to be located in /opt/zimbra/libexec. And then i try to use
    Code:
    zmprov ModifyServer <server-name> zimbraMailPurgeSleepInterval 30d
    but it not work again. Anyone can help me please.
    Last edited by KennyDeb; 03-10-2008 at 12:13 AM.

  2. #2
    boblin is offline Senior Member
    Join Date
    Jun 2007
    Location
    Czech Republic, Prague
    Posts
    66
    Rep Power
    8

    Default

    I think that automatic purging messages (trash,junk) is also not working for me in 5.0 ;(

  3. #3
    KennyDeb is offline Intermediate Member
    Join Date
    Sep 2007
    Location
    Thailand
    Posts
    24
    Rep Power
    7

    Default

    Anyone know the solution to solve this .

  4. #4
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    01-28-2008, 08:46 PM > Today, 08:50 PM (02-07-2008) isn't 30 days so how are you testing the cleanup?
    Try setting it to: zimbraMailPurgeSleepInterval 1d
    With the lifetime at: zimbraMailTrashLifetime 30d
    (There's an zimbraPrefTrashLifetime attribute as well, but let's deal the above first because that's not exposed in interfaces yet & setting the other one takes priority over it anyways.)

  5. #5
    boblin is offline Senior Member
    Join Date
    Jun 2007
    Location
    Czech Republic, Prague
    Posts
    66
    Rep Power
    8

    Default

    Quote Originally Posted by mmorse View Post
    Try setting it to: zimbraMailPurgeSleepInterval 1d
    With the lifetime at: zimbraMailTrashLifetime 30d
    Thank's, it works!

  6. #6
    KennyDeb is offline Intermediate Member
    Join Date
    Sep 2007
    Location
    Thailand
    Posts
    24
    Rep Power
    7

    Default

    It still not work for me someone help me please.

    Code:
    zimbra@mail:~$ zmprov ModifyServer <server-name> zimbraMailPurgeSleepInterval 1d
    zimbra@mail:~$ zmprov ModifyServer <server-name> zimbraMailTrashLifetime 30d
    ERROR: service.INVALID_REQUEST (invalid request: LDAP schema violation: [LDAP: error code 65 - attribute 'zimbraMailTrashLifetime' not allowed])
    zimbra@mail:~$ zmprov getServer <server-name> zimbraMailPurgeSleepInterval
    # name <server-name>
    zimbraMailPurgeSleepInterval: 1d
    
    zimbra@mail:~$ zmprov getServer <server-name> zimbraMailTrashLifetime
    # name <server-name>
    
    zimbra@mail:~$
    Last edited by KennyDeb; 03-10-2008 at 12:22 AM.

  7. #7
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,477
    Rep Power
    56

    Default

    Quote Originally Posted by KennyDeb View Post
    It still not work for me someone help me please.
    The error is because it's a COS attribute not a server attribute.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Also, you'll want to set zimbraMailPurgeSleepInterval to a much lower value - see: [SOLVED] Timeout Policy: Spam message lifetime doesn't work

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 07-19-2007, 02:00 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  3. Replies: 42
    Last Post: 08-11-2006, 09:50 AM
  4. Replies: 4
    Last Post: 08-10-2006, 10:55 PM
  5. Replies: 12
    Last Post: 12-29-2005, 02:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •