Results 1 to 7 of 7

Thread: zmupgrade.pm -- where is it?

  1. #1
    cohnhead is offline Active Member
    Join Date
    Dec 2005
    Posts
    25
    Rep Power
    9

    Default zmupgrade.pm -- where is it? (M2-->Beta 3/M4-41)

    Hi zimbra community -

    I'm finally getting around to upgrading M2 to Beta 3 (M4 41)...

    The instructions read:
    Download the zmupgrade.pm file and copy this file to /opt/zimbra/liexec/zmupgrade.pm.
    Sorry for the dumb question -- maybe its just too late in the day ... but where do I download this file from? I've checked the forums and the download site ... nada.

    Probably should have looked at this before I started the upgrade ... now I'm Zimbra-less until I figure this out. Please advise!

    Thanks,
    Cohnhead
    Last edited by cohnhead; 01-23-2006 at 04:06 PM.

  2. #2
    bobby is offline Zimbra Employee
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    i'm not sure that it's been posted anywhere, so now it's posted here. just remove the .txt

    make sure you follow the other instructions about when to copy this file into place
    Attached Files Attached Files

  3. #3
    cohnhead is offline Active Member
    Join Date
    Dec 2005
    Posts
    25
    Rep Power
    9

    Default Thanks Bobby

    I'll let you know how the upgrade goes...

  4. #4
    cohnhead is offline Active Member
    Join Date
    Dec 2005
    Posts
    25
    Rep Power
    9

    Default upgrade complete

    You guys are unbelieveable. Thanks so much.

    Upgrade to M4 complete in less than 1 hour. Now that the file is posted above, it would have only taken about 20 minutes.

    For anyone else doing an M2 to M4 upgrade, if you've changed any of your web console ports, use this command to update zimbra:

    zmprov ms <servername> zimbraMailPort <http port> zimbraMailSSLPort <https port>
    tomcat stop
    tomcat start
    No need any more to update server.xml & web.xml manually.

    Thanks!

  5. #5
    Mike Carifio is offline Intermediate Member
    Join Date
    Dec 2005
    Posts
    19
    Rep Power
    9

    Default upgrade from an even older version...

    Do I need upgrade.pm on the upgrade from M1_21 to M4_62?
    Will install.sh do all it needs, including modify the database?
    Pl. advise. Thanks.

  6. #6
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Quote Originally Posted by Mike Carifio
    Do I need upgrade.pm on the upgrade from M1_21 to M4_62?
    Will install.sh do all it needs, including modify the database?
    Pl. advise. Thanks.
    Wow.. yeah from M1 you'll need it but I'm not sure folks have tested an upgrade from that far back. Your best bet would be to do it in two steps. M1 -> M2, then M2 -> M4. This is a one-time thing since M1 didn't have full upgrade support. See this thread for the M1 -> M2 steps and upgrade scripts.

    M1 -> M2 Upgrade Scripts
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  7. #7
    Mike Carifio is offline Intermediate Member
    Join Date
    Dec 2005
    Posts
    19
    Rep Power
    9

    Default Follow up

    I had to wait for a free Saturday before I could try this.

    M1 -> M2 -> GA worked like a charm. Well almost. I needed to
    try GA 3.0.1 twice. But the second one just worked.

    Thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •