Results 1 to 9 of 9

Thread: Signature

  1. #1
    jbd
    jbd is offline Intermediate Member
    Join Date
    Nov 2007
    Posts
    16
    Rep Power
    7

    Default Signature

    Hey,
    in the old 4.5 the signature was autom. under the mail, in 5.x I must klick it. Thats not good, I will that all User the sig have autom under the Mail.

    How can I do this?

    Jan

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    What do you have enabled in Preferences->Signatures->Using Signatures ?

  3. #3
    jbd
    jbd is offline Intermediate Member
    Join Date
    Nov 2007
    Posts
    16
    Rep Power
    7

    Default

    Signature is active in WebUI and in the backend also. But if writing a mail you must choose whether signatur (none, yout own sig)

    I hope you know what i mean.

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Okay. So do you have the signature selected on the Preferences->Accounts->Primary Account Settings page ?

  5. #5
    jbd
    jbd is offline Intermediate Member
    Join Date
    Nov 2007
    Posts
    16
    Rep Power
    7

    Default

    I think so:


  6. #6
    Rich Graves is offline Outstanding Member
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    719
    Rep Power
    9

    Default

    We also lost all signature-by-default preferences in a 4.5.10 -> 5.0.1 upgrade.

    ZCS 5 changed how signatures were handled, normalizing them out as child LDAP entries. To use a signature that is an attribute of the account object itself, zimbraPrefDefaultSignatureId attribute now needs to be set on a per-user basis. I don't see a reasonable way to force this through CoS or scripting. Each user can do it manually through the Accounts tab in Preferences.

    We upgraded this weekend and users are just starting to notice/complain now. I'll open a support case unless someone her has an idea to script signatures back on.
    Attached Images Attached Images

  7. #7
    Rich Graves is offline Outstanding Member
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    719
    Rep Power
    9

    Default

    Here's a rough fix.

    1) ldapsearch all accounts with signatures defined and enabled
    2) create a whole bunch of lines like "ma nobody@example.edu zimbraPrefDefaultSignatureId 4e597208-e230-4c91-b9ec-fbfbfb498c84"
    3) feed those lines to zmprov

    There may be some chance of enabling a signature that shouldn't have been enabled, but my assumption is that the 15% or so of my user base who bothered to define a signature probably want it used.

    Change example.edu to your domain. If you have multiple domains, you'll need to parse out the DN, or have ldapsearch give you the mail: attribute, or something.

    Code:
    /opt/zimbra/openldap/bin/ldapsearch -LLL -x -D"`/opt/zimbra/bin/zmlocalconfig -s zimbra_ldap_userdn|awk '{print $3}'`" -w"`/opt/zimbra/bin/zmlocalconfig -s zimbra_ldap_password|awk '{print $3}'`" -H `/opt/zimbra/bin/zmlocalconfig ldap_url|awk '{print $3}'` '(&(zimbraPrefMailSignature=*)(zimbraPrefMailSignatureEnabled=TRUE)(!(zimbraPrefDefaultSignatureId=*))(objectClass=zimbraAccount))' zimbraSignatureId|perl -pe 's/dn: uid=(.*),ou=people,.*\n/ma $1\@example.edu zimbraPrefDefaultSignatureId /; s/zimbraSignatureId: (.*)\n/$1/'|zmprov

  8. #8
    Rich Graves is offline Outstanding Member
    Join Date
    Jan 2007
    Location
    Minnesota
    Posts
    719
    Rep Power
    9

    Default

    You and I both missed this in the 5.0 release notes. However, this would *not* have fixed the problem.

    Upgrading from 4.5.x to 5.0 migrates the 4.5 signatures to the new 5.0
    signature format but does not delete 4.5.x user signatures. After the
    upgrade to 5.0 is complete for all ZCS servers, you must run
    migrate20071202-DeleteSignatures.pl to delete 4.5.x signatures. This
    removes the 4.5.x signature style data from LDAP. (Bug 22289)
    To run this script, as the zimbra user, type
    /opt/zimbra/libexec/scripts/migrate20071202-DeleteSignatures.pl
    The upgrade process is incomplete. Bug 17320 - Next rev of (mail) identities preferences management (server side) missed the zimbraPrefDefaultSignatureId bit.

  9. #9
    jbd
    jbd is offline Intermediate Member
    Join Date
    Nov 2007
    Posts
    16
    Rep Power
    7

    Default

    Is there same new?? A solution??

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Apply signature from outside of zimbra.
    By artimus in forum Installation
    Replies: 8
    Last Post: 12-15-2010, 12:25 PM
  2. Signature problem
    By jwilso2 in forum Developers
    Replies: 4
    Last Post: 02-20-2009, 03:16 AM
  3. Replies: 5
    Last Post: 01-25-2007, 11:38 AM
  4. Replies: 2
    Last Post: 11-15-2006, 12:23 AM
  5. Feature Request: signature from a file
    By Storm16 in forum Developers
    Replies: 1
    Last Post: 11-09-2006, 07:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •