Results 1 to 3 of 3

Thread: Process execution

  1. #1
    Nicodemus is offline Starter Member
    Join Date
    Jan 2008
    Posts
    2
    Rep Power
    7

    Default Process execution

    I come from a qmail background, where it's really easy to pipe messages to processes. I have done a bit of research and see that that's possible with postfix.However, I don't know exactly how to do this right with Zimbra. I've found some stuff on the forums and what not that sound similar, but none of it makes sense, or seems to work. Could anyone explain to me the right way to have mail for a certain address, say process@domain.com execute a script on the server? We use this in a lot of different way to tie automated systems into email. For example, we use Request Tracker for our ticketing system, and so we have an email address that normally runs the rt-mailgate program to inject the message into the remote RT server. So in qmail I have a .qmail-rt file that has "|/usr/bin/rt-mailgate ..." in it. How do I get this functionality with Zimbra?

    We're using Zimbra 4.5 Network edition still, and are waiting for 5 to have a few more releases before we upgrade.

    Thanks,
    Nate

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Cant you just have the server drop a message in postdrop?

  3. #3
    Nicodemus is offline Starter Member
    Join Date
    Jan 2008
    Posts
    2
    Rep Power
    7

    Default

    I'm not familiar with postdrop, but it sounds like it just writes out the message to a file. So are you saying that I should write a cron or something that takes those files then posts them to the command? I guess I could do that... but I still have no idea how to make an address in zimbra run postdrop. How do you do that?

    Thanks,
    Nate

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 08:59 AM
  2. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  3. Tomcat not starting after upgrade
    By scottp in forum Installation
    Replies: 4
    Last Post: 12-07-2007, 05:21 PM
  4. Replies: 4
    Last Post: 11-14-2007, 02:19 PM
  5. tomcat not running / postfix/postqueue errors
    By seravitae in forum Installation
    Replies: 7
    Last Post: 03-10-2007, 08:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •