Results 1 to 3 of 3

Thread: Restricting LDAP permissions

  1. #1
    davidfraser is offline Intermediate Member
    Join Date
    Jan 2006
    Posts
    17
    Rep Power
    9

    Default Restricting LDAP permissions

    I want to enable people to use LDAP to access their contacts from mail clients.
    I would prefer if this information were not made public though... so I want to require authentication.

    But Zimbra seems to use LDAP internally without authentication, and adding "require authc" to slapd.conf seems to stop mail sending etc from working

    LDAP Security ? suggests blocking access to LDAP with the firewall but then people can't use it externally at all

    Is there any way to configure openldap to do this or should I be filing something in bugzilla?

  2. #2
    quanah is online now Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,276
    Rep Power
    10

    Default

    A bug for this already exists:

    Bug 15378 - Obviate the need for and disallow LDAP anonymous binds

    It is not currently resolved. You can with 5.0.0 and up work on disabling anonymous access to most things by manually customizing the ACLs. I think what you are really trying to do is also tied in with:

    Bug 16601 - Secure Access To LDAP

    So you have secure connections without anonymous binds.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  3. #3
    davidfraser is offline Intermediate Member
    Join Date
    Jan 2006
    Posts
    17
    Rep Power
    9

    Default Thanks

    Yay, voted for the bugs and waiting for the switch to make it into the 5.0 series - will be much easier than trying to patch all the LDAP config myself. Thanks for the feedback...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  2. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  3. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 03:39 PM
  4. Replies: 4
    Last Post: 11-15-2006, 12:16 PM
  5. MTA is Dying after yum update
    By tonyawbrey in forum Administrators
    Replies: 27
    Last Post: 04-02-2006, 06:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •