Results 1 to 4 of 4

Thread: New Skins Don't Appear

  1. #1
    DougWare is offline Loyal Member
    Join Date
    Dec 2007
    Location
    Raleigh, NC
    Posts
    91
    Rep Power
    7

    Default New Skins Don't Appear

    Good morning,

    When we were using the RC2 release, I vaguely played around with skins. I've upgraded our development system to 5.0GA, and I've been given the task if rebranding a couple of themes to see what we can do with it.

    Here's the problem, I copied the exact steel skin directory to a new directory. So far, all I've changed are the colors and the SkinName tag. I've double checked to make sure that the SkinName tag matches the directory name I'm installing from. It shows up under the /opt/zimbra/jetty/webapps/zimbra/skins folder, but once I restart Zimbra it never shows up in the themes list.

    On this system, we are using 5.0GA Network Edition.


    [zimbra@DevMail opt]$ zmskindeploy /opt/P4Theme/
    + '[' 1 -ne 1 ']'
    + SKIN_SRC=/opt/P4Theme/
    + SKIN_WORK_BASE=/opt/zimbra/mailboxd/webapps/zimbra
    + '[' -d /opt/P4Theme/ ']'
    + SKIN_SRC_DIR=/opt/P4Theme/
    ++ basename /opt/P4Theme/
    + SKIN_NAME=P4Theme
    + SKIN_WORK_DIR=/opt/zimbra/mailboxd/webapps/zimbra/skins/P4Theme
    + '[' -e /opt/zimbra/mailboxd/webapps/zimbra/skins/P4Theme ']'
    + rm -rf /opt/zimbra/mailboxd/webapps/zimbra/skins/P4Theme
    + cp -r /opt/P4Theme/ /opt/zimbra/mailboxd/webapps/zimbra/skins/P4Theme
    ++ pwd
    ++ dirname /opt/zimbra/bin/zmskindeploy
    + BIN_ROOT=/opt//opt/zimbra/bin
    + SKIN_DEST_DIR=/opt/zimbra/mailboxd/webapps/zimbra/img/loRes/skins/P4Theme
    + '[' -e /opt/zimbra/mailboxd/webapps/zimbra/img/loRes/skins/P4Theme ']'
    + rm -rf /opt/zimbra/mailboxd/webapps/zimbra/img/loRes/skins/P4Theme
    + mkdir -p /opt/zimbra/mailboxd/webapps/zimbra/img/loRes/skins/P4Theme
    + pushd /opt/zimbra/mailboxd/webapps/zimbra/skins/P4Theme
    ~/mailboxd/webapps/zimbra/skins/P4Theme /opt
    ++ find . -type f -name '*.html'
    + sh /opt//opt/zimbra/bin/zmjava -cp /opt/zimbra/mailboxd/webapps/zimbra/WEB-INF/classes/ com.zimbra.kabuki.tools.templates.Template --prefix P4Theme --authoritative --inputdir /opt/zimbra/mailboxd/webapps/zimbra/skins/P4Theme --outputdir /opt/zimbra/mailboxd/webapps/zimbra/skins/P4Theme --
    sh: /opt//opt/zimbra/bin/zmjava: No such file or directory
    + IMAGE_SUBDIRS=
    ++ find img -type d
    + for E in '`find img -type d`'
    + '[' ']'
    + IMAGE_SUBDIRS=img
    + for E in '`find img -type d`'
    + '[' img ']'
    + IMAGE_SUBDIRS='img;'
    + IMAGE_SUBDIRS='img;img/img'
    + sh /opt//opt/zimbra/bin/zmjava -cp /opt/zimbra/mailboxd/webapps/zimbra/WEB-INF/classes/ com.zimbra.kabuki.tools.img.ImageMerge --css-path /zimbra/img/loRes/skins/P4Theme/ --css-file P4Theme.css --cache-file ../../../../skins/P4Theme/CacheLoRes.html --output /opt/zimbra/mailboxd/webapps/zimbra/img/loRes/skins/P4Theme --input 'img;img/img'
    sh: /opt//opt/zimbra/bin/zmjava: No such file or directory
    + /usr/bin/perl -pi -e 's/\@jsVersion\@/080111102942/g' CacheLoRes.html
    Can't open CacheLoRes.html: No such file or directory.
    + /usr/bin/perl -pi -e 's/\@jsVersion\@/080111102942/g' /opt/zimbra/mailboxd/webapps/zimbra/img/loRes/skins/P4Theme/P4Theme.css
    Can't open /opt/zimbra/mailboxd/webapps/zimbra/img/loRes/skins/P4Theme/P4Theme.css: No such file or directory.
    + cp /opt/zimbra/mailboxd/webapps/zimbra/img/loRes/skins/P4Theme/P4Theme.css /opt/zimbra/mailboxd/webapps/zimbra/skins/P4Theme/P4Theme_imgs.css
    cp: cannot stat `/opt/zimbra/mailboxd/webapps/zimbra/img/loRes/skins/P4Theme/P4Theme.css': No such file or directory
    + popd
    /opt

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    zmprov mcf +zimbraInstalledSkin P4Theme

  3. #3
    DougWare is offline Loyal Member
    Join Date
    Dec 2007
    Location
    Raleigh, NC
    Posts
    91
    Rep Power
    7

    Default

    I've gotten this message a couple of other times trying to set options in the admin panel on this development system.

    [zimbra@DevMail root]$ zmprov mcf +zimbraInstalledSkin P4Theme
    ERROR: service.FAILURE (system failure: unable to modify attrs: Referral limit exceeded)
    [zimbra@DevMail root]$

  4. #4
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,270
    Rep Power
    10

    Default

    Do you have more than one LDAP server?
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. installing new skins
    By santo in forum Users
    Replies: 2
    Last Post: 03-08-2007, 08:02 AM
  2. New Skins
    By Coilcore in forum Developers
    Replies: 3
    Last Post: 02-02-2007, 03:41 PM
  3. 3.2 Beta 2 M2 - New Skins Not Available
    By klarsen in forum Developers
    Replies: 1
    Last Post: 07-26-2006, 12:14 PM
  4. Skins and ALE
    By kowell in forum Administrators
    Replies: 4
    Last Post: 06-06-2006, 07:25 PM
  5. Skins / Theme Development
    By kbaker in forum Developers
    Replies: 4
    Last Post: 01-31-2006, 02:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •