Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Search & Shared Folder

  1. #1
    benanthony is offline Intermediate Member
    Join Date
    Dec 2007
    Posts
    22
    Rep Power
    7

    Default Search & Shared Folder

    I am currently importing over 200,000 messages into a central Sales inbox. I have shared the "Sales" inbox accross multiple other users, when I do a search from within the "Sales" account I get results, however when I do the same search from a user that has the Sales inbox shared I don't get any results. How long does it take for the index to be updated after a PST import and is there somewhere in the logs I can look to make sure it is happening?

    Thanks,
    Ben

  2. #2
    benanthony is offline Intermediate Member
    Join Date
    Dec 2007
    Posts
    22
    Rep Power
    7

    Default

    As a follow-up I see in the search options that you can include shared folder, I checked it and now I am getting an error everytime I try to search.

    msg: invalid request: malformed item id
    code: service.INVALID_REQUEST
    method: ZmCsfeCommand.prototype.invoke
    detail: soap:Sender

    Could this be because I am still running an import on this mailbox?

    Thanks,
    Ben

  3. #3
    benanthony is offline Intermediate Member
    Join Date
    Dec 2007
    Posts
    22
    Rep Power
    7

    Default

    Ok I am still getting this error on this mailbox. I was able to share a diffrent users mailbox and search it successfully, but once I recreate this share I get the exact same error message. Please help me figure this out, this is a show stopper for my business.

    Thanks,
    Ben

  4. #4
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default

    There should be an error in mailbox.log each time you try to search in the shared folder. Can you post that error?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #5
    benanthony is offline Intermediate Member
    Join Date
    Dec 2007
    Posts
    22
    Rep Power
    7

    Default

    Here is the error in mailbox.log

    com.zimbra.common.service.ServiceException: invalid request: malformed item ID: 1f4f840f-a8dd-4a27-8aa4-c2ee1ff8b524
    Code:service.INVALID_REQUEST
    at com.zimbra.common.service.ServiceException.INVALID _REQUEST(ServiceException.java:190)
    at com.zimbra.cs.service.util.ItemId.<init>(ItemId.ja va:89)
    at com.zimbra.cs.index.queryparser.ZimbraQueryParser. GetQuery(ZimbraQueryParser.java:202)
    at com.zimbra.cs.index.queryparser.ZimbraQueryParser. Rhs_Text(ZimbraQueryParser.java:471)
    at com.zimbra.cs.index.queryparser.ZimbraQueryParser. Clause(ZimbraQueryParser.java:944)
    at com.zimbra.cs.index.queryparser.ZimbraQueryParser. Query(ZimbraQueryParser.java:1117)
    at com.zimbra.cs.index.queryparser.ZimbraQueryParser. Clause(ZimbraQueryParser.java:728)
    at com.zimbra.cs.index.queryparser.ZimbraQueryParser. Query(ZimbraQueryParser.java:1117)
    at com.zimbra.cs.index.queryparser.ZimbraQueryParser. DoParse(ZimbraQueryParser.java:1128)
    at com.zimbra.cs.index.queryparser.ZimbraQueryParser. Parse(ZimbraQueryParser.java:308)
    at com.zimbra.cs.index.ZimbraQuery.<init>(ZimbraQuery .java:2339)
    at com.zimbra.cs.index.MailboxIndex.search(MailboxInd ex.java:147)
    at com.zimbra.cs.mailbox.Mailbox.search(Mailbox.java: 3128)
    at com.zimbra.cs.service.mail.Search.doSearch(Search. java:100)
    at com.zimbra.cs.service.mail.Search.handle(Search.ja va:72)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:347)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:213)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:118)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:272)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:174)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:487)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1093)
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA gentFilter.java:81)
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1084)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:360)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:181)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:712)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:405)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:211)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.handler.RewriteHandler.handle(Re writeHandler.java:176)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.Server.handle(Server.java:313)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:506)
    at org.mortbay.jetty.HttpConnection$RequestHandler.co ntent(HttpConnection.java:844)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:644)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:205)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:381)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:396)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:442)
    Caused by: java.lang.NumberFormatException: For input string: "a8dd-4a27-8aa4-c2ee1ff8b524"
    at java.lang.NumberFormatException.forInputString(Num berFormatException.java:48)
    at java.lang.Integer.parseInt(Integer.java:447)
    at java.lang.Integer.parseInt(Integer.java:497)
    at com.zimbra.cs.service.util.ItemId.<init>(ItemId.ja va:82)
    ... 43 more

  6. #6
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default

    This sounds like a web client bug. Can you please file a new bug in bugzilla against the web client and attach that stack trace?

    Thanks!
    Bugzilla - Wiki - Downloads - Before posting... Search!

  7. #7
    benanthony is offline Intermediate Member
    Join Date
    Dec 2007
    Posts
    22
    Rep Power
    7

    Default

    I will do that, How can I trace this error down further, I really need to find a workaround ASAP as my company has plan to roll out zimbra over the weekend. So far I have found that if I share the Inbox and subfolders for user "sales" that this error happens, but if I just share one of the subfolders it doesn't. I am going to share all the subfolder seperatly and see if it happens and then if not move the subfolders out of the inbox tree and just share it. My guess is that through the .pst import I have some sort of screwed up folder or message that is causing problems. Is there anything I can do to help me track this down faster?

    Thanks,
    Ben

  8. #8
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default

    Please file the bug with as much detail as possible. Also, if you could open the Zimbra web client debug window and include the SOAP from the failing SearchRequest in the bug report, that'd also be very helpful.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  9. #9
    benanthony is offline Intermediate Member
    Join Date
    Dec 2007
    Posts
    22
    Rep Power
    7

    Default

    I filled out the bug request. Looks to me like its using some sort of weird folder ID when there are subfolders present. I was able to isolate it to the fact that there had to be subfolders within the shared folder. So I guess the workaround is to now have shared folder with subs, but I would really like to get a fix soon. Is there a way to get a fix on this without having to upgrade to a whole new version? I am running 5.0.0 is it possible that this is already fixed in 5.0.1 and how hard is the upgrade?

    Thanks,
    Ben

  10. #10
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default

    Sorry, but if you want a Zimbra fix you'll have to wait for a real release. Thanks for filing the bug -- we'll try to reproduce it in-house and fix it.
    Bugzilla - Wiki - Downloads - Before posting... Search!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. .pst migration issues
    By jimklein in forum Migration
    Replies: 13
    Last Post: 02-16-2009, 01:55 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. can't you help me
    By iwan siahaan in forum Administrators
    Replies: 6
    Last Post: 12-17-2007, 06:53 PM
  4. Replies: 3
    Last Post: 08-11-2007, 12:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •