Results 1 to 6 of 6

Thread: Auto Expand Folders

  1. #1
    benanthony is offline Intermediate Member
    Join Date
    Dec 2007
    Posts
    22
    Rep Power
    7

    Default Auto Expand Folders

    Is there a way to set it so that all mail folders are expanded? If there isn't an option in the user interface, is there somewhere in the code (I'm running the OSS version) that I can change it so that this happens.

    Thanks,
    ben

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    You can right-click > then expand all on the top of your folder structure (pic attached)
    But it sounds like you want to vote for Bug 1920 - Persist folder tree expand/collapse state across sessions so you don't have to do it each time
    Last edited by mmorse; 04-14-2008 at 09:20 PM.

  3. #3
    Fooshnik is offline Member
    Join Date
    Dec 2009
    Posts
    12
    Rep Power
    5

    Default

    The bug shows as "Fixed". Do we know how to do this or is it a V7 fix?

  4. #4
    bdial's Avatar
    bdial is offline Moderator
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    this is a v7 feature

  5. #5
    smilodon is offline Starter Member
    Join Date
    Mar 2012
    Posts
    2
    Rep Power
    3

    Default

    It is partly fixed...

    Tryng out Zimbra here, and stumbled on this bug.

    If you create folders under your primary account and subfolders for these folders. Then the "opened" state of folders, Folder state will be saved correctly.

    However there are separators, "zimlets" and if you use child accounts with "google for +zimbraChildAccount". Then neither separators, or child accounts remeber if they should be closed or opened.

    They behave very randomly. If you create new accounts + childaccounts and view from parent account, then they are all opened. I got them all closed after logging in/out like 10 times.. and after 10 times of tryng i never could get them all be opened as default again. Then i added more child accounts, and wanted them all to be closed by default.. i never managed that either.

    All testing was done With:
    Server: Ubuntu 10.04 LTS 64bit - Zimbra 7.1
    Client: Firefox 7.0 and Google Chrome 14.0 on Debian 6 aka squeeze.

    Shortly - folders remember closed/opened state.
    Everything else that can be closed/opened acts randomly (especially annoyng with lots of child accounts under primary account).

    This is a stopper to migrate my small business to Zimbra.

    PS: the comment i made at.. https://bugzilla.zimbra.com/process_bug.cgi
    seems to hang on Fixed bug, sorry.. could anyone create a new bug correctly.. or how could i do it myself ?
    PS:PS: if i would try to fix this myself, where should i look in the source/or webserver files ?
    Last edited by smilodon; 03-09-2012 at 08:12 AM.

  6. #6
    smilodon is offline Starter Member
    Join Date
    Mar 2012
    Posts
    2
    Rep Power
    3

    Default

    Hi i have fixed the problem for myself.
    If anyone could open a bug report, i could attach some instruction on it how to fix it.

    Giving a hint what is actually wrong:
    The bug involves this line:
    Code:
    appCtxt.set(ZmSetting.ACCOUNT_TREE_OPEN, expanded, null, null, null, acct);
    In file Startup1_2_all.js
    The variable "acct" gets lost in settings saving procedures.
    And instead wrong account is used as Active Account to save ACCOUNT_TREE_OPEN expanded/closed status.

    Took me 2 days to learn javascript debugging with firebug, and finding the correct bug location and coming up with a fix for it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. auto generated distro lists
    By griffon in forum Administrators
    Replies: 4
    Last Post: 07-30-2010, 10:55 PM
  2. Replies: 2
    Last Post: 07-31-2007, 11:17 PM
  3. Auto timezone problem in calendar
    By kdunphy in forum Administrators
    Replies: 8
    Last Post: 03-19-2007, 05:54 PM
  4. Email Address Auto complete
    By mcavalieri in forum Users
    Replies: 5
    Last Post: 07-10-2006, 02:08 PM
  5. Email auto complete in 3.1 ?
    By sperkins in forum Administrators
    Replies: 2
    Last Post: 04-29-2006, 05:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •