Results 1 to 8 of 8

Thread: [SOLVED] Rename Individual Backups?

  1. #1
    godzilla8nj is offline Intermediate Member
    Join Date
    May 2007
    Posts
    24
    Rep Power
    8

    Default [SOLVED] Rename Individual Backups?

    Backing up individual mailbox per CLI - zmbackup Network Edition Only - Zimbra :: Wiki

    End up with full-20080107.165203.694. Can I rename it?

  2. #2
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    If you're moving it somewhere else then yes; if it's sitting in your /opt/zimbra/backup or whatever target you've specified I would just leave it.

  3. #3
    godzilla8nj is offline Intermediate Member
    Join Date
    May 2007
    Posts
    24
    Rep Power
    8

    Default

    Thank you for the fast response. Actually it and the automated backups are in /opt/zimbra/backup/ldap (by default?) My reason for creating it is the employee has left the company and we want a copy of the mailbox in case we later need anything from it. My intention was to leave it where it was created so the GUI could find it if I need to restore it, but I could move it if that is best practice. I just want it retrievable so I can delete the user. Suggestions?

  4. #4
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    as long as you can keep it out of the way of zmbackup -del crontab though...
    Last edited by mmorse; 01-07-2008 at 12:52 PM. Reason: just explain in a new post so they see the edit

  5. #5
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    You don't want it to get deleted on old backup cleanup which is why you might want to make a copy elsewhere.

  6. #6
    godzilla8nj is offline Intermediate Member
    Join Date
    May 2007
    Posts
    24
    Rep Power
    8

    Default

    I'll move it to subfolder so it isn't deleted. Many thanks.

  7. #7
    godzilla8nj is offline Intermediate Member
    Join Date
    May 2007
    Posts
    24
    Rep Power
    8

    Default

    Hmm, actually it isn't working as I thought. After I move it to /opt/zimbra/backups/archives/ and rename it shouldn't I be able to use the Admin GUI to restore it using "path to the backup targets is: /opt/zimbra/backups/archives/"? I get:
    Message: Could not find any backup labels for the specified account in the specified target
    Error code: backup.NO_LABELS_FOUND
    Method: SingleAccountRestoreXWizard.prototype.backupQueryC allBack

  8. #8
    godzilla8nj is offline Intermediate Member
    Join Date
    May 2007
    Posts
    24
    Rep Power
    8

    Default

    Disregard. I've simply developed a backup paradigm that works for us. (Oh, and it seems the ldap folder is a red herring, actual backups in sessions).

    # Switch to user Zimbra
    su zimbra
    # Create an archive folder for the account to be backed up (in this example user@test.com)
    mkdir /opt/zimbra/backup/archives/user
    # Run the backup
    # -z zips it up to save space
    # -f designates it a full backup
    # -s server
    # -a account
    # -t target (path)
    zmbackup -z -f -s mail.test.com -a user@test.com -t /opt/zimbra/backup/archives/user

    Then I just need to point the Admin GUI to the user's archive directory.
    Last edited by godzilla8nj; 01-07-2008 at 12:24 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Full and Incremental Backups occuring at same time...
    By mledford in forum Administrators
    Replies: 5
    Last Post: 01-24-2008, 10:59 PM
  2. Question about NE and Backups.
    By dougconley in forum Administrators
    Replies: 2
    Last Post: 12-18-2007, 12:56 AM
  3. Backups - Please review what I am doing
    By sternfan in forum Administrators
    Replies: 1
    Last Post: 12-13-2007, 04:36 PM
  4. Backups fail after workaround for bug 10827
    By warbirdcharles in forum Administrators
    Replies: 1
    Last Post: 07-17-2007, 12:07 PM
  5. How To Vet If Backups Are Working?
    By LMStone in forum Administrators
    Replies: 2
    Last Post: 03-19-2007, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •