Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 42

Thread: Instant Messaging

  1. #21
    davidfsmith is offline Special Member
    Join Date
    Jan 2007
    Location
    UK
    Posts
    160
    Rep Power
    8

    Default IM Clients

    Ok so I've managed to connect using the following IM Clients

    Adium
    Pidgin
    Trillian

    All using the relevant jabber connection / account options, however for some reason iChat doesn't want to play... anyone have any thoughts as to why this might be ?

  2. #22
    Mark Daniel's Avatar
    Mark Daniel is offline Senior Member
    Join Date
    May 2007
    Location
    Ferndale, MI
    Posts
    54
    Rep Power
    8

    Default iChat workin' for me!

    The fix I posted appears to carry over across restarts, FYI. Here's what I have for my iChat settings (all users are in the same domain, btw):

    jabber id: user@domain.com
    server: fqdn.oftheserver.com
    port: 5223 (√) use ssl
    ( ) auto discover server & port
    (√) warn before
    ( ) use kerberos

    location information shouldn't matter.
    mark daniel | actc
    zcs 6 ose | mac pro | mac os x server 10.4.11

  3. #23
    davidfsmith is offline Special Member
    Join Date
    Jan 2007
    Location
    UK
    Posts
    160
    Rep Power
    8

    Thumbs up

    Quote Originally Posted by Mark Daniel View Post
    The fix I posted appears to carry over across restarts, FYI. Here's what I have for my iChat settings (all users are in the same domain, btw):

    jabber id: user@domain.com
    server: fqdn.oftheserver.com
    port: 5223 (√) use ssl
    ( ) auto discover server & port
    (√) warn before
    ( ) use kerberos

    location information shouldn't matter.
    That works, probably about the only combination I hadn't tried.

    Magic
    ;-)

  4. #24
    jareep is offline Special Member
    Join Date
    Oct 2006
    Posts
    103
    Rep Power
    8

    Default

    What are the magical settings to connect via Pidgin 2.3.1? For instance, lets say I have port 5222 and 5223 on the firewall, my user name is test, my domain name is test.com, and my server name is im.test.com. I've tried everything I can think of and I keep getting a "Read Error".

    And fyi, I can telnet to both ports successfully...
    Last edited by jareep; 01-11-2008 at 11:05 AM.

  5. #25
    jareep is offline Special Member
    Join Date
    Oct 2006
    Posts
    103
    Rep Power
    8

    Default

    I download another client called Exodus and it seems to get a little further than Pidgin. When I connected with Exodus I got a prompt to save and accept the SSL certificate. I allowed it, and it continued connecting. I saw my buddy list for about a millisecond, then the connection was terminated. It auto-reconnected and same problem.

    Here is the log info:
    2008-01-11 13:24:12,668 INFO [SocketAcceptorIoProcessor-0.0] [] im - XMPP Session created: (SOCKET, R: /24.196.195.122:31231, L: /10.5.3.2:5222, S: 0.0.0.0/0.0.0.0:5222)
    2008-01-11 13:24:12,673 INFO [AnonymousIoService-11] [] im - Handshaking complete for client
    2008-01-11 13:24:13,943 ERROR [AnonymousIoService-14] [] im - Could not route packet
    java.lang.NullPointerException
    at com.zimbra.cs.account.Provisioning.onLocalServer(P rovisioning.java:1809)
    at com.zimbra.cs.im.provider.ZimbraRoutingTableImpl.g etCloudRoute(ZimbraRoutingTableImpl.java:100)
    at com.zimbra.cs.im.provider.ZimbraRoutingTableImpl.g etRoute(ZimbraRoutingTableImpl.java:128)
    at com.zimbra.cs.im.provider.ZimbraRoutingTableImpl.g etRoute(ZimbraRoutingTableImpl.java:93)
    at org.jivesoftware.wildfire.IQRouter.handle(IQRouter .java:223)
    at org.jivesoftware.wildfire.IQRouter.route(IQRouter. java:105)
    at org.jivesoftware.wildfire.spi.PacketRouterImpl.rou te(PacketRouterImpl.java:72)
    at org.jivesoftware.wildfire.net.SocketReader.process IQ(SocketReader.java:356)
    at org.jivesoftware.wildfire.net.ClientSocketReader.p rocessIQ(ClientSocketReader.java:62)
    at org.jivesoftware.wildfire.net.SocketReader.process (SocketReader.java:322)
    at org.jivesoftware.wildfire.net.NioReadingMode.proce ss(NioReadingMode.java:124)
    at org.jivesoftware.wildfire.net.NioReadingMode.nioRe adCompleted(NioReadingMode.java:171)
    at org.jivesoftware.wildfire.net.NioAcceptingMode$Nio IoHandlerAdapter.messageReceived(NioAcceptingMode. java:95)
    at org.apache.mina.common.support.AbstractIoFilterCha in$TailFilter.messageReceived(AbstractIoFilterChai n.java:703)
    at org.apache.mina.common.support.AbstractIoFilterCha in.callNextMessageReceived(AbstractIoFilterChain.j ava:362)
    at org.apache.mina.common.support.AbstractIoFilterCha in.access$1100(AbstractIoFilterChain.java:54)
    at org.apache.mina.common.support.AbstractIoFilterCha in$EntryImpl$1.messageReceived(AbstractIoFilterCha in.java:800)
    at org.apache.mina.filter.support.SSLHandler.flushPos tHandshakeEvents(SSLHandler.java:290)
    at org.apache.mina.filter.SSLFilter.messageReceived(S SLFilter.java:451)
    at org.apache.mina.common.support.AbstractIoFilterCha in.callNextMessageReceived(AbstractIoFilterChain.j ava:362)
    at org.apache.mina.common.support.AbstractIoFilterCha in.access$1100(AbstractIoFilterChain.java:54)
    at org.apache.mina.common.support.AbstractIoFilterCha in$EntryImpl$1.messageReceived(AbstractIoFilterCha in.java:800)
    at org.apache.mina.filter.executor.ExecutorFilter.pro cessEvent(ExecutorFilter.java:247)
    at org.apache.mina.filter.executor.ExecutorFilter$Pro cessEventsRunnable.run(ExecutorFilter.java:307)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run Task(ThreadPoolExecutor.java:885)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:907)
    at java.lang.Thread.run(Thread.java:619)
    2008-01-11 13:24:13,945 INFO [AnonymousIoService-14] [] im - XMPP Session closed: (SOCKET, R: /24.196.195.122:31231, L: /10.5.3.2:5222, S: 0.0.0.0/0.0.0.0:5222)

  6. #26
    jareep is offline Special Member
    Join Date
    Oct 2006
    Posts
    103
    Rep Power
    8

    Default

    Apparently, its a known bug? Bug 23521 - IM: NPE during initial startup

  7. #27
    folioguru is offline Partner (VAR/HSP)
    Join Date
    May 2007
    Location
    Los Angeles, California
    Posts
    71
    Rep Power
    8

    Default So, how do I IM from Zimbra

    OK, got IM up and running in Zimbra. So, what are the steps to use it?

    If, in Zimbra, I want to instant message someone on MSN, do I also need an MSN account? Or, is it that all I need is their MSN screen name entered into their contact profile?

    When my Zimbra IM screen comes up, there are now these two icons at the bottom: One for aol, the other for msn. When I put my cursor over one or the other, it says I am not logged into the service. Do I need to be logged into MSN in order to IM someone on MSN?

    What is the format of the screen name I should give someone on MSN/AOL to IM me on Zimbra?

    Thanks to anyone who can explain how this is supposed to work.

  8. #28
    sturgis is offline Senior Member
    Join Date
    Jan 2007
    Location
    France
    Posts
    71
    Rep Power
    8

    Default

    Quote Originally Posted by folioguru View Post
    OK, got IM up and running in Zimbra. So, what are the steps to use it?

    If, in Zimbra, I want to instant message someone on MSN, do I also need an MSN account? Or, is it that all I need is their MSN screen name entered into their contact profile?

    When my Zimbra IM screen comes up, there are now these two icons at the bottom: One for aol, the other for msn. When I put my cursor over one or the other, it says I am not logged into the service. Do I need to be logged into MSN in order to IM someone on MSN?

    What is the format of the screen name I should give someone on MSN/AOL to IM me on Zimbra?

    Thanks to anyone who can explain how this is supposed to work.
    Is there any wiki on how the IM works?
    I did what it is written in this thread and now I can add contacts, that's it.

    How does it work? Do I have to open these 2 ports in my firewall?
    Help

  9. #29
    mjanthony is offline New Member
    Join Date
    Feb 2008
    Posts
    3
    Rep Power
    7

    Default

    How do you remove that stupid Yahoo Icon (at the bottom right) within the Instant Messenger screen within the webui?

    Cheers!

    -- MJ.

  10. #30
    carlos.labarca's Avatar
    carlos.labarca is offline New Member
    Join Date
    Oct 2007
    Location
    Santiago de Chile
    Posts
    4
    Rep Power
    7

    Default

    Quote Originally Posted by jareep View Post
    What are the magical settings to connect via Pidgin 2.3.1? For instance, lets say I have port 5222 and 5223 on the firewall, my user name is test, my domain name is test.com, and my server name is im.test.com. I've tried everything I can think of and I keep getting a "Read Error".

    And fyi, I can telnet to both ports successfully...
    I had the same "Read Error",

    The problem is the connection parameters.

    It's worked for me:
    Pidgin version : Pidgin 2.3.1-1.fc8
    Protocol : XMPP
    User : carlos.labarca
    Domain : xxxxxx.xx
    (ssl checked)
    Port : 5222
    Server mail.xxxxxx.xx

    Good luck!

Page 3 of 5 FirstFirst 12345 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Instant Messaging
    By premoddev in forum Administrators
    Replies: 4
    Last Post: 07-27-2008, 06:12 AM
  2. Testing 5.0RC2 - How To Enable Instant Messaging?
    By Chewie71 in forum Administrators
    Replies: 20
    Last Post: 11-27-2007, 03:03 PM
  3. Instant Messaging
    By premoddev in forum Administrators
    Replies: 7
    Last Post: 01-05-2007, 05:07 AM
  4. Instant messaging
    By mansuper in forum Users
    Replies: 1
    Last Post: 08-09-2006, 07:28 AM
  5. Instant Messaging Integration...
    By sammie in forum Developers
    Replies: 3
    Last Post: 02-26-2006, 09:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •