Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: Big Fubar on 5 FOSS GA Upgrade

  1. #11
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Still! no joy so time to build a new VM me thinks.

  2. #12
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Bit if advice please but I mess things up. I have setup a new VM, and copied my existing /opt/zimbra into place. I have setup the zimbra and postfix user as per the original installation, and have also copied across /etc/init.d/zimbra. Do I need anything else from my original installation ? I have also stopped perl from being upgraded in the future but putting in a exception!

  3. #13
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    We haven't seen this in any of our test enviroments, so this is a bit strange.

    To restore your system, please use this PowerTip:
    http://www.zimbra.com/blog/archives/...er_server.html

  4. #14
    SpEnTBoY is offline Advanced Member
    Join Date
    Mar 2007
    Location
    Regina, Sask.
    Posts
    215
    Rep Power
    8

    Default

    Quote Originally Posted by uxbod View Post
    Argggh still failing with :-

    Updating from 5.0.0_RC3
    5 is only avaliable with the XS version at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30, <OUTPUT> line 3.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 970, <OUTPUT> line 3.

    and that bit of code is :-

    Code:
    # non-XS Versions of Scalar::Util will fail
    BEGIN{
        eval { use Scalar::Util 'dualvar'; dualvar(0,'') };
        die "You need the XS Version of Scalar::Util for dualvar() support"
            if $@;
    }
    How can I overcome this problem; any ideas ? I am sure others on RHEL4 will get the same problem when upgrading Perl. This is a real PIA
    THis is what I'm seeing right now too:

    Code:
    prov> prov> 5 is only avaliable with the XS version at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30, <DBCONFIG> line 16.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 970, <DBCONFIG> line 16.
    Not sure whats going on but it looks like I have to try a recovery

  5. #15
    SpEnTBoY is offline Advanced Member
    Join Date
    Mar 2007
    Location
    Regina, Sask.
    Posts
    215
    Rep Power
    8

    Default

    Well ... I did the force install of Scalar::Util and everything worked fine so I'm not sure where else you could keep troubleshooting for getting it working.

    Here's what I'm running now:

    2.6.18-53.1.4.el5.centos.plus
    CentOS release 5 (Final)
    Release 5.0.0_GA_1869.RHEL5_20071218205219 CentOS5 FOSS edition

  6. #16
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    I just built a new VM with CentOS 5.1 and have the same problem, so the broken Scalar must be in that version aswell. Just setting up another VM with the 5.0 CentOS release. Hopefully that will cure it. Certainly has been a interesting exercise! and my fiancee is needing her email back soon

    Well one good thing out of all of this, have learnt a lot about Zimbra

    Will keep you posted, but I bet a long night ahead.

  7. #17
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Well it fell in a heap again same problem. Just noticed SpEntBoY that you are running the RHEL5 version, where as I am trying to install the RHEL4 version. Hmmm, Wonder if there is a difference in the bundled Scalar::Util between these versions ?

  8. #18
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Yee Ha Up and running again. Applied all Centos5 patches, force install of Scalar::Util and switched from Zimbra RHEL4 too RHEL5.

    When upgrading between versions just had to ensure I removed what was under /opt/zimbra/zimbramon/lib/i386-linux-thread-multi so that the RHEL4 version of Scalar was not in the Perl include PATH.

    All looks great now apart from "From" saying "step 3."

  9. #19
    SpEnTBoY is offline Advanced Member
    Join Date
    Mar 2007
    Location
    Regina, Sask.
    Posts
    215
    Rep Power
    8

    Default

    Quote Originally Posted by uxbod View Post
    Yee Ha Up and running again. Applied all Centos5 patches, force install of Scalar::Util and switched from Zimbra RHEL4 too RHEL5.

    When upgrading between versions just had to ensure I removed what was under /opt/zimbra/zimbramon/lib/i386-linux-thread-multi so that the RHEL4 version of Scalar was not in the Perl include PATH.

    All looks great now apart from "From" saying "step 3."
    Gah sorry I never responded sooner (I know what it's like to have something not working) either way glad you're up and running!!

  10. #20
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Thanks to all for your help though. It did steer me in the right direction. Sometimes the smallest problems are the biggest to solve.

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 10-04-2007, 03:20 PM
  2. Replies: 4
    Last Post: 07-18-2007, 03:51 PM
  3. failed upgrade, failed restore, big trouble
    By feralcoder in forum Installation
    Replies: 2
    Last Post: 03-19-2007, 05:38 PM
  4. M1 -> M2 Upgrade Scripts
    By KevinH in forum Announcements
    Replies: 57
    Last Post: 12-15-2005, 10:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •