Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: [SOLVED] Integration with Mailman

  1. #1
    amitbapat is offline Intermediate Member
    Join Date
    Jan 2006
    Posts
    19
    Rep Power
    9

    Exclamation [SOLVED] Integration with Mailman

    I am trying to integrate Zimbra Postfix with Mailman and I'm stuck.

    Here is an excerpt from Mailman installation guide :

    First, you need to set up the Postfix virtual alias domains as described in the Postfix documentation (see Postfix's virtual(5) manpage). Note that it's your responsibility to include the virtual-alias.domain anything line as described manpage; Mailman will not include this line in virtual-mailman. You are highly encouraged to make sure your virtual alias domains are working properly before integrating with Mailman.
    I know that there is already a virtual_alias_maps table setup (with ldap lookup, in Zimbra Postfix). What I could not understand is the comment about "virtual-alias.doman anything" entry.

    Has anybody tried integrating mailman with Zimbra?

  2. #2
    amitbapat is offline Intermediate Member
    Join Date
    Jan 2006
    Posts
    19
    Rep Power
    9

    Default Progress so far

    I have added following to main.cf of postfix:
    Code:
    virtual_alias_maps = ldap:/opt/zimbra/conf/ldap-vam.cf,hash:/etc/mailman/virtual-mailman
    alias_maps = hash:/etc/aliases,hash:/etc/mailman/aliases
    /etc/mailman/virtual-mailman contains:
    Code:
    testlist@domain.com              testlist
    testlist-admin@domain.com        testlist-admin
    testlist-bounces@domain.com      testlist-bounces
    testlist-confirm@domain.com      testlist-confirm
    testlist-join@domain.com         testlist-join
    testlist-leave@domain.com        testlist-leave
    testlist-owner@domain.com        testlist-owner
    testlist-request@domain.com      testlist-request
    testlist-subscribe@domain.com    testlist-subscribe
    testlist-unsubscribe@domain.com  testlist-unsubscribe
    /etc/mailman/aliases contains:
    Code:
    testlist:             "|/usr/lib/mailman/mail/mailman post testlist"
    testlist-admin:       "|/usr/lib/mailman/mail/mailman admin testlist"
    testlist-bounces:     "|/usr/lib/mailman/mail/mailman bounces testlist"
    testlist-confirm:     "|/usr/lib/mailman/mail/mailman confirm testlist"
    testlist-join:        "|/usr/lib/mailman/mail/mailman join testlist"
    testlist-leave:       "|/usr/lib/mailman/mail/mailman leave testlist"
    testlist-owner:       "|/usr/lib/mailman/mail/mailman owner testlist"
    testlist-request:     "|/usr/lib/mailman/mail/mailman request testlist"
    testlist-subscribe:   "|/usr/lib/mailman/mail/mailman subscribe testlist"
    testlist-unsubscribe: "|/usr/lib/mailman/mail/mailman unsubscribe testlist"

    $myhostname is "linux.lan" which is not a FQDN. I am hosting domain.com and domain2.com as two virtual domains. "linux.lan" is also added as domain in zimbra.

    testlist@domain.com gets correctly translated to testlist@linux.lan because of virtual_alias_map entry in the 'virtual-mailman' file.

    However, instead of delivering "testlist@linux.lan" locally using the alias_maps, postfix bounces it.

    What am I doing wrong?

  3. #3
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default logged error?

    What's it logging when it bounces the message? Do you have dns enabled?

  4. #4
    amitbapat is offline Intermediate Member
    Join Date
    Jan 2006
    Posts
    19
    Rep Power
    9

    Default Postfix Log

    Here's what I see in /var/log/zimbra.log
    Code:
    Jan 13 15:04:53 linux postfix/smtpd[22122]: initializing the server-side TLS engine
    Jan 13 15:04:53 linux postfix/smtpd[22122]: connect from zproxy.wundermail.com[X.X.X.X]
    Jan 13 15:04:54 linux postfix/smtpd[22122]: 397FF212569: client=zproxy.wundermail.com[X.X.X.X]
    Jan 13 15:04:54 linux postfix/cleanup[22126]: 397FF212569: message-id=<5af329be0601131504p27b22979ue1e8d75792553
    1eb@mail.wundermail.com>
    Jan 13 15:04:54 linux postfix/qmgr[28815]: 397FF212569: from=<sender@wundermail.com>, size=1666, nrcpt=1 (queue 
    ac
    tive)
    Jan 13 15:04:54 linux amavis[20246]: (20246-02) ESMTP::10024 /opt/zimbra/amavisd/tmp/amavis-20060113T140002-2024
    6: <sender@wundermail.com> -> <testlist@linux.lan> Received: SIZE=1666 from linux.lan ([127.0.0.1]) by localho 
    st (linux.lan [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 20246-02 for <testlist@linux.lan>; Fri, 1
    3 Jan 2006 15:04:54 -0800 (PST)
    Jan 13 15:04:54 linux amavis[20246]: (20246-02) Checking: lho4XkAzQjYk [64.233.162.195] <sender@wundermail.com> 
    ->
     <testlist@linux.lan> 
    Jan 13 15:04:54 linux clamd[20640]: SelfCheck: Database status OK. 
    Jan 13 15:04:55 linux postfix/smtpd[22131]: initializing the server-side TLS engine
    Jan 13 15:04:55 linux postfix/smtpd[22131]: connect from localhost.localdomain[127.0.0.1]
    Jan 13 15:04:55 linux postfix/smtpd[22131]: 95BFE21256B: client=localhost.localdomain[127.0.0.1]
    Jan 13 15:04:55 linux postfix/cleanup[22126]: 95BFE21256B: message-id=<5af329be0601131504p27b22979ue1e8d75792553
    1eb@mail.wundermail.com>
    Jan 13 15:04:55 linux postfix/qmgr[28815]: 95BFE21256B: from=<sender@wundermail.com>, size=2318, nrcpt=1 (queue 
    ac
    tive)
    Jan 13 15:04:55 linux amavis[20246]: (20246-02) FWD via SMTP: <sender@wundermail.com> -> <testlist@linux.lan>, 2
    50 2.6.0 Ok, id=20246-02, from MTA([127.0.0.1]:10025): 250 Ok: queued as 95BFE21256B
    Jan 13 15:04:55 linux amavis[20246]: (20246-02) Passed CLEAN, [64.233.162.195] [64.233.162.195] <sender@wundermail.com> -> <testlist@linux.lan>, Message-ID: <5af329be0601131504p27b22979ue1e8d757925531eb@mail.wundermail.com>, mail_id: lho4XkAzQjYk, Hits: -2.009, 1234 ms
    Jan 13 15:04:55 linux amavis[20246]: (20246-02) extra modules loaded: Net/LDAP/Bind.pm
    Jan 13 15:04:55 linux postfix/smtpd[22131]: disconnect from localhost.localdomain[127.0.0.1]
    Jan 13 15:04:55 linux postfix/smtp[22127]: 397FF212569: to=<testlist@linux.lan>, orig_to=<testlist@domain.com>,
     relay=127.0.0.1[127.0.0.1], delay=1, status=sent (250 2.6.0 Ok, id=20246-02, from MTA([127.0.0.1]:10025): 250 O
    k: queued as 95BFE21256B)
    Jan 13 15:04:55 linux postfix/qmgr[28815]: 397FF212569: removed 
    Jan 13 15:04:55 linux postfix/error[22132]: 95BFE21256B: to=<testlist@linux.lan>, relay=none, delay=0, status=
    bounced (linux.lan)
    Jan 13 15:04:55 linux postfix/cleanup[22126]: C063421256C: message-id=<20060113230455.C063421256C@linux.lan>Jan 13 15:04:55 linux postfix/qmgr[28815]: C063421256C: from=<>, size=3889, nrcpt=1 (queue active)Jan 13 15:04:55 linux postfix/qmgr[28815]: 95BFE21256B: removed
    Jan 13 15:04:57 linux postfix/smtp[22135]: C063421256C: to=<sender@wundermail.com>, relay=wundermail-smtp-in.l.g
    oogle.com[66.249.83.27], delay=2, status=sent (250 2.0.0 OK 1137193497 i19si4153614wxd)Jan 13 15:04:57 linux postfix/qmgr[28815]: C063421256C: removed
    I have fudged email address to protect privacy.
    sender@wundermail.com is the sender from outside.
    testlist@domain.com is the mailing list I have created in mailman as described in the first post.

  5. #5
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default Dns

    And, do you have DNS enabled on the MTA?

  6. #6
    amitbapat is offline Intermediate Member
    Join Date
    Jan 2006
    Posts
    19
    Rep Power
    9

    Default Dns

    I am running a local DNS server for .lan zone on another linux machine on the intranet. This DNS also works as a cacheing name server.
    Here's linux.lan's /etc/resolve.conf
    Code:
    search lan
    nameserver 192.168.11.1
    Running dig on linux.lan would yield following:
    Code:
    # dig linux.lan
    ; <<>> DiG 9.3.1 <<>> linux.lan
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4786
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;linux.lan.                     IN      A
    
    ;; ANSWER SECTION:
    linux.lan.              86400   IN      A       192.168.11.3
    
    ;; AUTHORITY SECTION:
    lan.                    86400   IN      NS      gateway.lan.
    
    ;; ADDITIONAL SECTION:
    gateway.lan.               86400   IN      A       192.168.11.1
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.11.1#53(192.168.11.1)
    ;; WHEN: Fri Jan 13 15:44:02 2006
    ;; MSG SIZE  rcvd: 80

  7. #7
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default MX record?

    If you want to send mail to the domain, you should add an MX record to your DNS server.

    Also - does this account testlist@linux.lan exist anywhere?

  8. #8
    amitbapat is offline Intermediate Member
    Join Date
    Jan 2006
    Posts
    19
    Rep Power
    9

    Default testlist

    No testlist@linux.lan only exists in the virtual_alias_maps, that is /etc/mailman/virtual-mailman.

    Let me try adding MX to my DNS and see.

  9. #9
    amitbapat is offline Intermediate Member
    Join Date
    Jan 2006
    Posts
    19
    Rep Power
    9

    Default how about removing linux.lan domain from Zimbra

    I really don't need to receive mail for linux.lan. All my real accounts are on domain.com and domain2.com. I only created linux.lan domain in Zimbra because that was the default option when I installed.

    What if I remove the linux.lan domain from zimbra and move the Zimbra SPAM and Zimbra HAM account from the linux.lan domain to domain.com?

    Will that force postfix to deliver mail for linux.lan locally? Because then there would be no entry for linux.lan in virtual_mailbox_domains and postfix will be forced to use local_recipient_maps to deliver.

    Here's my thinking, let me know if it is correct:

    on a RCPT TO: address, postfix searches virtual_alias_domains, virtual_mailbox_domains. Since linux.lan won't be there it'll try to match it to myhostname which happens to be linux.lan so it'll match.

    and since local_transport is set to local:$myhostname, now postfix will be forced to deliver testlist@linux.lan locally.

    Is that correct?

  10. #10
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default postfix

    afaik, that's correct. I assume that it's bouncing it because there's no such account in it's recipient table (in ldap).

    So, I'm not sure what kind of expansion testlist@linux.lan is supposed to undergo, or where the email is ultimately supposed to be delivered - but it appears that that expansion is not happening.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Zimbra+Mailman Howto
    By amitbapat in forum Administrators
    Replies: 59
    Last Post: 04-03-2013, 02:31 AM
  2. mailman integration problems -- still
    By BilldaCat in forum Administrators
    Replies: 2
    Last Post: 11-01-2006, 02:30 PM
  3. mailman integration problems
    By BilldaCat in forum Administrators
    Replies: 4
    Last Post: 08-14-2006, 09:04 AM
  4. Tomcat hanging
    By Morg0 in forum Administrators
    Replies: 42
    Last Post: 04-19-2006, 08:06 PM
  5. mta and mailbox die
    By Morg0 in forum Administrators
    Replies: 5
    Last Post: 03-20-2006, 04:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •