Results 1 to 10 of 10

Thread: dspam settings

  1. #1
    ronsterchan is offline Junior Member
    Join Date
    Mar 2007
    Posts
    8
    Rep Power
    8

    Default dspam settings

    Hello

    I have dspam switched on but some messages marked as spam is still coming through, are there other settings I need to make? For example this is in the header of one of the spam messages that still came through.

    X-DSPAM-Result: Spam
    X-DSPAM-Confidence: 0.7016
    X-DSPAM-Probability: 1.0000

    Thanks
    Ron

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Hi Ron,
    May I ask how you enabled it?

  3. #3
    ronsterchan is offline Junior Member
    Join Date
    Mar 2007
    Posts
    8
    Rep Power
    8

    Default

    uncomment this line

    #$dspam = '/opt/zimbra/dspam/bin/dspam';

    in amavisd.conf

  4. #4
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Yeah, I don't know. We don't use DSPAM anymore, so it might be that it's just becoming abandonware.

  5. #5
    Krishopper is offline Dedicated Member
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    775
    Rep Power
    9

    Default

    Quote Originally Posted by ronsterchan View Post
    uncomment this line

    #$dspam = '/opt/zimbra/dspam/bin/dspam';

    in amavisd.conf
    Uncomment it in amavisd.conf.in, as amavisd.conf gets re-written every time Zimbra is stop/started.

    Check your spam score in the headers. Spam classification is not entirely based on dspam, as SpamAssassin scores are considered.

    For example:

    X-Spam-Status: Yes, score=14.823 tagged_above=-10 required=6.6
    tests=[BAYES_50=0.001, DSPAM_SPAM=4.5, HTML_IMAGE_ONLY_20=1.546,
    HTML_MESSAGE=0.001, MIME_HTML_ONLY=1.457, RCVD_IN_BL_SPAMCOP_NET=1.96,
    RCVD_IN_PBL=0.905, RCVD_IN_SORBS_DUL=0.877, RCVD_IN_XBL=3.033,
    TVD_FW_GRAPHIC_NAME_MID=0.543]

    I bumped my DSPAM_SPAM score up to 4.5 from the default of 1.5 and found things to work a lot better (within salocal.conf.in).

  6. #6
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Nice catch Kris!

  7. #7
    Krishopper is offline Dedicated Member
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    775
    Rep Power
    9

    Default

    Well, on this note *sigh* I upgraded from 4.5.8 to 4.5.10 last night and now dspam is not running for me, either.

    Uncommented it in amavisd.conf.in, restarted Zimbra, and it's uncommented in amavisd.conf

    So I don't know? dspam is one of the things that helps my spam filtering a ton, and Zimbra won't let me use it.

  8. #8
    Krishopper is offline Dedicated Member
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    775
    Rep Power
    9

    Default

    Looks like dspam still requires a "chown -R zimbra:zimbra dspam-3.6.2" after install.

    That got mine working again.

  9. #9
    maerten is offline Awaiting Activation
    Join Date
    Aug 2007
    Posts
    12
    Rep Power
    0

    Default

    I thinks that since version 4.5.10, you must make dspam readable and executable as root:
    chmod a+rx /opt/zimbra/dspam/bin/dspam

  10. #10
    maerten is offline Awaiting Activation
    Join Date
    Aug 2007
    Posts
    12
    Rep Power
    0

    Default

    The above solution doesn't work, you really have to change the ownership like "Krishopper" said.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. dspam broke after 4.5.7 upgrade?
    By Krishopper in forum Administrators
    Replies: 9
    Last Post: 09-24-2007, 08:07 AM
  2. Configuring and using DSPAM
    By JoshuaPrismon in forum Administrators
    Replies: 55
    Last Post: 03-02-2007, 09:08 AM
  3. Per user spamassassin settings possible?
    By redhat in forum Administrators
    Replies: 1
    Last Post: 08-11-2006, 03:51 PM
  4. Rewrote zmtrainsa for DSPAM
    By unilogic in forum Developers
    Replies: 18
    Last Post: 01-12-2006, 06:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •